summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlphaJack2021-01-09 12:31:21 +0100
committerAlphaJack2021-01-09 12:31:21 +0100
commitf15471dc76d8011ca2cc0c214749d410c89fdd5b (patch)
tree6e74c40ad245126601a24914ce544d7d6b168dbd
parent5cf0ad8f946f1342a24064d8540b008a1da9cb98 (diff)
downloadaur-f15471dc76d8011ca2cc0c214749d410c89fdd5b.tar.gz
Moved perl and python2 to optdepends array
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
2 files changed, 14 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bca629ed547c..1adfbb4a5aac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,13 +14,13 @@ pkgbase = ices0
depends = lame
depends = libxml2
depends = libshout
- depends = perl
- depends = python2
optdepends = flac: flac audio support
optdepends = faad2: aac audio support
optdepends = libmp4v2: aac audio support
optdepends = libogg: vorbis audio support
optdepends = libvorbis: vorbis audio support
+ optdepends = perl: playlist scripting engine
+ optdepends = python2: playlist scripting engine
options = !docs
source = https://github.com/Moonbase59/ices0/archive/v0.4.11.tar.gz
sha256sums = 9179496149e763a75fea37bf6ec12947cad4bdb868b401d34728b353b836047a
diff --git a/PKGBUILD b/PKGBUILD
index c2980dda3cd1..e253c3827f02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,12 +10,14 @@ pkgdesc="A source client for broadcasting in MP3, FLAC, AAC and OGG Vorbis forma
license=("GPL2")
arch=("i686" "x86_64" "armv7h")
url="https://github.com/Moonbase59/ices0"
-depends=("lame" "libxml2" "libshout" "perl" "python2")
+depends=("lame" "libxml2" "libshout")
optdepends=("flac: flac audio support"
"faad2: aac audio support"
"libmp4v2: aac audio support"
"libogg: vorbis audio support"
- "libvorbis: vorbis audio support")
+ "libvorbis: vorbis audio support"
+ "perl: playlist scripting engine"
+ "python2: playlist scripting engine")
makedepends=("autoconf" "automake" "pkgconf")
source=("$url/archive/v$pkgver.tar.gz")
sha256sums=("9179496149e763a75fea37bf6ec12947cad4bdb868b401d34728b353b836047a")
@@ -27,8 +29,14 @@ build(){
aclocal
autoreconf -fi
automake --add-missing
- ./configure --prefix="/usr" --sysconfdir="/usr/share/$pkgname" -mandir="/usr/share" \
- --with-python="/usr/bin/python2"
+ if [ -f "/usr/bin/python2" ]; then
+ ./configure --prefix="/usr" --sysconfdir="/usr/share/$pkgname" -mandir="/usr/share" --with-python="/usr/bin/python2"
+ else
+ ./configure --prefix="/usr" --sysconfdir="/usr/share/$pkgname" -mandir="/usr/share"
+ fi
+ echo "Please check that all the features you want are available, otherwise install optional dependencies"
+ echo "Waiting 10 seconds"
+ sleep 10
make
}