summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsuperlex2015-06-11 16:10:50 +0200
committersuperlex2015-06-11 16:10:50 +0200
commitbb312071e25298313fcb5f923f2292dde1c25d40 (patch)
treede5c58351eeacfff01e735740446d4951b33a22b
downloadaur-bb312071e25298313fcb5f923f2292dde1c25d40.tar.gz
Initial import
-rw-r--r--.SRCINFO71
-rw-r--r--PKGBUILD178
-rw-r--r--iceweasel-20.0.1-fixed-loading-icon.pngbin0 -> 12184 bytes
-rw-r--r--iceweasel-install-dir.patch13
-rw-r--r--iceweasel.desktop105
-rw-r--r--iceweasel.install13
-rw-r--r--mozconfig43
-rw-r--r--vendor.js15
8 files changed, 438 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4ee13d584475
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,71 @@
+pkgbase = iceweasel
+ pkgdesc = Debian Browser based on Mozilla Firefox
+ pkgver = 38.0.1.deb5
+ pkgrel = 2
+ url = https://packages.debian.org/source/sid/iceweasel
+ install = iceweasel.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = MPL
+ license = LGPL
+ makedepends = unzip
+ makedepends = zip
+ makedepends = diffutils
+ makedepends = python2
+ makedepends = yasm
+ makedepends = mesa
+ makedepends = imake
+ makedepends = libpulse
+ makedepends = gst-plugins-base-libs
+ makedepends = inetutils
+ makedepends = quilt
+ makedepends = pkg-config
+ makedepends = nss>=3.18.1
+ makedepends = libidl2
+ makedepends = librsvg
+ makedepends = libxslt
+ makedepends = autoconf2.13
+ makedepends = imagemagick
+ depends = gtk2
+ depends = mozilla-common
+ depends = libxt
+ depends = startup-notification
+ depends = mime-types
+ depends = dbus-glib
+ depends = alsa-lib
+ depends = desktop-file-utils
+ depends = hicolor-icon-theme
+ depends = libvpx
+ depends = icu
+ depends = libevent
+ depends = nss
+ depends = hunspell
+ depends = sqlite
+ optdepends = networkmanager: Location detection via available WiFi networks
+ optdepends = gst-plugins-good: h.264 video
+ optdepends = gst-libav: h.264 video
+ optdepends = upower: Battery API
+ optdepends = iceweasel-extension-archsearch: Iceweasel Arch search engines
+ optdepends = iceweasel-extension-archforumsearch-it: Iceweasel search engines for Arch Linux Italian forum
+ provides = iceweasel=38.0.1
+ options = !emptydirs
+ options = !makeflags
+ options = debug
+ source = http://ftp.debian.org/debian/pool/main/i//iceweasel/iceweasel_38.0.1.orig.tar.bz2
+ source = http://ftp.debian.org/debian/pool/main/i//iceweasel/iceweasel_38.0.1-5.debian.tar.xz
+ source = mozconfig
+ source = iceweasel.desktop
+ source = iceweasel-install-dir.patch
+ source = vendor.js
+ source = iceweasel-20.0.1-fixed-loading-icon.png
+ md5sums = 9a29fca249e533da2252097f3da2c3ce
+ md5sums = 132801eddc1729a8c0b5bb3fb5b347df
+ md5sums = 1040e0c5613128fb54f4134e486b37b7
+ md5sums = 7b9e5996dd9fe0b186a43a297db1c6b5
+ md5sums = 1c42509891cf6843660a5f3c69896e80
+ md5sums = ced8f3b950fb819e784415e61ec91bb1
+ md5sums = 6e335a517c68488941340ee1c23f97b0
+
+pkgname = iceweasel
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2dc7a9a178f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,178 @@
+# Maintainer: superlex
+
+# Based on Parabola GNU/Linux iceweasel-libre PKGBUILD :
+
+# Contributor (ConnochaetOS): Henry Jensen <hjensen@connochaetos.org>
+# Contributor (Parabola): Luke Shumaker <lukeshu@sbcglobal.net>
+# Contributor: Figue <ffigue at gmail>
+# Contributor (Parabola): fauno <fauno@kiwwwi.com.ar>
+# Contributor (Parabola): vando <facundo@esdebian.org>
+# Contributor (Parabola): André Silva <emulatorman@lavabit.com>
+# Contributor (Parabola): Márcio Silva <coadde@lavabit.com>
+# Contributor (Arch): Jakub Schmidtke <sjakub@gmail.com>
+# Thank you very much to the older contributors:
+# Contributor: evr <evanroman at gmail>
+# Contributor: Muhammad 'MJ' Jassim <UnbreakableMJ@gmail.com>
+
+# Firefox PKGBUILD (Arch Linux):
+
+# Maintainer : Ionut Biru <ibiru@archlinux.org>
+# Contributor: Jakub Schmidtke <sjakub@gmail.com>
+
+_pgo=false
+
+# We're getting this from Debian Sid
+_debname=iceweasel
+_debver=38.0.1
+_debrel=5
+_debrepo=http://ftp.debian.org/debian/pool/main/i/
+
+pkgname=iceweasel
+pkgver=$_debver.deb$_debrel
+pkgrel=2
+pkgdesc="Debian Browser based on Mozilla Firefox"
+arch=('i686' 'x86_64')
+license=('GPL' 'MPL' 'LGPL')
+depends=('gtk2' 'mozilla-common' 'libxt' 'startup-notification' 'mime-types' 'dbus-glib' 'alsa-lib' 'desktop-file-utils' 'hicolor-icon-theme' 'libvpx' 'icu' 'libevent' 'nss' 'hunspell' 'sqlite')
+makedepends=('unzip' 'zip' 'diffutils' 'python2' 'yasm' 'mesa' 'imake' 'libpulse' 'gst-plugins-base-libs' 'inetutils' 'quilt' 'pkg-config' 'nss>=3.18.1' 'libidl2' 'librsvg' 'libxslt' 'autoconf2.13' 'imagemagick')
+
+options=(!emptydirs !makeflags debug)
+if $_pgo; then
+ makedepends+=(xorg-server-xvfb)
+ options+=(!ccache)
+fi
+
+optdepends=('networkmanager: Location detection via available WiFi networks'
+ 'gst-plugins-good: h.264 video'
+ 'gst-libav: h.264 video'
+ 'upower: Battery API'
+ 'iceweasel-extension-archsearch: Iceweasel Arch search engines'
+ 'iceweasel-extension-archforumsearch-it: Iceweasel search engines for Arch Linux Italian forum')
+url="https://packages.debian.org/source/sid/iceweasel"
+install=iceweasel.install
+provides=("$_debname"="$_debver")
+source=("${_debrepo}/${_debname}/${_debname}_${_debver}.orig.tar.bz2"
+ "${_debrepo}/${_debname}/${_debname}_${_debver}-${_debrel}.debian.tar.xz"
+ 'mozconfig'
+ 'iceweasel.desktop'
+ 'iceweasel-install-dir.patch'
+ 'vendor.js'
+ 'iceweasel-20.0.1-fixed-loading-icon.png')
+md5sums=('9a29fca249e533da2252097f3da2c3ce'
+ '132801eddc1729a8c0b5bb3fb5b347df'
+ '1040e0c5613128fb54f4134e486b37b7'
+ '7b9e5996dd9fe0b186a43a297db1c6b5'
+ '1c42509891cf6843660a5f3c69896e80'
+ 'ced8f3b950fb819e784415e61ec91bb1'
+ '6e335a517c68488941340ee1c23f97b0')
+
+prepare() {
+ export DEBIAN_BUILD="mozilla-release"
+
+ export QUILT_PATCHES=debian/patches
+ export QUILT_REFRESH_ARGS='-p ab --no-timestamps --no-index'
+ export QUILT_DIFF_ARGS='--no-timestamps'
+
+ mv debian "$srcdir/$DEBIAN_BUILD"
+ cd "$srcdir/$DEBIAN_BUILD"
+
+ # We wont save user profile in .mozilla/iceweasel
+ sed -i 's/MOZ_APP_PROFILE=mozilla\/firefox/MOZ_APP_PROFILE=mozilla\/iceweasel/g' "debian/branding/configure.sh"
+
+ # Doesn't apply and seems unimportant
+ rm -v debian/patches/l10n/Place-google-and-gmail-before-yandex.patch || true
+
+ quilt push -av
+
+ # Install to /usr/lib/$pkgname
+ patch -Np1 -i "$srcdir/iceweasel-install-dir.patch"
+
+ # Load our build config
+ cp "$srcdir/mozconfig" .mozconfig
+
+ mkdir "$srcdir/python2-path"
+
+ # WebRTC build tries to execute "python" and expects Python 2
+ ln -s /usr/bin/python2 "$srcdir/python2-path/python"
+
+ # configure script misdetects the preprocessor without an optimization level
+ # https://bugs.archlinux.org/task/34644
+ sed -i '/ac_cpp=/s/$CPPFLAGS/& -O2/' configure
+
+ # Fix tab loading icon (flickers with libpng 1.6)
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=841734
+ cp "$srcdir/iceweasel-20.0.1-fixed-loading-icon.png" \
+ browser/themes/linux/tabbrowser/loading.png
+}
+
+build() {
+ export DEBIAN_BUILD="mozilla-release"
+
+ cd "$srcdir/$DEBIAN_BUILD"
+
+ export PATH="$srcdir/python2-path:$PATH"
+ export PYTHON="/usr/bin/python2"
+
+ if $_pgo; then
+ xvfb-run -a -s "-extension GLX -screen 0 1280x1024x24" \
+ make -f client.mk build MOZ_PGO=1
+ else
+ make -f client.mk build
+ fi
+}
+
+package() {
+ export DEBIAN_BUILD="mozilla-release"
+
+ cd "$srcdir/$DEBIAN_BUILD"
+ make -f client.mk DESTDIR="$pkgdir" INSTALL_SDK= install
+
+ install -Dm644 ../vendor.js "$pkgdir/usr/lib/$pkgname/browser/defaults/preferences/vendor.js"
+
+ _brandingdir=debian/branding
+ brandingdir=moz-objdir/$_brandingdir
+ icondir="$pkgdir/usr/share/icons/hicolor"
+ for i in 16x16 32x32 48x48 64x64; do
+ install -Dm644 "$brandingdir/default${i/x*/}.png" "$icondir/$i/apps/$pkgname.png"
+ done
+ install -Dm644 "$brandingdir/mozicon128.png" "$icondir/128x128/apps/$pkgname.png"
+ install -Dm644 "$_brandingdir/iceweasel_icon.svg" "$icondir/scalable/apps/$pkgname.svg"
+
+ install -d "$pkgdir/usr/share/applications"
+ install -m644 "$srcdir/iceweasel.desktop" "$pkgdir/usr/share/applications"
+
+
+ # Use system-provided dictionaries
+ rm -rf "$pkgdir/usr/lib/$pkgname/"{dictionaries,hyphenation}
+ ln -sf /usr/share/hunspell "$pkgdir/usr/lib/$pkgname/dictionaries"
+ ln -sf /usr/share/hyphen "$pkgdir/usr/lib/$pkgname/hyphenation"
+
+
+ # We don't want the development stuff
+ rm -rf "$pkgdir"/usr/{include,lib/$pkgname-devel,share/idl}
+
+ # Workaround for now: https://bugzilla.mozilla.org/show_bug.cgi?id=658850
+ ln -sf $pkgname "$pkgdir/usr/lib/$pkgname/$pkgname-bin"
+
+
+ # Remove $srcdir refers
+ sed -i '1d' "$pkgdir/usr/lib/$pkgname/defaults/pref/channel-prefs.js"
+
+
+
+ # Searchplugins section
+
+ # According to debian choices, we prefer to use /etc/icewasel/searchplugins
+ install -d "$pkgdir/etc/${pkgname}/searchplugins/common"
+ install -d "$pkgdir/etc/${pkgname}/searchplugins/locale"
+
+ # Add common web searchplugins
+ # install -Dm644 "$srcdir/$DEBIAN_BUILD/debian/duckduckgo.xml" "$pkgdir/etc/${pkgname}/searchplugins/common/duckduckgo.xml"
+ install -Dm644 "$srcdir/$DEBIAN_BUILD/debian/debsearch.xml" "$pkgdir/etc/${pkgname}/searchplugins/common/debsearch.xml"
+
+ # Add web searchplugins for default locale (en-US)
+ cp -R "$pkgdir/usr/lib/$pkgname/browser/searchplugins" "$pkgdir/etc/${pkgname}/searchplugins/locale/en-US"
+
+ rm -rv "$pkgdir/usr/lib/$pkgname/browser/searchplugins"
+}
+
diff --git a/iceweasel-20.0.1-fixed-loading-icon.png b/iceweasel-20.0.1-fixed-loading-icon.png
new file mode 100644
index 000000000000..55f25e591ff5
--- /dev/null
+++ b/iceweasel-20.0.1-fixed-loading-icon.png
Binary files differ
diff --git a/iceweasel-install-dir.patch b/iceweasel-install-dir.patch
new file mode 100644
index 000000000000..af113fa85173
--- /dev/null
+++ b/iceweasel-install-dir.patch
@@ -0,0 +1,13 @@
+diff --git a/config/baseconfig.mk b/config/baseconfig.mk
+index 7ca8e35..6e92846 100644
+--- a/config/baseconfig.mk
++++ b/config/baseconfig.mk
+@@ -5,7 +5,7 @@
+ MOZ_APP_BASE_VERSION = $(firstword $(subst ., ,$(MOZ_APP_VERSION))).$(word 2,$(subst ., ,$(MOZ_APP_VERSION)))
+ includedir := $(includedir)/$(MOZ_APP_NAME)-$(MOZ_APP_BASE_VERSION)
+ idldir = $(datadir)/idl/$(MOZ_APP_NAME)-$(MOZ_APP_BASE_VERSION)
+-installdir = $(libdir)/$(MOZ_APP_NAME)-$(MOZ_APP_BASE_VERSION)
++installdir = $(libdir)/$(MOZ_APP_NAME)
+ sdkdir = $(libdir)/$(MOZ_APP_NAME)-devel-$(MOZ_APP_BASE_VERSION)
+ ifndef TOP_DIST
+ TOP_DIST = dist
diff --git a/iceweasel.desktop b/iceweasel.desktop
new file mode 100644
index 000000000000..c4a338cc6865
--- /dev/null
+++ b/iceweasel.desktop
@@ -0,0 +1,105 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Iceweasel
+Name[bg]=Iceweasel
+Name[ca]=Iceweasel
+Name[cs]=Iceweasel
+Name[el]=Iceweasel
+Name[es]=Iceweasel
+Name[fa]=Iceweasel
+Name[fi]=Iceweasel
+Name[fr]=Iceweasel
+Name[hu]=Iceweasel
+Name[it]=Iceweasel
+Name[ja]=Iceweasel
+Name[ko]=Iceweasel
+Name[nb]=Iceweasel
+Name[nl]=Iceweasel
+Name[nn]=Iceweasel
+Name[no]=Iceweasel
+Name[pl]=Iceweasel
+Name[pt]=Iceweasel
+Name[pt_BR]=Iceweasel
+Name[ru]=Iceweasel
+Name[sk]=Iceweasel
+Name[sv]=Iceweasel
+Comment=Browse the World Wide Web
+Comment[bg]=Сърфиране в Мрежата
+Comment[ca]=Navegueu per el web
+Comment[cs]=Prohlížení stránek World Wide Webu
+Comment[de]=Im Internet surfen
+Comment[el]=Περιηγηθείτε στον παγκόσμιο ιστό
+Comment[es]=Navegue por la web
+Comment[fa]=صفحات شبکه جهانی اینترنت را مرور نمایید
+Comment[fi]=Selaa Internetin WWW-sivuja
+Comment[fr]=Navigue sur Internet
+Comment[hu]=A világháló böngészése
+Comment[it]=Esplora il web
+Comment[ja]=ウェブを閲覧します
+Comment[ko]=웹을 돌아 다닙니다
+Comment[nb]=Surf på nettet
+Comment[nl]=Verken het internet
+Comment[nn]=Surf på nettet
+Comment[no]=Surf på nettet
+Comment[pl]=Przeglądanie stron WWW
+Comment[pt]=Navegue na Internet
+Comment[pt_BR]=Navegue na Internet
+Comment[ru]=Обозреватель Всемирной Паутины
+Comment[sk]=Prehliadanie internetu
+Comment[sv]=Surfa på webben
+GenericName=Web Browser
+GenericName[bg]=Интернет браузър
+GenericName[ca]=Navegador web
+GenericName[cs]=Webový prohlížeč
+GenericName[de]=Webbrowser
+GenericName[el]=Περιηγητής ιστού
+GenericName[es]=Navegador web
+GenericName[fa]=مرورگر اینترنتی
+GenericName[fi]=WWW-selain
+GenericName[fr]=Navigateur Web
+GenericName[hu]=Webböngésző
+GenericName[it]=Browser Web
+GenericName[ja]=ウェブ・ブラウザ
+GenericName[ko]=웹 브라우저
+GenericName[nb]=Nettleser
+GenericName[nl]=Webbrowser
+GenericName[nn]=Nettlesar
+GenericName[no]=Nettleser
+GenericName[pl]=Przeglądarka WWW
+GenericName[pt]=Navegador Web
+GenericName[pt_BR]=Navegador Web
+GenericName[ru]=Интернет-браузер
+GenericName[sk]=Internetový prehliadač
+GenericName[sv]=Webbläsare
+X-GNOME-FullName=Iceweasel Web Browser
+X-GNOME-FullName[bg]=Интернет браузър (Iceweasel)
+X-GNOME-FullName[ca]=Navegador web Iceweasel
+X-GNOME-FullName[cs]=Iceweasel Webový prohlížeč
+X-GNOME-FullName[el]=Περιηγήτης Ιστού Iceweasel
+X-GNOME-FullName[es]=Navegador web Iceweasel
+X-GNOME-FullName[fa]=مرورگر اینترنتی Iceweasel
+X-GNOME-FullName[fi]=Iceweasel-selain
+X-GNOME-FullName[fr]=Navigateur Web Iceweasel
+X-GNOME-FullName[hu]=Iceweasel webböngésző
+X-GNOME-FullName[it]=Iceweasel Browser Web
+X-GNOME-FullName[ja]=Iceweasel ウェブ・ブラウザ
+X-GNOME-FullName[ko]=Iceweasel 웹 브라우저
+X-GNOME-FullName[nb]=Iceweasel Nettleser
+X-GNOME-FullName[nl]=Iceweasel webbrowser
+X-GNOME-FullName[nn]=Iceweasel Nettlesar
+X-GNOME-FullName[no]=Iceweasel Nettleser
+X-GNOME-FullName[pl]=Przeglądarka WWW Iceweasel
+X-GNOME-FullName[pt]=Iceweasel Navegador Web
+X-GNOME-FullName[pt_BR]=Navegador Web Iceweasel
+X-GNOME-FullName[ru]=Интернет-браузер Iceweasel
+X-GNOME-FullName[sk]=Internetový prehliadač Iceweasel
+X-GNOME-FullName[sv]=Webbläsaren Iceweasel
+Exec=/usr/lib/iceweasel/iceweasel %u
+Terminal=false
+X-MultipleArgs=false
+Type=Application
+Icon=iceweasel
+Categories=Network;WebBrowser;
+MimeType=text/html;text/xml;application/xhtml+xml;application/xml;application/vnd.mozilla.xul+xml;application/rss+xml;application/rdf+xml;image/gif;image/jpeg;image/png;x-scheme-handler/http;x-scheme-handler/https;
+StartupWMClass=Iceweasel
+StartupNotify=true
diff --git a/iceweasel.install b/iceweasel.install
new file mode 100644
index 000000000000..c1fe8284a157
--- /dev/null
+++ b/iceweasel.install
@@ -0,0 +1,13 @@
+post_install() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+
diff --git a/mozconfig b/mozconfig
new file mode 100644
index 000000000000..597e0966f00e
--- /dev/null
+++ b/mozconfig
@@ -0,0 +1,43 @@
+. $topsrcdir/browser/config/mozconfig
+
+ac_add_options --prefix=/usr
+ac_add_options --libdir=/usr/lib
+
+# Iceweasel
+ac_add_options --disable-official-branding
+ac_add_options --with-branding=debian/branding
+
+# We wont save user profile in ~/.mozilla/iceweasel instead of ~/.mozilla/firefox
+# Using debian branding it needs to set MOZ_APP_PROFILE too
+ac_add_options --with-user-appdir=.mozilla
+ac_add_options --with-app-basename=iceweasel
+
+# System libraries
+ac_add_options --with-system-nspr
+ac_add_options --with-system-nss
+ac_add_options --with-system-jpeg
+ac_add_options --with-system-zlib
+ac_add_options --with-system-bz2
+ac_add_options --with-system-png
+ac_add_options --with-system-libevent
+ac_add_options --with-system-libvpx
+ac_add_options --with-system-icu
+ac_add_options --enable-system-hunspell
+ac_add_options --enable-system-sqlite
+ac_add_options --enable-system-ffi
+#ac_add_options --enable-system-cairo
+ac_add_options --enable-system-pixman
+
+# Features
+ac_add_options --enable-startup-notification
+ac_add_options --enable-pulseaudio
+ac_add_options --enable-gstreamer=1.0
+
+ac_add_options --disable-crashreporter
+ac_add_options --disable-updater
+ac_add_options --disable-installer
+ac_add_options --disable-debug-symbols
+
+# Other
+mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/moz-objdir
+
diff --git a/vendor.js b/vendor.js
new file mode 100644
index 000000000000..2ec426b0fe06
--- /dev/null
+++ b/vendor.js
@@ -0,0 +1,15 @@
+// You can make any change in here, it is the purpose of this file.
+
+pref("extensions.update.enabled", true);
+
+// Use LANG environment variable to choose locale
+pref("intl.locale.matchOS", true);
+
+// Disable default browser checking.
+pref("browser.shell.checkDefaultBrowser", false);
+
+// Don't disable our bundled extensions in the application directory
+pref("extensions.autoDisableScopes", 11);
+pref("extensions.shownSelectionUI", true);
+
+