summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Nüßlein2015-08-31 17:53:08 +0200
committerAndreas Nüßlein2015-08-31 17:53:08 +0200
commitf6709b1d697d0c92b53dbf182181a03d3ecdbba7 (patch)
tree84b3c2d668d6e4c29ede2638cddfd1c650a232db
downloadaur-f6709b1d697d0c92b53dbf182181a03d3ecdbba7.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5b3e01944be2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = icinga-classic-ui
+ pkgdesc = Icinga Classic UI Standalone.
+ pkgver = 1.12.0
+ pkgrel = 1
+ url = http://www.icinga.org
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = icinga2
+ depends = fcgiwrap
+ source = https://github.com/Icinga/icinga-core/releases/download/v1.12.0/icinga-1.12.0.tar.gz
+ md5sums = 0d7919057455a548d43b888dfa7d0cdb
+
+pkgname = icinga-classic-ui
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1078063d48d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+pkgname=icinga-classic-ui
+pkgver=1.12.0
+pkgrel=1
+pkgdesc="Icinga Classic UI Standalone."
+license=('GPL')
+arch=('i686' 'x86_64')
+depends=('icinga2' 'fcgiwrap')
+url="http://www.icinga.org"
+source=("https://github.com/Icinga/icinga-core/releases/download/v${pkgver}/icinga-${pkgver}.tar.gz")
+
+build() {
+ cd "$srcdir/icinga-$pkgver"
+
+ ./configure \
+ --enable-classicui-standalone \
+ --with-web-user=http --with-web-group=http \
+ --prefix=/usr/share/icinga-classic-ui \
+ --with-htmurl=/ --with-cgiurl=/cgi-bin \
+ --enable-cgi-log --with-cgi-log-dir=/var/log/icinga/ \
+ --with-http-auth-file=/etc/icinga2/users \
+ --with-command-group=http --sysconfdir=/etc/icinga2
+}
+
+package() {
+ cd "$srcdir/icinga-$pkgver"
+
+ make DESTDIR="$pkgdir" classicui-standalone
+ make DESTDIR="$pkgdir" install-classicui-standalone install-classicui-standalone-conf
+}
+
+md5sums=('0d7919057455a548d43b888dfa7d0cdb')