summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulian Brost2020-02-23 22:59:53 +0100
committerJulian Brost2020-02-23 22:59:53 +0100
commitc3cdba713761933ade53a809475f14cd30788011 (patch)
tree7c30364809cf494abf61df4a05c6881ebe863e5a
parent68fe04b068d90322247bb67603da72226d07e971 (diff)
downloadaur-c3cdba713761933ade53a809475f14cd30788011.tar.gz
new version 2.11.2-3: new workaround for builing with boost 1.72
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD24
-rw-r--r--icinga2.changelog4
3 files changed, 26 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc32eda0b4e0..26bb43f6c722 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = icinga2
pkgdesc = An open source host, service and network monitoring program
pkgver = 2.11.2
- pkgrel = 2
+ pkgrel = 3
url = http://www.icinga.org
install = icinga2.install
changelog = icinga2.changelog
arch = i686
arch = x86_64
license = GPL
- makedepends = boost1.69
+ makedepends = boost
makedepends = cmake
makedepends = libmariadbclient
makedepends = postgresql-libs
makedepends = systemd
- depends = boost1.69-libs
+ depends = boost-libs
depends = libedit
depends = libsystemd
depends = openssl
@@ -48,9 +48,11 @@ pkgbase = icinga2
backup = etc/icinga2/zones.conf
backup = etc/logrotate.d/icinga2
source = https://github.com/Icinga/icinga2/archive/v2.11.2.tar.gz
+ source = https://www.boost.org/patches/1_72_0/0001-revert-cease-dependence-on-range.patch
source = icinga2.tmpfiles
source = icinga2.sysusers
sha256sums = b9da300ce6914fe2d25652dc87f5c22aa036b33f4e3e24e1ffe1d746d192a812
+ sha256sums = da7950df251a9d785a84c0092fb7ac4f68f6872c6172cccb303a5453e0ef98fd
sha256sums = 1302b333f49ead14f8808a379535971501d3a0c1ba02a7bf7b4406b7d27c754c
sha256sums = 2f946a33ea50a3c4400a81acd778e6411ffe5e2257a98004288b84a64f382810
diff --git a/PKGBUILD b/PKGBUILD
index 502e40ea758f..8788cdddf055 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,19 +4,16 @@
pkgname='icinga2'
pkgver=2.11.2
-pkgrel=2
+pkgrel=3
pkgdesc="An open source host, service and network monitoring program"
license=('GPL')
arch=('i686' 'x86_64')
url="http://www.icinga.org"
-# There currently is a bug in boost 1.72 preventing icinga2 from compiling, use
-# boost 1.69 as a workaround. See also
-# https://github.com/Icinga/icinga2/issues/7730#issuecomment-569496219
-depends=('boost1.69-libs' 'libedit' 'libsystemd' 'openssl' 'yajl')
+depends=('boost-libs' 'libedit' 'libsystemd' 'openssl' 'yajl')
optdepends=('monitoring-plugins: plugins needed for icinga checks'
'libmariadbclient: for MySQL support'
'postgresql-libs: for PostgreSQL support')
-makedepends=('boost1.69' 'cmake' 'libmariadbclient' 'postgresql-libs' 'systemd')
+makedepends=('boost' 'cmake' 'libmariadbclient' 'postgresql-libs' 'systemd')
replaces=('icinga2-common')
backup=(etc/default/icinga2
etc/icinga2/features-available/api.conf
@@ -46,12 +43,24 @@ backup=(etc/default/icinga2
install='icinga2.install'
changelog="icinga2.changelog"
source=("https://github.com/Icinga/$pkgname/archive/v$pkgver.tar.gz"
+ 'https://www.boost.org/patches/1_72_0/0001-revert-cease-dependence-on-range.patch'
"$pkgname.tmpfiles"
"$pkgname.sysusers")
sha256sums=('b9da300ce6914fe2d25652dc87f5c22aa036b33f4e3e24e1ffe1d746d192a812'
+ 'da7950df251a9d785a84c0092fb7ac4f68f6872c6172cccb303a5453e0ef98fd'
'1302b333f49ead14f8808a379535971501d3a0c1ba02a7bf7b4406b7d27c754c'
'2f946a33ea50a3c4400a81acd778e6411ffe5e2257a98004288b84a64f382810')
+prepare() {
+ mkdir -p "$srcdir/include/boost/coroutine"
+ cd "$srcdir/include"
+
+ # Workaround to make icinga2 compile with boost 1.72, see also
+ # https://github.com/Icinga/icinga2/issues/7730#issuecomment-569496219
+ cp /usr/include/boost/coroutine/asymmetric_coroutine.hpp boost/coroutine/
+ patch -p1 < "$srcdir/0001-revert-cease-dependence-on-range.patch"
+}
+
build() {
mkdir -p "$srcdir/$pkgname-$pkgver/build"
cd "$srcdir/$pkgname-$pkgver/build"
@@ -73,7 +82,8 @@ build() {
-DBoost_NO_BOOST_CMAKE=TRUE \
-DBoost_NO_SYSTEM_PATHS=TRUE \
-DBOOST_LIBRARYDIR=/usr/lib \
- -DBOOST_INCLUDEDIR=/usr/include
+ -DBOOST_INCLUDEDIR=/usr/include \
+ -DCMAKE_CXX_FLAGS=-I"$srcdir/include"
make
}
diff --git a/icinga2.changelog b/icinga2.changelog
index b61f324e4fe7..c582b5550a62 100644
--- a/icinga2.changelog
+++ b/icinga2.changelog
@@ -1,3 +1,7 @@
+2.11.2-3
+ - Other workaround for the bug in boost 1.72 now that boost 1.69 is gone from
+ the Arch repos
+
2.11.2-2
- Build against boost 1.69 as a workaround for a bug in boost 1.72