summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMalte Rabenseifner2015-06-20 19:32:37 +0200
committerMalte Rabenseifner2015-06-20 19:32:37 +0200
commit89ebf4213d78f92fff6b380cd534a5bee0adcf83 (patch)
tree98fe0c2651322a81fd09b667c853d9407678e29d
downloadaur-89ebf4213d78f92fff6b380cd534a5bee0adcf83.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD39
-rw-r--r--icingaweb2.install12
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ebf888b3bb9e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = icingaweb2
+ pkgdesc = Icinga Web 2 Interface
+ pkgver = 2.0.0_rc1
+ pkgrel = 1
+ url = http://www.icinga.org
+ install = icingaweb2.install
+ arch = any
+ license = GPL
+ depends = php
+ optdepends = php-gd: export data to PDF
+ optdepends = php-intl: support for internationalization
+ optdepends = php-ldap: for LDAP authentication
+ optdepends = php-pgsql: for PostgreSQL backend
+ source = https://github.com/Icinga/icingaweb2/archive/v2.0.0-rc1.tar.gz
+ sha256sums = 2d86bc919f5c37eec8145a3cedaeb60c2bdebab01d38650c2c18b7b43ea1c707
+
+pkgname = icingaweb2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e8b32d0cb69b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Malte Rabenseifner <mail@malte-rabenseifner.de>
+
+pkgname=icingaweb2
+pkgver=2.0.0_rc1
+_pkgver=2.0.0-rc1
+pkgrel=1
+pkgdesc="Icinga Web 2 Interface"
+license=('GPL')
+arch=('any')
+depends=('php')
+optdepends=('php-gd: export data to PDF'
+ 'php-intl: support for internationalization'
+ 'php-ldap: for LDAP authentication'
+ 'php-pgsql: for PostgreSQL backend')
+url="http://www.icinga.org"
+source=("https://github.com/Icinga/${pkgname}/archive/v${_pkgver}.tar.gz")
+install='icingaweb2.install'
+sha256sums=('2d86bc919f5c37eec8145a3cedaeb60c2bdebab01d38650c2c18b7b43ea1c707')
+
+package() {
+ cd "$srcdir/$pkgname-$_pkgver"
+
+ #mkdir -p "$pkgdir/etc/webapps/icingaweb2"
+ mkdir -p "$pkgdir/etc/icingaweb2"
+ mkdir -p "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/usr/share/webapps/icingaweb2"
+ mkdir -p "$pkgdir/var/log/icingaweb2"
+
+ cp -r application doc library modules public bin "$pkgdir/usr/share/webapps/icingaweb2"
+ ln -s /usr/share/webapps/icingaweb2/bin/icingacli "$pkgdir/usr/bin/icingacli"
+
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/icingaweb2/LICENSE"
+ install -Dm644 etc/bash_completion.d/icingacli "$pkgdir/etc/bash_completion.d/icingacli"
+ cp -r etc/schema "$pkgdir/usr/share/icingaweb2"
+
+ #chmod 2770 "$pkgdir/etc/webapps/icingaweb2"
+ chmod 2770 "$pkgdir/etc/icingaweb2"
+ chmod 750 "$pkgdir/var/log/icingaweb2"
+}
diff --git a/icingaweb2.install b/icingaweb2.install
new file mode 100644
index 000000000000..eddc01300373
--- /dev/null
+++ b/icingaweb2.install
@@ -0,0 +1,12 @@
+post_install() {
+ getent group icingacmd &> /dev/null && usermod -a -G icingacmd http &> /dev/null
+
+ #chown -R root:http /etc/webapps/icingaweb2
+ chown -R root:http /etc/icingaweb
+ chown -R http:http /var/log/icingaweb2
+}
+
+post_remove() {
+ echo " You may remove the user 'http' from group 'icingacmd' by running"
+ echo " 'gpasswd -d http icingacmd' if no other icinga web interface is installed."
+}