summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMalte Rabenseifner2015-06-20 19:35:56 +0200
committerMalte Rabenseifner2015-06-20 19:35:56 +0200
commit76fe4644da72c786b7d5919a4d3475f52ecbce87 (patch)
tree60f175d126bb7b3bb41c3feb0e54cc15b3ff0b6f
downloadaur-76fe4644da72c786b7d5919a4d3475f52ecbce87.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD47
-rw-r--r--icingaweb2-git.install12
3 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..50450c593d2c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = icingaweb2-git
+ pkgdesc = Icinga Web 2 Interface
+ pkgver = r7176.9b14fff
+ pkgrel = 1
+ url = http://www.icinga.org
+ install = icingaweb2-git.install
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = php
+ optdepends = php-gd: export data to PDF
+ optdepends = php-intl: support for internationalization
+ optdepends = php-ldap: for LDAP authentication
+ optdepends = php-pgsql: for PostgreSQL backend
+ provides = icingaweb2
+ conflicts = icingaweb2
+ source = git+https://github.com/Icinga/icingaweb2.git
+ sha256sums = SKIP
+
+pkgname = icingaweb2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9150299d5547
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Malte Rabenseifner <mail@malte-rabenseifner.de>
+
+pkgname=icingaweb2-git
+_pkgname=icingaweb2
+pkgver=r7176.9b14fff
+pkgrel=1
+pkgdesc="Icinga Web 2 Interface"
+license=('GPL')
+arch=('any')
+depends=('php')
+makedepends=('git')
+optdepends=('php-gd: export data to PDF'
+ 'php-intl: support for internationalization'
+ 'php-ldap: for LDAP authentication'
+ 'php-pgsql: for PostgreSQL backend')
+provides=('icingaweb2')
+conflicts=('icingaweb2')
+url="http://www.icinga.org"
+source=("git+https://github.com/Icinga/icingaweb2.git")
+install='icingaweb2-git.install'
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+
+ #mkdir -p "$pkgdir/etc/webapps/icingaweb2"
+ mkdir -p "$pkgdir/etc/icingaweb2"
+ mkdir -p "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/usr/share/webapps/icingaweb2"
+ mkdir -p "$pkgdir/var/log/icingaweb2"
+
+ cp -r application doc library modules public bin "$pkgdir/usr/share/webapps/icingaweb2"
+ ln -s /usr/share/webapps/icingaweb2/bin/icingacli "$pkgdir/usr/bin/icingacli"
+
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/icingaweb2/LICENSE"
+ install -Dm644 etc/bash_completion.d/icingacli "$pkgdir/etc/bash_completion.d/icingacli"
+ cp -r etc/schema "$pkgdir/usr/share/icingaweb2"
+
+ #chmod 2770 "$pkgdir/etc/webapps/icingaweb2"
+ chmod 2770 "$pkgdir/etc/icingaweb2"
+ chmod 750 "$pkgdir/var/log/icingaweb2"
+}
diff --git a/icingaweb2-git.install b/icingaweb2-git.install
new file mode 100644
index 000000000000..7c9e7c78295a
--- /dev/null
+++ b/icingaweb2-git.install
@@ -0,0 +1,12 @@
+post_install() {
+ getent group icingacmd &> /dev/null && usermod -a -G icingacmd http &> /dev/null
+
+ #chown -R root:http /etc/webapps/icingaweb2
+ chown -R root:http /etc/icingaweb2
+ chown -R http:http /var/log/icingaweb2
+}
+
+post_remove() {
+ echo " You may remove the user 'http' from group 'icingacmd' by running"
+ echo " 'gpasswd -d http icingacmd' if no other icinga web interface is installed."
+}