summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Finelli2016-03-26 09:21:07 -0400
committerMario Finelli2016-03-26 09:21:07 -0400
commitd924f534677b9e4ac1a1ab6ea0c87361009de949 (patch)
tree0f928bfab555e9f63dadbcead4fbba44061f42fa
downloadaur-d924f534677b9e4ac1a1ab6ea0c87361009de949.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD40
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..712c5a93ab7f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Sat Mar 26 13:20:47 UTC 2016
+pkgbase = icmptunnel
+ pkgdesc = Transparently tunnel your IP traffic through ICMP echo and reply packets.
+ pkgver = 1.0.0alpha
+ pkgrel = 1
+ url = https://github.com/DhavalKapil/icmptunnel
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = net-tools
+ provides = icmptunnel
+ conflicts = icmptunnel
+ source = https://github.com/DhavalKapil/icmptunnel/archive/1.0.0-alpha.tar.gz
+ source = http://dhaval.mit-license.org/license.txt
+ sha256sums = 8479ee13f8c0c7af07ecd30d7af15cddf228ae126c1403b16283333c506dccd8
+ sha256sums = e9d8fd95de3a96aa5b015e0f3afd75e7d24450f6702e0971a0f02062fd5891d4
+
+pkgname = icmptunnel
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e3ad3dc27078
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Mario Finelli <mario at finel dot li>
+
+pkgname=icmptunnel
+_pkgver=1.0.0-alpha
+pkgver=1.0.0alpha
+pkgrel=1
+pkgdesc="Transparently tunnel your IP traffic through ICMP echo and reply packets."
+arch=('i686' 'x86_64')
+url="https://github.com/DhavalKapil/icmptunnel"
+license=('MIT')
+depends=('net-tools')
+makedepends=('git')
+provides=('icmptunnel')
+conflicts=('icmptunnel')
+source=("https://github.com/DhavalKapil/icmptunnel/archive/$_pkgver.tar.gz"
+ "http://dhaval.mit-license.org/license.txt")
+sha256sums=('8479ee13f8c0c7af07ecd30d7af15cddf228ae126c1403b16283333c506dccd8'
+ 'e9d8fd95de3a96aa5b015e0f3afd75e7d24450f6702e0971a0f02062fd5891d4')
+
+prepare() {
+ cd "$srcdir/icmptunnel-$_pkgver"
+ sed -i '/SERVER_SCRIPT/s/server.sh/\/usr\/bin\/icmptunnel-server/' tunnel.h
+ sed -i '/CLIENT_SCRIPT/s/client.sh/\/usr\/bin\/icmptunnel-client/' tunnel.h
+}
+
+build(){
+ cd "$srcdir/icmptunnel-$_pkgver"
+ make
+}
+
+package(){
+ cd "$srcdir/icmptunnel-$_pkgver"
+ install -Dm0755 icmptunnel "$pkgdir"/usr/bin/icmptunnel
+
+ install -Dm0755 client.sh "$pkgdir"/usr/bin/icmptunnel-client
+ install -Dm0755 server.sh "$pkgdir"/usr/bin/icmptunnel-server
+
+ install -Dm0644 "$srcdir/license.txt" \
+ "$pkgdir/usr/share/licenses/icmptunnel/license.txt"
+}