summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Finelli2015-11-11 23:12:53 -0500
committerMario Finelli2015-11-11 23:12:53 -0500
commit51e4c2f3ef3cbf4428e744a3e48e5bc8bb3f7b69 (patch)
tree8c718bda2ad321f74f85db65cfa7cbcbec9ef97e
downloadaur-51e4c2f3ef3cbf4428e744a3e48e5bc8bb3f7b69.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0e1a8e1b003f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = icmptunnel-git
+ pkgdesc = Transparently tunnel your IP traffic through ICMP echo and reply packets.
+ pkgver = r46.308ba3b
+ pkgrel = 1
+ url = https://github.com/DhavalKapil/icmptunnel
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ provides = icmptunnel
+ conflicts = icmptunnel
+ source = git://github.com/DhavalKapil/icmptunnel.git
+ md5sums = SKIP
+
+pkgname = icmptunnel-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f0cc93f117e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Mario Finelli <mario dot finelli at yahoo dot com>
+
+pkgname=icmptunnel-git
+pkgver=r46.308ba3b
+pkgrel=1
+pkgdesc="Transparently tunnel your IP traffic through ICMP echo and reply packets."
+arch=('i686' 'x86_64')
+url="https://github.com/DhavalKapil/icmptunnel"
+license=('MIT')
+makedepends=('git')
+provides=('icmptunnel')
+conflicts=('icmptunnel')
+source=('git://github.com/DhavalKapil/icmptunnel.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/icmptunnel"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build(){
+ cd "$srcdir/icmptunnel"
+ make
+}
+
+package(){
+ cd "$srcdir/icmptunnel"
+ install -Dm0755 icmptunnel "$pkgdir"/usr/bin/icmptunnel
+}