summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F Rødseth2015-06-10 14:41:38 +0200
committerAlexander F Rødseth2015-06-10 14:41:38 +0200
commit88456a5a09896fb3008a7f3f1f4f303b6a65bcd4 (patch)
tree6b6ffe8b4005669da740f6e0b04f2dad552c4188
downloadaur-88456a5a09896fb3008a7f3f1f4f303b6a65bcd4.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD33
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bf5bdee05c03
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = icompile
+ pkgdesc = Zero-configuration build system
+ pkgver = 0.5.16
+ pkgrel = 1
+ url = http://ice.sourceforge.net
+ arch = any
+ license = BSD
+ depends = python2
+ source = http://kent.dl.sourceforge.net/sourceforge/ice/icompile-0.5.16.tar.gz
+ md5sums = 34aee2f877f45b85c934cf11a340503e
+
+pkgname = icompile
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ce1ff1542434
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Contributor: Alexander Rødseth <rodseth@gmail.com>
+pkgname=icompile
+pkgver=0.5.16
+pkgrel=1
+pkgdesc="Zero-configuration build system"
+arch=('any')
+url="http://ice.sourceforge.net"
+license=('BSD')
+depends=('python2')
+source=("http://kent.dl.sourceforge.net/sourceforge/ice/$pkgname-$pkgver.tar.gz")
+md5sums=('34aee2f877f45b85c934cf11a340503e')
+
+build() {
+ cd "$srcdir"
+
+ # Fix to use python 2 instead of python 3
+ sed -i 's:bin/env python:bin/env python2:' "$pkgname"
+ # Fix flag that does not work on the latest version of gcc that comes with Arch
+ sed -i "s:state.compilerOptions.append('-fpmath=sse'):pass:" "$pkgname"
+ mkdir -p "$pkgdir/usr/lib/python2.7/site-packages"
+}
+
+package() {
+ cd "$srcdir"
+
+ cp -r ice "$pkgdir/usr/lib/python2.7/site-packages/"
+ install -Dm644 $pkgname.html "$pkgdir/usr/share/doc/$pkgname/$pkgname.html"
+ install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
+ mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
+ touch "$pkgdir/usr/share/licenses/$pkgname/BSD"
+}
+
+# vim:set ts=2 sw=2 et: