summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2015-06-09 00:27:41 +0200
committerStefan Husmann2015-06-09 00:27:41 +0200
commit1e5c8dab5f6b5117891d12c9e181c91e38b34404 (patch)
tree25a394d826f591048ca23774b996f44554d74adf
downloadaur-1e5c8dab5f6b5117891d12c9e181c91e38b34404.tar.gz
initial version
-rw-r--r--.SRCINFO20
-rw-r--r--LICENSE20
-rw-r--r--PKGBUILD55
3 files changed, 95 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3772f7d488c4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = icon-git
+ pkgdesc = The Icon programming language
+ pkgver = 11.g26f32ee
+ pkgrel = 1
+ url = http://www.cs.arizona.edu/icon/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = git
+ depends = sh
+ depends = libx11
+ provides = icon=951
+ conflicts = icon
+ source = git://github.com/gtownsend/icon.git
+ source = LICENSE
+ md5sums = SKIP
+ md5sums = 46e837548bf46e5b0db662322650eb4f
+
+pkgname = icon-git
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..ab65c7f18262
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,20 @@
+This material is in the public domain. You may use and copy this material
+freely. This privilege extends to modifications, although any modified
+version of this system given to a third party should clearly identify your
+modifications as well as the original source.
+
+The responsibility for the use of this material resides entirely with you.
+We make no warranty of any kind concerning this material, nor do we make
+any claim as to the suitability of Icon for any application.
+
+For more information or assistance, contact:
+
+ www.cs.arizona.edu/icon
+ icon-project@cs.arizona.edu
+
+ Icon Project
+ Department of Computer Science
+ The University of Arizona
+ P.O. Box 210077
+ Tucson, AZ 85721-0077
+ U.S.A.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..45bce412ab80
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+pkgname=icon-git
+pkgver=11.g26f32ee
+pkgrel=1
+pkgdesc="The Icon programming language"
+arch=('i686' 'x86_64')
+url="http://www.cs.arizona.edu/icon/"
+license=('custom')
+depends=('sh' 'libx11')
+makedepends=('git')
+provides=('icon=951')
+conflicts=('icon')
+source=("git://github.com/gtownsend/icon.git" LICENSE)
+md5sums=('SKIP' '46e837548bf46e5b0db662322650eb4f')
+_gitname="icon"
+
+pkgver() {
+ cd "$srcdir"/"$_gitname"
+ git describe --tags | sed 's|-|.|g' |cut -c8-
+}
+
+build() {
+ cd "$srcdir"/"$_gitname"
+ make X-Configure name=linux
+ make -j1
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ install -d $pkgdir/usr/share
+ make Install dest=$pkgdir/usr/share/icon
+ for _i in colrbook colrpick fontpick icont iconx palette vib wevents
+ do
+ install -D -m755 $pkgdir/usr/share/icon/bin/$_i $pkgdir/usr/bin/$_i
+ rm $pkgdir/usr/share/icon/bin/$_i
+ done
+ cd $pkgdir/usr/share/icon/bin
+ rm icon
+ install -D -m644 $pkgdir/usr/share/icon/bin/libcfunc.so \
+ $pkgdir/usr/lib/libcfunc.so
+ rm $pkgdir/usr/share/icon/bin/libcfunc.so
+ rm -fr $pkgdir/usr/share/icon/bin
+ for _i in icont icon
+ do
+ install -D -m644 $pkgdir/usr/share/icon/man/man1/$_i.1 \
+ $pkgdir/usr/share/man/man1/$_i.1
+ rm $pkgdir/usr/share/icon/man/man1/$_i.1
+ done
+ rmdir $pkgdir/usr/share/icon/man/man1/
+ rmdir $pkgdir/usr/share/icon/man
+ cd $pkgdir/usr/bin
+ ln -s icont icon
+ install -D -m644 $srcdir/LICENSE \
+ $pkgdir/usr/share/licenses/icon/LICENSE
+}