summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2021-05-09 00:24:23 +0200
committerhaawda2021-05-09 00:24:23 +0200
commitadb99e1c7be0a6224c74750e036a0fa1a6f5b2e6 (patch)
tree7db20319a0ae0f622bf437c2304ccce0462e5b6b
parentc40f7f29695c41e9c694f37f27e25de182c70df9 (diff)
downloadaur-adb99e1c7be0a6224c74750e036a0fa1a6f5b2e6.tar.gz
new pkgver function, and epoch
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 410fe6f3fd48..d94b38d4da1a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = icon-git
pkgdesc = The Icon programming language
- pkgver = 20181004
+ pkgver = 9.5.20i.r1.gf48c0f5
pkgrel = 1
- url = http://www.cs.arizona.edu/icon/
+ epoch = 1
+ url = https://github.com/gtownsend/icon
arch = i686
arch = x86_64
license = custom
@@ -10,9 +11,9 @@ pkgbase = icon-git
makedepends = libxt
depends = sh
depends = libx11
- provides = icon=951
+ provides = icon
conflicts = icon
- source = git://github.com/gtownsend/icon.git
+ source = git+https://github.com/gtownsend/icon.git
source = LICENSE
sha256sums = SKIP
sha256sums = 57b2b71129aa652ca63b07d3c23564bc7a45444a274d12e50856b46e4d088e35
diff --git a/PKGBUILD b/PKGBUILD
index 5be6232df989..b074a7e12777 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,24 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
pkgname=icon-git
-pkgver=20181004
+pkgver=9.5.20i.r1.gf48c0f5
pkgrel=1
+epoch=1
pkgdesc="The Icon programming language"
arch=('i686' 'x86_64')
-url="http://www.cs.arizona.edu/icon/"
+url="https://github.com/gtownsend/icon"
license=('custom')
depends=('sh' 'libx11')
makedepends=('git' 'libxt')
-provides=('icon=951')
+provides=('icon')
conflicts=('icon')
-source=("git://github.com/gtownsend/icon.git" LICENSE)
+source=("git+$url.git" LICENSE)
sha256sums=('SKIP'
'57b2b71129aa652ca63b07d3c23564bc7a45444a274d12e50856b46e4d088e35')
pkgver() {
cd ${pkgname%-git}
- git log -1 --format="%cd" --date=short | tr -d '-'
+ git describe --tags | sed 's+-+.r+' | cut -c2- | tr - .
}
build() {