summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSkycoder422017-02-06 15:13:45 +0100
committerSkycoder422017-02-06 15:13:45 +0100
commit141cb50f37bfbb6b13d50b9c28626f4b44e438b3 (patch)
treecd3d42d709ea9870f03c651f0273884df8355502
downloadaur-141cb50f37bfbb6b13d50b9c28626f4b44e438b3.tar.gz
Create package with version 1.0.1
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD30
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..433c3604e7df
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = iconthemebrowser
+ pkgdesc = A small application to browse icon themes available in Qt
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/Skycoder42/IconThemeBrowser
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ depends = qt5-base
+ depends = qt5-tools
+ optdepends = qt5-imageformats: Support for additional icon types
+ optdepends = qt5-svg: Support for SVG-Icons
+ source = iconthemebrowser-1.0.1::git+https://github.com/Skycoder42/IconThemeBrowser#tag=1.0.1
+ md5sums = SKIP
+
+pkgname = iconthemebrowser
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..273272cd9461
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Felix Barz <skycoder42.de@gmx.de>
+pkgname=iconthemebrowser
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="A small application to browse icon themes available in Qt"
+arch=('i686' 'x86_64')
+url="https://github.com/Skycoder42/IconThemeBrowser"
+license=('BSD')
+depends=('qt5-base' 'qt5-tools')
+makedepends=('git')
+optdepends=('qt5-imageformats: Support for additional icon types'
+ 'qt5-svg: Support for SVG-Icons')
+source=("$pkgname-$pkgver::git+https://github.com/Skycoder42/IconThemeBrowser#tag=1.0.1")
+md5sums=('SKIP')
+
+build() {
+ cd "$pkgname-$pkgver"
+ git submodule update --init --recursive
+
+ qmake
+ make qmake_all
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ make INSTALL_ROOT="$pkgdir" install
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}