summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAzat Khuzhin2020-03-31 15:37:04 +0300
committerAzat Khuzhin2020-03-31 15:37:57 +0300
commit4519f9476d8ad50d72bb2479abe760cd870bba07 (patch)
tree88115a0865f864dd463625719ce2e824595a78e6
downloadaur-4519f9476d8ad50d72bb2479abe760cd870bba07.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD47
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1bcd9598d5cb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = icu-git-static
+ pkgdesc = International Components for Unicode library
+ pkgver = 66.1.r137.gea9ce7e34f
+ pkgrel = 1
+ url = http://site.icu-project.org/
+ arch = i686
+ arch = x86_64
+ license = custom:icu
+ makedepends = git
+ depends = glibc
+ depends = sh
+ provides = icu
+ provides = icu-git
+ conflicts = icu
+ conflicts = icu-git
+ source = git+https://github.com/unicode-org/icu.git
+ sha256sums = SKIP
+
+pkgname = icu-git-static
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..11867435a9a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=icu-git-static
+pkgver=66.1.r137.gea9ce7e34f
+pkgrel=1
+pkgdesc="International Components for Unicode library"
+arch=('i686' 'x86_64')
+url="http://site.icu-project.org/"
+license=('custom:icu')
+depends=('glibc' 'sh')
+makedepends=('git')
+provides=('icu' 'icu-git')
+conflicts=('icu' 'icu-git')
+source=("git+https://github.com/unicode-org/icu.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "icu"
+
+ git describe --long --tags | sed 's/^release-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "icu/icu4c/source"
+
+ export CC=gcc CXX=g++
+ ./configure \
+ --prefix="/usr" \
+ --sbindir="/usr/bin" \
+ --sysconfdir="/etc" \
+ --enable-static
+ make
+}
+
+check() {
+ cd "icu/icu4c/source"
+
+ make check
+}
+
+package() {
+ cd "icu/icu4c/source"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "$srcdir/icu/icu4c/LICENSE" "$pkgdir/usr/share/licenses/icu/LICENSE"
+}