summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Demers2015-12-22 00:07:56 -0500
committerAlexandre Demers2015-12-22 00:07:56 -0500
commiteb89074eaca88b4d986e59277596d8af8c5bb29f (patch)
tree0bd1b1a39506420e53ed1a76407735e0131db7bc
downloadaur-eb89074eaca88b4d986e59277596d8af8c5bb29f.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD41
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c593bcc68ebc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Tue Dec 22 05:04:47 UTC 2015
+pkgbase = icu51
+ pkgdesc = International Components for Unicode library, version 51
+ pkgver = 51.2
+ pkgrel = 1
+ url = http://www.icu-project.org/
+ arch = i686
+ arch = x86_64
+ license = custom:"icu"
+ depends = gcc-libs>=4.7.1-5
+ source = http://download.icu-project.org/files/icu4c/51.2/icu4c-51_2-src.tgz
+ md5sums = 072e501b87065f3a0ca888f1b5165709
+
+pkgname = icu51
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..11d9154f990d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Alexandre Demers <alexandre.f.demers@gmail.com>
+
+_setPrefix="/usr"
+_setLibdir="$_setPrefix/lib"
+_pkgbase=icu
+_pkgmaj=51
+_pkgmin=2
+pkgrel=1
+
+pkgname=$_pkgbase$_pkgmaj
+pkgver=$_pkgmaj.$_pkgmin
+pkgdesc="International Components for Unicode library, version 51"
+arch=('i686' 'x86_64')
+url="http://www.icu-project.org/"
+license=('custom:"icu"')
+depends=('gcc-libs>=4.7.1-5')
+
+source=("http://download.icu-project.org/files/${_pkgbase}4c/${pkgver}/${_pkgbase}4c-${pkgver//./_}-src.tgz")
+
+md5sums=('072e501b87065f3a0ca888f1b5165709')
+
+build() {
+ cd ${srcdir}/icu/source
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --libdir=${_setLibdir}
+ make
+}
+
+package() {
+ cd "${srcdir}/icu/source"
+
+ # Copy only .so libs to the destination dir
+ mkdir -p "${pkgdir}${_setLibdir}"
+ cp -a lib/libicu*51* "${pkgdir}${_setLibdir}"
+
+ # Install the license
+ install -Dm644 ${srcdir}/icu/license.html ${pkgdir}/usr/share/licenses/${pkgname}/license.html
+}