summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrobot Viktor2017-11-19 01:52:07 +0300
committerDrobot Viktor2017-11-19 01:52:07 +0300
commit3f858e30bdffc09eb5a30901ed4c6e2dd1c220e1 (patch)
tree901e1f1a70c9bb6ebbb6a932a9448456510f6ce1
downloadaur-3f858e30bdffc09eb5a30901ed4c6e2dd1c220e1.tar.gz
first commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD31
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f9469c2eeff6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = icu59
+ pkgdesc = International Components for Unicode library
+ pkgver = 59.1
+ pkgrel = 1
+ url = http://www.icu-project.org/
+ arch = i686
+ arch = x86_64
+ license = custom:"icu"
+ depends = gcc-libs>=4.7.1-5
+ source = https://vorboss.dl.sourceforge.net/project/icu/ICU4C/59.1/icu4c-59_1-src.tgz
+ sha256sums = 7132fdaf9379429d004005217f10e00b7d2319d0fea22bdfddef8991c45b75fe
+
+pkgname = icu59
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e6f9bd4abab1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Author: CubeTheThird <cubethethird@gmail.com>
+
+_pkgname=icu
+pkgname=${_pkgname}59
+pkgver=59.1
+pkgrel=1
+pkgdesc="International Components for Unicode library"
+arch=('i686' 'x86_64')
+url="http://www.icu-project.org/"
+license=('custom:"icu"')
+depends=('gcc-libs>=4.7.1-5')
+source=(https://vorboss.dl.sourceforge.net/project/${_pkgname}/ICU4C/${pkgver}/${_pkgname}4c-${pkgver//./_}-src.tgz)
+sha256sums=('7132fdaf9379429d004005217f10e00b7d2319d0fea22bdfddef8991c45b75fe')
+
+build() {
+ cd ${srcdir}/${_pkgname}/source
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}/source
+ make -j1 DESTDIR=${pkgdir} install
+ rm -r "${pkgdir}"/usr/{bin,include,sbin,share,lib/*so,lib/icu/{Makefile.inc,current,pkgdata.inc}}
+ rm -r "${pkgdir}/usr/lib/pkgconfig"
+
+ # Install license
+ install -Dm644 ${srcdir}/${_pkgname}/license.html ${pkgdir}/usr/share/licenses/${pkgname}/license.html
+}