summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlo Bottai2018-08-12 15:07:03 +0200
committerCarlo Bottai2018-08-12 15:07:03 +0200
commitc20f887413bcb4e9fa8f8511ee730b26a7d7abdf (patch)
tree77b360af787d811087878388361e8c724582fb63
downloadaur-c20f887413bcb4e9fa8f8511ee730b26a7d7abdf.tar.gz
new package that provides ICU v61
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD37
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c9c2b47a6ed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = icu61
+ pkgdesc = International Components for Unicode library
+ pkgver = 61.1
+ pkgrel = 1
+ url = http://www.icu-project.org/
+ arch = i686
+ arch = x86_64
+ license = custom:"icu"
+ depends = gcc-libs>=4.7.1-5
+ source = https://vorboss.dl.sourceforge.net/project/icu/ICU4C/61.1/icu4c-61_1-src.tgz
+ sha1sums = 06ca7b1e64c28e07d5633a2e0257380884ea486b
+
+pkgname = icu61
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ae467a7cf5d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Author: n3ssuno <carlo.bottai@gmail.com>
+
+_pkgname=icu
+pkgname=${_pkgname}61
+pkgver=61.1
+pkgrel=1
+pkgdesc="International Components for Unicode library"
+arch=('i686' 'x86_64')
+url="http://www.icu-project.org/"
+license=('custom:"icu"')
+depends=('gcc-libs>=4.7.1-5')
+source=(https://vorboss.dl.sourceforge.net/project/${_pkgname}/ICU4C/${pkgver}/${_pkgname}4c-${pkgver//./_}-src.tgz)
+sha1sums=('06ca7b1e64c28e07d5633a2e0257380884ea486b')
+
+prepare() {
+ # fix xlocale.h problems (FS#55246)
+ cd ${srcdir}/${_pkgname}/source
+ sed -i 's/xlocale/locale/' i18n/digitlst.cpp
+}
+
+build() {
+ cd ${srcdir}/${_pkgname}/source
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man
+ make -j5
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}/source
+ make -j5 DESTDIR=${pkgdir} install
+ rm -r "${pkgdir}"/usr/{bin,include,sbin,share,lib/*so,lib/icu/{Makefile.inc,current,pkgdata.inc}}
+ rm -r "${pkgdir}/usr/lib/pkgconfig"
+
+ # Install license
+ install -Dm644 ${srcdir}/${_pkgname}/license.html ${pkgdir}/usr/share/licenses/${pkgname}/license.html
+}