summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTopik2021-11-19 22:49:02 -0600
committerTopik2021-11-19 22:49:02 -0600
commit544f121ffb7672cfbc61c161a97f52b37ae50a80 (patch)
tree7f5ec548922ad93eb6a6e5123ade0a448877997a
parentefa3a717c539ae948e848179b1a71c57543e27c7 (diff)
downloadaur-544f121ffb7672cfbc61c161a97f52b37ae50a80.tar.gz
Switched to using the official binaries and did various things to make it work properly
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD22
2 files changed, 17 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 21e34ecd010d..aa8d09bc0350 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,7 +6,7 @@ pkgbase = icu67-bin
arch = x86_64
license = custom:icu
depends = bash
- source = https://github.com/topik0/icu-binaries/releases/download/v67/icu67-67.1-1-x86_64.pkg.tar.zst
- sha512sums = e20ff5731be37ebc1bd8a78788e171f9df6f1dee1cc3b454d28d24bbd23c430c5b18663b3a3d21ff7d8b57c4939839fe9c4d4dd1b0bc7cb9f2bf9849f424dcba
+ source = https://github.com/unicode-org/icu/releases/download/release-67-1/icu4c-67_1-Fedora31-x64.tgz
+ sha512sums = a60a1ecd6c942d69181442559d32afdf44b852490dbf3833e5b9dcd340754a26edaafbe08432a86ff9ff6372e4b14e631471178d48d4108b9e90be0564564ade
pkgname = icu67-bin
diff --git a/PKGBUILD b/PKGBUILD
index fd9c9e9628ab..793b8e52798c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,13 +7,21 @@ arch=('x86_64')
url="https://github.com/unicode-org/icu"
license=('custom:icu')
depends=('bash')
-source=("https://github.com/topik0/icu-binaries/releases/download/v67/icu67-67.1-1-x86_64.pkg.tar.zst")
-sha512sums=('e20ff5731be37ebc1bd8a78788e171f9df6f1dee1cc3b454d28d24bbd23c430c5b18663b3a3d21ff7d8b57c4939839fe9c4d4dd1b0bc7cb9f2bf9849f424dcba')
+source=("https://github.com/unicode-org/icu/releases/download/release-67-1/icu4c-67_1-Fedora31-x64.tgz")
+sha512sums=('a60a1ecd6c942d69181442559d32afdf44b852490dbf3833e5b9dcd340754a26edaafbe08432a86ff9ff6372e4b14e631471178d48d4108b9e90be0564564ade')
package() {
- tar xf icu67-67.1-1-x86_64.pkg.tar.zst
- mkdir -p "${pkgdir}"/usr/{share,lib}
- mkdir -p "${pkgdir}"/usr/share/licenses/icu67
- cp -r "${srcdir}"/usr/lib/* -t "${pkgdir}"/usr/lib/
- install -Dm644 "${srcdir}"/usr/share/licenses/icu67/LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
+ tar xf icu4c-67_1-Fedora31-x64.tgz
+ # Remove certain files if icu is installed to not cause conflicts
+ rm -rf "${srcdir}"/icu/usr/local/lib/icu "${srcdir}"/icu/usr/local/lib/pkgconfig
+ for filename in "${srcdir}"/icu/usr/local/lib/*.so; do
+ if [[ ! -e "$filename" ]]; then continue; fi
+ if [[ -e "/usr/lib/${filename##*/}" ]]; then
+ rm -rf "${filename}"
+ fi
+ done
+ mkdir -p "${pkgdir}"/usr/{share,lib}
+ mkdir -p "${pkgdir}"/usr/share/licenses/icu67
+ cp -rn "${srcdir}"/icu/usr/local/lib/* -t "${pkgdir}"/usr/lib/
+ install -Dm644 "${srcdir}"/icu/usr/local/share/icu/67.1/LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
} \ No newline at end of file