summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcorey drew bruce2023-12-29 14:58:32 +1000
committercorey drew bruce2023-12-29 14:58:32 +1000
commita46b7dcd4eb9caf2eca49b7121d9b2472bfeac70 (patch)
treeb7aef5773d1688b18d3c51c98f7080797c8f2125
parentbec274b8b0b714b4545aef72f05c270c04c59d8d (diff)
downloadaur-icytower.tar.gz
Icy Tower 1.0.1-1
-rw-r--r--.SRCINFO9
-rwxr-xr-xPKGBUILD27
2 files changed, 17 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 443eedb79633..d849700300bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = icytower
pkgdesc = Harold the Homeboy and his friends have decided to climb a huge tower they found the other day. It's up to you to help them get as high as possible without falling down, and collect extra points by doing cool moves on the way.
- pkgver = 1.0.0
+ pkgver = 1.0.1
pkgrel = 1
arch = pentium4
arch = x86_64
@@ -8,11 +8,10 @@ pkgbase = icytower
makedepends = unzip
depends = wget
depends = wine
- depends = wine-gecko
- depends = wine-mono
+ depends = lib32-libpulse
depends = unzip
- depends = zenity
- source = git+https://gitlab.com/icytower/icytower-launch-script
+ depends = yad
+ source = https://gitlab.com/icytower/icytower/-/archive/1.0.1-1/icytower-1.0.1-1.tar.gz
sha256sums = SKIP
pkgname = icytower
diff --git a/PKGBUILD b/PKGBUILD
index 95968e8886e8..482a22967ae7 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,31 @@
pkgname=icytower
_pkgname=IcyTower
-pkgver=1.0.0
+pkgver=1.0.1
pkgrel=1
pkgdesc="Harold the Homeboy and his friends have decided to climb a huge tower they found the other day. It's up to you to help them get as high as possible without falling down, and collect extra points by doing cool moves on the way."
arch=('pentium4' 'x86_64')
url=""
license=('GPL')
-depends=('wget' 'wine' 'wine-gecko' 'wine-mono' 'unzip' 'zenity')
+depends=('wget' 'wine' 'lib32-libpulse' 'unzip' 'yad')
makedepends=('unzip')
-source=("git+https://gitlab.com/icytower/icytower-launch-script")
+source=("https://gitlab.com/icytower/icytower/-/archive/$pkgver-$pkgrel/icytower-$pkgver-$pkgrel.tar.gz")
sha256sums=("SKIP")
package() {
- cd "$srcdir"
- cp -r "$srcdir/icytower-launch-script/." "$srcdir"
- rm -rf "./icytower-launch-script"
- wget -nc "https://gitlab.com/icytower/icytower-binary/1.3.1/-/raw/main/IcyTower.tar.gz"
- install -dm755 "$pkgdir/opt/$_pkgname"
- cp -r ./ "$pkgdir/opt/$_pkgname"
-
- # Link to binary
+ install -dm755 "$pkgdir/usr/share/games/$_pkgname"
install -dm755 "$pkgdir/usr/bin"
install -dm755 "$pkgdir/usr/share/pixmaps"
- ln -s "/opt/$_pkgname/$pkgname" "$pkgdir/usr/bin/$pkgname"
- cp -r "$pkgname.png" "$pkgdir/usr/share/pixmaps"
+
+ cd "$srcdir/icytower-$pkgver-$pkgrel"
+ wget "https://gitlab.com/icytower/Binaries/1.3.1/-/raw/main/IcyTower.tar.gz"
+ cp -r ./ "$pkgdir/usr/share/games/$_pkgname"
+ cp -r "$pkgdir/usr/share/games/$_pkgname/$pkgname.png" "$pkgdir/usr/share/pixmaps"
+
+ # Link to binary
+ cp -r "$pkgdir/usr/share/games/$_pkgname/icytower" "$pkgdir/usr/bin"
# Desktop Entry
- install -Dm644 "$srcdir/$_pkgname.desktop" \
+ install -Dm644 "$pkgdir/usr/share/games/$_pkgname/$_pkgname.desktop" \
"$pkgdir/usr/share/applications/$_pkgname.desktop"
sed -i s%/usr/share%/opt% "$pkgdir/usr/share/applications/$_pkgname.desktop"
}