summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordllud2021-06-03 20:39:42 +0100
committerdllud2021-06-03 20:39:42 +0100
commit54dadee2b45deb60919b1f11140b7bd7a838322a (patch)
treead5a4da1c4d731bd4fd0192d2112adb6a8fe6a49
parent16b2e7515e317ffe97861bd296337f0e6a3e8edc (diff)
downloadaur-id3-git.tar.gz
Patching is no longer needed.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD17
-rw-r--r--do-not-replace-dots.patch19
3 files changed, 8 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 94bc478b7110..87ec9ca92177 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = id3-git
- pkgdesc = id3 mass tagger lists and manipulates ID3 and Lyrics3 tags in multiple files. Patched to avoid replacement of dot characters.
- pkgver = r569.51e738e
- pkgrel = 2
+ pkgdesc = id3 mass tagger lists and manipulates ID3 and Lyrics3 tags in multiple files.
+ pkgver = r573.a899eac
+ pkgrel = 1
url = https://squell.github.io/id3/
arch = i686
arch = x86_64
@@ -11,9 +11,6 @@ pkgbase = id3-git
conflicts = id3
options = !makeflags
source = id3-git::git+https://github.com/squell/id3.git
- source = do-not-replace-dots.patch
md5sums = SKIP
- md5sums = 162c7882a19f45003e62013427bfea8c
pkgname = id3-git
-
diff --git a/PKGBUILD b/PKGBUILD
index b895de5844e9..4b02e8dfa554 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,9 +4,9 @@
# Contributor: Jochem Kossen <j.kossen@home.nl>
pkgname=id3-git
-pkgver=r569.51e738e
-pkgrel=2
-pkgdesc="id3 mass tagger lists and manipulates ID3 and Lyrics3 tags in multiple files. Patched to avoid replacement of dot characters."
+pkgver=r573.a899eac
+pkgrel=1
+pkgdesc="id3 mass tagger lists and manipulates ID3 and Lyrics3 tags in multiple files."
url="https://squell.github.io/id3/"
arch=('i686' 'x86_64')
license=('BSD')
@@ -14,21 +14,14 @@ depends=('gcc-libs')
makedepends=('git')
conflicts=('id3')
options=('!makeflags')
-source=("$pkgname::git+https://github.com/squell/id3.git"
- "do-not-replace-dots.patch")
-md5sums=('SKIP'
- '162c7882a19f45003e62013427bfea8c')
+source=("$pkgname::git+https://github.com/squell/id3.git")
+md5sums=('SKIP')
pkgver() {
cd "$pkgname"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "$pkgname"
- patch -Np1 -i "${srcdir}/do-not-replace-dots.patch"
-}
-
build() {
cd "$pkgname"
make
diff --git a/do-not-replace-dots.patch b/do-not-replace-dots.patch
deleted file mode 100644
index 0339f76933db..000000000000
--- a/do-not-replace-dots.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff --git a/setfname.cpp b/setfname.cpp
-index 6eac756..5ae89e1 100644
---- a/setfname.cpp
-+++ b/setfname.cpp
-@@ -65,14 +65,8 @@ bool file::vmodify(const char* fname, const function& edit) const
- }
-
- string name = edited;
-- int dot = 1;
- for(string::iterator p = name.end()-1; p != name.begin()-1; --p) {
- if(!portable_fn(*p)) *p = '_'; // replace ill. chars
-- if(*p == '.') {
-- if(dot-- <= 0) {
-- *p = '_';
-- }
-- }
- }
- if(const char* psep = strrchr(fname, '/')) {
- name.insert(0, fname, psep-fname+1); // copy path prefix