summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStick2020-02-25 17:59:55 -0500
committerStick2020-02-25 18:04:25 -0500
commit43a0ab40faae15a4a9f81e8655e44537c2a6c0b6 (patch)
tree6cdd280e671a5f39c4e59731da1bde179a677a2f
parente96215dd63bf9245f5a7758a1f84234c2724632c (diff)
downloadaur-43a0ab40faae15a4a9f81e8655e44537c2a6c0b6.tar.gz
create ida-eval from ida-free
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD54
-rw-r--r--ida-eval.desktop (renamed from ida-free.desktop)6
-rw-r--r--idademo74_linux.run1
5 files changed, 42 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 26042f3bcf4d..64d941c2ec57 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
-pkgbase = ida-free
- pkgdesc = Freeware version of the world's smartest and most feature-full disassembler
- pkgver = 7.0.191002
+pkgbase = ida-eval
+ pkgdesc = Evaluation version of the world's smartest and most feature-full disassembler
+ pkgver = 7.4
pkgrel = 1
url = https://www.hex-rays.com/products/ida/
arch = x86_64
license = custom
makedepends = fakechroot
options = !strip
- source = idafree70_linux.run-7.0.191002-1::https://out7.hex-rays.com/files/idafree70_linux.run
- source = ida-free.desktop
- sha256sums = 136e0e1995f16e1ff85244c269450fa91fb5454a565ca7623712f34ac004e245
- sha256sums = 55f2ed3f165df6efb5f7975b17d8e53bee1d88cad33efb9d4422402213d17440
+ source = idademo74_linux.run
+ source = ida-eval.desktop
+ sha256sums = 547373518e2823a94195ea5e06cacf53c101610afa0f642204e7265f4b548045
+ sha256sums = 5f51fea009781672998ffec1c1d63d392e87ac6eb04b637a1ee2827805b8e1db
-pkgname = ida-free
+pkgname = ida-eval
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..924dfb95c209
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
index ea53727be78b..2f691aad4203 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,43 @@
-# Maintainer: fatalis <fatalis@fatalis.pw>
-pkgname=ida-free
-pkgver=7.0.191002
+# Maintainer: stick <stick@stma.is>
+pkgname=ida-eval
+pkgver=7.4
pkgrel=1
-pkgdesc="Freeware version of the world's smartest and most feature-full disassembler"
+pkgdesc="Evaluation version of the world's smartest and most feature-full disassembler"
arch=('x86_64')
url='https://www.hex-rays.com/products/ida/'
license=('custom')
makedepends=('fakechroot')
options=('!strip')
-_originalname='idafree70_linux.run'
-_installer="${_originalname}-${pkgver}-${pkgrel}"
-source=("${_installer}::https://out7.hex-rays.com/files/${_originalname}"
- 'ida-free.desktop')
-sha256sums=('136e0e1995f16e1ff85244c269450fa91fb5454a565ca7623712f34ac004e245'
- '55f2ed3f165df6efb5f7975b17d8e53bee1d88cad33efb9d4422402213d17440')
+_installer='idademo74_linux.run'
+source=("$_installer"
+ "$pkgname.desktop")
+sha256sums=('547373518e2823a94195ea5e06cacf53c101610afa0f642204e7265f4b548045'
+ '5f51fea009781672998ffec1c1d63d392e87ac6eb04b637a1ee2827805b8e1db')
package() {
- install -d "${pkgdir}"/opt/${pkgname}
- install -d "${pkgdir}"/usr/bin
- install -d "${pkgdir}"/usr/share/{icons,applications,licenses/${pkgname}}
- install -d "${pkgdir}"/tmp
+ install -d "$pkgdir"/opt/"$pkgname"
+ install -d "$pkgdir"/usr/bin
+ install -d "$pkgdir"/usr/share/{icons,applications,licenses/"$pkgname"}
+ install -d "$pkgdir"/tmp
# chroot is needed to prevent the installer from creating a single file outside of prefix
# have to copy the installer due to chroot
- cp "${srcdir}"/${_installer} "${pkgdir}"/
- chmod +x "${pkgdir}"/${_installer}
- fakechroot chroot "${pkgdir}" /${_installer} --mode unattended --prefix /opt/${pkgname} --installpassword ""
- rm "${pkgdir}"/${_installer}
- rm "${pkgdir}"/tmp/bitrock_installer.log
- rmdir "${pkgdir}"/tmp
+ cp "$srcdir/$_installer" "$pkgdir"/
+ chmod +x "$pkgdir"/"$_installer"
+ fakechroot chroot "$pkgdir" /"$_installer" --mode unattended \
+ --prefix /opt/"$pkgname" --installpassword ""
+ rm "$pkgdir"/"$_installer"
+ rm "$pkgdir"/tmp/bitrock_installer.log
+ rmdir "$pkgdir"/tmp
# the installer needlessly makes a lot of files executable
- find "${pkgdir}"/opt/${pkgname} -type f -exec chmod -x {} \;
- chmod +x "${pkgdir}"/opt/${pkgname}/{ida64,assistant}
+ find "$pkgdir"/opt/"$pkgname" -type f -exec chmod -x {} \;
+ chmod +x "$pkgdir"/opt/"$pkgname"/{ida64,assistant}
- rm "${pkgdir}"/opt/${pkgname}/{uninstall*,Uninstall*}
+ rm "$pkgdir"/opt/"$pkgname"/{uninstall*,Uninstall*}
- install "${srcdir}"/ida-free.desktop "${pkgdir}"/usr/share/applications
- ln -s /opt/${pkgname}/appico64.png "${pkgdir}"/usr/share/icons/ida-free.png
- ln -s /opt/${pkgname}/license.txt "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
- ln -s /opt/${pkgname}/ida64 "${pkgdir}"/usr/bin/ida64
+ install "$srcdir"/"$pkgname".desktop "$pkgdir"/usr/share/applications
+ ln -s /opt/"$pkgname"/appico64.png "$pkgdir"/usr/share/icons/"$pkgname".png
+ ln -s /opt/"$pkgname"/license.txt "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+ ln -s /opt/"$pkgname"/ida64 "$pkgdir"/usr/bin/ida64-eval
}
diff --git a/ida-free.desktop b/ida-eval.desktop
index 122082e155fc..cadc2bacfff7 100644
--- a/ida-free.desktop
+++ b/ida-eval.desktop
@@ -1,8 +1,8 @@
[Desktop Entry]
-Name=IDA
+Name=IDA (Evaluation)
Comment=The Interactive Disassembler
-Exec=/opt/ida-free/ida64
-Icon=ida-free
+Exec=/opt/ida-eval/ida64
+Icon=ida-eval
Terminal=false
Type=Application
Categories=Development
diff --git a/idademo74_linux.run b/idademo74_linux.run
new file mode 100644
index 000000000000..537666de3f40
--- /dev/null
+++ b/idademo74_linux.run
@@ -0,0 +1 @@
+Download from https://out7.hex-rays.com/demo