summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfatalis2018-02-11 13:37:10 -0600
committerfatalis2018-02-11 13:37:10 -0600
commit5f9a5fad853e3bb81ba8d34b6155b7fa5d4e4cd3 (patch)
tree22752b22e41ad5a22cdf585f169ffdb81e5ef4d1
parentf0c0a83b11d1a8542ab2a92cde5bc1da7fe1e01a (diff)
downloadaur-5f9a5fad853e3bb81ba8d34b6155b7fa5d4e4cd3.tar.gz
Fix installer creating file outside of prefix
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a463da898474..605f49b1a7f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,8 +16,10 @@ package() {
install -d "${pkgdir}/usr/bin"
install -d "${pkgdir}/usr/share/"{icons,applications,licenses/${pkgname}}
+ # chroot is needed to prevent the installer from creating a single file outside of prefix
+ mkdir -p ../tmp
chmod +x ${_installer}
- ./${_installer} --mode unattended --prefix "${pkgdir}/opt/${pkgname}"
+ fakechroot chroot ../ /${_installer} --mode unattended --prefix "/pkg/${pkgname}/opt/${pkgname}"
install ../ida-free.desktop "${pkgdir}/usr/share/applications"
# the installer needlessly makes a lot of files executable