summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfatalis2018-02-02 16:27:17 -0600
committerfatalis2018-02-02 16:27:17 -0600
commitcc0dcdc370e0fc320af39e49e6f789ea290f6640 (patch)
tree409b2d62c84feba179481099b58c224733924876
downloadaur-cc0dcdc370e0fc320af39e49e6f789ea290f6640.tar.gz
Initial commit of v7.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD32
-rw-r--r--ida-free.desktop8
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d67b57da515f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = ida-free
+ pkgdesc = Freeware version of the world's smartest and most feature-full disassembler
+ pkgver = 7.0
+ pkgrel = 1
+ url = https://www.hex-rays.com/products/ida/
+ arch = x86_64
+ license = custom
+ options = !strip
+ source = https://out7.hex-rays.com/files/idafree70_linux.run
+ sha256sums = 6e589aa5dfe20ab3028aeb3ba4c1c4f1d987522a6f1d7ad4861240be7851178f
+
+pkgname = ida-free
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8cd719b5aff1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: fatalis <fatalis@fatalis.pw>
+pkgname=ida-free
+pkgver=7.0
+pkgrel=1
+pkgdesc="Freeware version of the world's smartest and most feature-full disassembler"
+arch=('x86_64')
+url='https://www.hex-rays.com/products/ida/'
+license=('custom')
+options=('!strip')
+_installer='idafree70_linux.run'
+source=("https://out7.hex-rays.com/files/${_installer}")
+sha256sums=('6e589aa5dfe20ab3028aeb3ba4c1c4f1d987522a6f1d7ad4861240be7851178f')
+
+package() {
+ install -d "${pkgdir}/opt/${pkgname}"
+ install -d "${pkgdir}/usr/bin"
+ install -d "${pkgdir}/usr/share/"{icons,applications,licenses/${pkgname}}
+
+ chmod +x ${_installer}
+ ./${_installer} --mode unattended --prefix "${pkgdir}/opt/${pkgname}"
+ install ../ida-free.desktop "${pkgdir}/usr/share/applications"
+
+ # the installer needlessly makes a lot of files executable
+ find "${pkgdir}/opt/${pkgname}" -type f -exec chmod -x {} \;
+ chmod +x "${pkgdir}/opt/${pkgname}/ida64"
+
+ rm "${pkgdir}/opt/${pkgname}/"{uninstall*,Uninstall*,assistant}
+
+ ln -s /opt/${pkgname}/appico64.png "${pkgdir}/usr/share/icons/ida-free.png"
+ ln -s /opt/${pkgname}/license.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ ln -s /opt/${pkgname}/ida64 "${pkgdir}/usr/bin/ida64"
+}
diff --git a/ida-free.desktop b/ida-free.desktop
new file mode 100644
index 000000000000..122082e155fc
--- /dev/null
+++ b/ida-free.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=IDA
+Comment=The Interactive Disassembler
+Exec=/opt/ida-free/ida64
+Icon=ida-free
+Terminal=false
+Type=Application
+Categories=Development