summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfab312018-01-09 18:44:12 +0100
committerfab312018-01-09 18:44:12 +0100
commita4bf46fb2cd616597afe59c25575920c3d7ab405 (patch)
tree001f045d3725c20096d288ffe5724bc5c56767ab
downloadaur-a4bf46fb2cd616597afe59c25575920c3d7ab405.tar.gz
initial release
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD36
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5da642368ced
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ideamaker-rc
+ pkgdesc = Fast and user friendly 3D slicer for FDM printers
+ pkgver = 3.0.5
+ pkgrel = 1
+ url = https://www.raise3d.com/pages/ideamaker
+ arch = x86_64
+ license = other
+ makedepends = binutils
+ depends = mesa-libgl
+ depends = desktop-file-utils
+ provides = ideamaker
+ source = https://s3.amazonaws.com/ideamaker/linux/ideaMaker_3.0.5-ubuntu_amd64.deb
+ md5sums = 281e12871381ea0d1dd4219191b6759d
+
+pkgname = ideamaker-rc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..165678089292
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Fabien Devaux <fdev31@gmail.com>
+pkgname=ideamaker-rc
+pkgver=3.0.5
+pkgrel=1
+epoch=
+pkgdesc="Fast and user friendly 3D slicer for FDM printers"
+arch=('x86_64')
+url="https://www.raise3d.com/pages/ideamaker"
+license=('other')
+groups=()
+depends=('mesa-libgl' 'desktop-file-utils')
+makedepends=('binutils')
+checkdepends=()
+optdepends=()
+provides=(ideamaker)
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://s3.amazonaws.com/ideamaker/linux/ideaMaker_${pkgver}-ubuntu_amd64.deb")
+noextract=()
+md5sums=('281e12871381ea0d1dd4219191b6759d')
+validpgpkeys=()
+
+package() {
+ tar xf "$srcdir/data.tar.xz" -C "${pkgdir}"
+ mkdir -p "${pkgdir}/usr/bin"
+ ln -fs "/usr/lib/x86_64-linux-gnu/ideamaker/ideamaker-start.sh" "${pkgdir}/usr/bin/ideamaker"
+}