summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPieter Goetschalckx2020-10-03 04:33:21 +0200
committerPieter Goetschalckx2020-10-03 04:33:21 +0200
commit4e76214aaa6413e2df0a5f1b1ed59951891749f0 (patch)
tree3bfb7f167d8d2fdb130b9693b4cafa036668f7eb
parentf1399bb7562cb367cdbea2bf165d67908e4e00ef (diff)
downloadaur-4e76214aaa6413e2df0a5f1b1ed59951891749f0.tar.gz
Solve conflict with mesa-demos
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d76a8033ecf..74af3199be19 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = identity
pkgdesc = Compare multiple versions of an image or video
pkgver = 0.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.gnome.org/YaLTeR/identity
arch = x86_64
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index c7c94ab62075..806dcf70395c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=identity
pkgver=0.1.0
-pkgrel=1
+pkgrel=2
pkgdesc='Compare multiple versions of an image or video'
arch=(x86_64)
url=https://gitlab.gnome.org/YaLTeR/identity
@@ -18,6 +18,13 @@ makedepends=(
source=(https://gitlab.gnome.org/YaLTeR/${pkgname}/-/archive/v${pkgver}/${pkgname}-v${pkgver}.tar.gz)
sha256sums=('6d994ca2286976c8067076f323049a61a22ad4c5a3b2449265d33b5f57c3292a')
+prepare() {
+ cd ${pkgname}-v${pkgver}
+ # Binary conflict with mesa-demos
+ sed -i "s/output: meson.project_name()/output: 'identity-compare'/g" src/meson.build
+ sed -i "s/Exec=identity/Exec=identity-compare/g" data/org.gnome.gitlab.YaLTeR.Identity.desktop.in.in
+}
+
build() {
arch-meson ${pkgname}-v${pkgver} build
meson compile -C build