summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortinywrkb2020-12-13 12:55:38 +0200
committertinywrkb2020-12-13 12:55:38 +0200
commit1258b4882525ff0be71d1fb8214821e26ae9d4f2 (patch)
tree1faf938e23b525894517d691b74858c1075cddfc
downloadaur-1258b4882525ff0be71d1fb8214821e26ae9d4f2.tar.gz
initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3c3063e4e327
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ideviceinstaller
+ pkgdesc = Manage Applications of an iPhone or iPod Touch
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = http://www.libimobiledevice.org/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = usbmuxd
+ depends = libzip
+ source = https://github.com/libimobiledevice/ideviceinstaller/archive/1.1.1.tar.gz
+ sha256sums = b1401678a61f28c4aca95375c100b5a83ccc2cdfa0222c0de7ad0a2cfb4e3c9f
+
+pkgname = ideviceinstaller
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7dcc7c504105
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: tinywrkb <tinywrkb@gmail.com>
+# Contributor: Joeny Ang <ang(dot)joeny(at)gmail(dot)com>
+# Contributor: Matías Hernández <msdark(at)archlinux(dot)cl>
+# Contributor: Hugo Ideler <hugoideler(at)dse(dot)nl>
+
+pkgname=ideviceinstaller
+pkgver=1.1.1
+pkgrel=1
+pkgdesc="Manage Applications of an iPhone or iPod Touch"
+arch=('i686' 'x86_64')
+url="http://www.libimobiledevice.org/"
+license=('GPL2')
+depends=('usbmuxd' 'libzip')
+source=("https://github.com/libimobiledevice/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('b1401678a61f28c4aca95375c100b5a83ccc2cdfa0222c0de7ad0a2cfb4e3c9f')
+
+build() {
+ cd ${pkgname}-${pkgver}
+
+ sed -i "/AS_COMPILER_FLAGS(/s/-Werror//" configure.ac
+ ./autogen.sh --prefix=/usr
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+
+ make DESTDIR=${pkgdir} install
+}