summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author0x9fff002020-08-01 20:06:20 +0200
committer0x9fff002020-08-01 20:06:20 +0200
commit45332a0133bdca4d34972160a05f1042c5d2fd61 (patch)
tree0d8a5122c6c33054aebc34eba1e894302c41a573
downloadaur-45332a0133bdca4d34972160a05f1042c5d2fd61.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore27
-rw-r--r--.gitignore_append1
-rw-r--r--0001-configure.ac-check-for-pthreads.patch25
-rw-r--r--PKGBUILD37
5 files changed, 111 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..869a922998c9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = idevicerestore
+ pkgdesc = Restore/upgrade firmware of iOS devices
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://www.libimobiledevice.org
+ arch = x86_64
+ license = LGPL3
+ depends = curl
+ depends = libimobiledevice
+ depends = libplist
+ depends = libirecovery
+ depends = libzip
+ depends = openssl
+ depends = zlib
+ source = https://github.com/libimobiledevice/idevicerestore/releases/download/1.0.0/idevicerestore-1.0.0.tar.bz2
+ source = 0001-configure.ac-check-for-pthreads.patch
+ sha256sums = 32712e86315397fd2e8999e77a2d2f790c67f6b4aa50d4d1c64cb2c4609836f7
+ sha256sums = fdf51e7f7105af048902fd18f950b6ed7c3f845fc80a225ba43709e9e48a42d5
+
+pkgname = idevicerestore
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f12030797c07
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,27 @@
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+*~
+
+# temporary files which can be created if a process still has a handle open of a deleted file
+.fuse_hidden*
+
+# KDE directory preferences
+.directory
+
+# Linux trash folder which might appear on any partition or disk
+.Trash-*
+
+# .nfs files are created when an open file is removed but is still being accessed
+.nfs*
+# archlinuxpackages linux
diff --git a/.gitignore_append b/.gitignore_append
new file mode 100644
index 000000000000..a92184e5a9bf
--- /dev/null
+++ b/.gitignore_append
@@ -0,0 +1 @@
+# archlinuxpackages linux
diff --git a/0001-configure.ac-check-for-pthreads.patch b/0001-configure.ac-check-for-pthreads.patch
new file mode 100644
index 000000000000..6259137460b8
--- /dev/null
+++ b/0001-configure.ac-check-for-pthreads.patch
@@ -0,0 +1,25 @@
+From bef683bd63ab686d273fb38b1430018c95daa16b Mon Sep 17 00:00:00 2001
+From: Ivan Shapovalov <intelfx100@gmail.com>
+Date: Fri, 25 Sep 2015 23:37:27 +0300
+Subject: [PATCH] configure.ac: check for pthreads
+
+Fixes building at least on Arch.
+---
+ configure.ac | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/configure.ac b/configure.ac
+index 7c4ad95..a8be5eb 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -35,6 +35,7 @@ AM_PROG_CC_C_O
+ AC_PROG_LIBTOOL
+
+ # Checks for libraries.
++AC_SEARCH_LIBS([pthread_create], [pthread])
+ PKG_CHECK_MODULES(libirecovery, libirecovery-1.0 >= $LIBIRECOVERY_VERSION)
+ PKG_CHECK_MODULES(libimobiledevice, libimobiledevice-1.0 >= $LIBIMOBILEDEVICE_VERSION)
+ PKG_CHECK_MODULES(libplist, libplist-2.0 >= $LIBPLIST_VERSION)
+--
+2.28.0
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d3875970fae7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: 0x9fff00 <0x9fff00+git@protonmail.ch>
+# Contributor: Ivan Shapovalov <intelfx@intelfx.name>
+# Contributor: Matthew Bauer <mjbauer95@gmail.com>
+
+pkgname=idevicerestore
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='Restore/upgrade firmware of iOS devices'
+arch=('x86_64')
+url='https://www.libimobiledevice.org'
+license=('LGPL3')
+depends=('curl' 'libimobiledevice' 'libplist' 'libirecovery' 'libzip' 'openssl' 'zlib')
+source=("https://github.com/libimobiledevice/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.bz2"
+ '0001-configure.ac-check-for-pthreads.patch')
+sha256sums=('32712e86315397fd2e8999e77a2d2f790c67f6b4aa50d4d1c64cb2c4609836f7'
+ 'fdf51e7f7105af048902fd18f950b6ed7c3f845fc80a225ba43709e9e48a42d5')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+
+ for p in "${srcdir}"/*.patch; do
+ patch -Np1 -i "${p}"
+ done
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir" install
+}