summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIvan Shapovalov2018-05-09 03:13:16 +0300
committerIvan Shapovalov2018-05-09 03:13:16 +0300
commit09b66c9c059629fde432078d64c61f71a4e55259 (patch)
tree230269ebe98e2a3155835933cb3a10f52aae31e9
parent36d53630efda0e6d9631d06664939a722ae99cf2 (diff)
downloadaur-09b66c9c059629fde432078d64c61f71a4e55259.tar.gz
Bump to r572.b8b3035; patch buildsystem to search for and link with zlib.
-rw-r--r--.SRCINFO4
-rw-r--r--0002-configure.ac-src-Makefile.am-check-for-and-link-with.patch40
-rw-r--r--PKGBUILD12
3 files changed, 51 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 12d330a5835d..33bc11235c48 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Tue Jan 10 00:05:31 UTC 2017
+# Wed May 9 00:11:38 UTC 2018
pkgbase = idevicerestore-git
pkgdesc = Restore/upgrade firmware of iOS devices
pkgver = r546.cae1734
@@ -19,8 +19,10 @@ pkgbase = idevicerestore-git
depends = curl
source = git+https://git.libimobiledevice.org/idevicerestore.git
source = 0001-configure.ac-check-for-pthreads.patch
+ source = 0002-configure.ac-src-Makefile.am-check-for-and-link-with.patch
sha256sums = SKIP
sha256sums = c259a9f977de42fbfde75ad0c9a4d813b7d39bf217ee416902409403cd6d7931
+ sha256sums = 2c4a09389f3e02e44971eeec06f1979188678dc82989e3fd311677172fb3401f
pkgname = idevicerestore-git
diff --git a/0002-configure.ac-src-Makefile.am-check-for-and-link-with.patch b/0002-configure.ac-src-Makefile.am-check-for-and-link-with.patch
new file mode 100644
index 000000000000..e852ce421e0f
--- /dev/null
+++ b/0002-configure.ac-src-Makefile.am-check-for-and-link-with.patch
@@ -0,0 +1,40 @@
+From 946e9161ae83d2c0fe5122fd53f2ace39a6b0a9a Mon Sep 17 00:00:00 2001
+From: Ivan Shapovalov <intelfx@intelfx.name>
+Date: Wed, 9 May 2018 03:09:09 +0300
+Subject: [PATCH] configure.ac, src/Makefile.am: check for and link with zlib
+
+Fixes building at least on Arch.
+---
+ configure.ac | 1 +
+ src/Makefile.am | 3 ++-
+ 2 files changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 2b31499..006d85d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -41,6 +41,7 @@ PKG_CHECK_MODULES(libplist, libplist >= $LIBPLIST_VERSION)
+ PKG_CHECK_MODULES(libzip, libzip >= $LIBZIP_VERSION)
+ PKG_CHECK_MODULES(libcurl, libcurl >= $LIBCURL_VERSION)
+ PKG_CHECK_MODULES(openssl, openssl >= $OPENSSL_VERSION)
++PKG_CHECK_MODULES(zlib, zlib)
+
+ GLOBAL_CFLAGS=""
+ AC_LDADD=""
+diff --git a/src/Makefile.am b/src/Makefile.am
+index f169708..f5a84a9 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -15,7 +15,8 @@ AM_LDFLAGS =\
+ $(libplist_LIBS) \
+ $(libzip_LIBS) \
+ $(openssl_LIBS) \
+- $(libcurl_LIBS)
++ $(libcurl_LIBS) \
++ $(zlib_LIBS)
+
+ AM_LDADD = $(AC_LDADD)
+
+--
+2.17.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 6b180b4741e7..1535047359de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=idevicerestore-git
epoch=1
-pkgver=r546.cae1734
+pkgver=r572.b8b3035
pkgrel=1
pkgdesc="Restore/upgrade firmware of iOS devices"
arch=('i686' 'x86_64')
@@ -12,9 +12,11 @@ license=('LGPL3')
depends=('libirecovery-git' 'libimobiledevice-git' 'libusbmuxd-git' 'libplist-git' 'libzip' 'openssl' 'curl')
makedepends=('git')
source=("git+https://git.libimobiledevice.org/idevicerestore.git"
- "0001-configure.ac-check-for-pthreads.patch")
+ "0001-configure.ac-check-for-pthreads.patch"
+ "0002-configure.ac-src-Makefile.am-check-for-and-link-with.patch")
sha256sums=('SKIP'
- 'c259a9f977de42fbfde75ad0c9a4d813b7d39bf217ee416902409403cd6d7931')
+ 'c259a9f977de42fbfde75ad0c9a4d813b7d39bf217ee416902409403cd6d7931'
+ '2c4a09389f3e02e44971eeec06f1979188678dc82989e3fd311677172fb3401f')
pkgver() {
cd idevicerestore
@@ -25,7 +27,9 @@ pkgver() {
prepare() {
cd idevicerestore
- patch -Np1 -i "${srcdir}/0001-configure.ac-check-for-pthreads.patch"
+ for p in "${srcdir}"/*.patch; do
+ patch -Np1 -i "${p}"
+ done
# sed -re 's|automake|& --add-missing|' -i autogen.sh
}