summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIvan Shapovalov2024-03-25 02:26:13 +0300
committerIvan Shapovalov2024-03-25 02:26:13 +0300
commit5e96b12687ab6dcb96509c821d1185e0fe9a2d31 (patch)
tree3483758063ff3d4f68565e8c8c07ef71156e07ea
parent20f6ddc51f71673f7e30f999e662a1f695934041 (diff)
downloadaur-5e96b12687ab6dcb96509c821d1185e0fe9a2d31.tar.gz
Drop obsolete patch, use `git apply -3`
-rw-r--r--.SRCINFO4
-rw-r--r--0002-configure.ac-accept-unreleased-libirecovery-1.0-1.0..patch35
-rw-r--r--PKGBUILD15
3 files changed, 9 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b194b96a18b4..e0168a52cd32 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = idevicerestore-git
pkgdesc = Restore/upgrade firmware of iOS devices
- pkgver = 1.0.0.r134.g163a164
+ pkgver = 1.0.0.r178.ge4a5ac4
pkgrel = 1
epoch = 1
url = http://www.libimobiledevice.org
@@ -17,9 +17,7 @@ pkgbase = idevicerestore-git
depends = libirecovery-git
source = git+https://github.com/libimobiledevice/idevicerestore
source = 0001-configure.ac-check-for-pthreads.patch
- source = 0002-configure.ac-accept-unreleased-libirecovery-1.0-1.0..patch
sha256sums = SKIP
sha256sums = d7fcc4e46a175d309298bd95d330c027fcca7dba3226f3e1b802c8ebe8d8ed15
- sha256sums = b1348ccc86d0ccbbc5bf6fa4e2027b0303a52673431ace50cc1e0ef8a6171305
pkgname = idevicerestore-git
diff --git a/0002-configure.ac-accept-unreleased-libirecovery-1.0-1.0..patch b/0002-configure.ac-accept-unreleased-libirecovery-1.0-1.0..patch
deleted file mode 100644
index 4465c4b02741..000000000000
--- a/0002-configure.ac-accept-unreleased-libirecovery-1.0-1.0..patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 3d389b0735cf2b46a1c747e3fe9f09a5410e7eaf Mon Sep 17 00:00:00 2001
-From: Ivan Shapovalov <intelfx@intelfx.name>
-Date: Fri, 5 May 2023 18:42:52 +0300
-Subject: [PATCH 2/2] configure.ac: accept unreleased libirecovery-1.0 =
- 1.0.0-<n>
-
----
- configure.ac | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 74782f5..d97959d 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -15,7 +15,7 @@ if test -z $PACKAGE_VERSION; then
- fi
-
- # Minimum package versions
--LIBIRECOVERY_VERSION=1.0.1
-+LIBIRECOVERY_VERSION=1.0.0
- LIBIMOBILEDEVICE_VERSION=1.3.0
- LIBPLIST_VERSION=2.3.0
- LIMD_GLUE_VERSION=1.0.0
-@@ -38,7 +38,7 @@ LT_INIT
-
- # Checks for libraries.
- AC_SEARCH_LIBS([pthread_create], [pthread])
--PKG_CHECK_MODULES(libirecovery, libirecovery-1.0 >= $LIBIRECOVERY_VERSION)
-+PKG_CHECK_MODULES(libirecovery, libirecovery-1.0 > $LIBIRECOVERY_VERSION)
- PKG_CHECK_MODULES(libimobiledevice, libimobiledevice-1.0 >= $LIBIMOBILEDEVICE_VERSION)
- PKG_CHECK_MODULES(libplist, libplist-2.0 >= $LIBPLIST_VERSION)
- PKG_CHECK_MODULES(limd_glue, libimobiledevice-glue-1.0 >= $LIMD_GLUE_VERSION)
---
-2.40.1
-
diff --git a/PKGBUILD b/PKGBUILD
index ece00cd772c7..27b3be46897b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=idevicerestore-git
epoch=1
-pkgver=1.0.0.r134.g163a164
+pkgver=1.0.0.r178.ge4a5ac4
pkgrel=1
pkgdesc="Restore/upgrade firmware of iOS devices"
arch=('i686' 'x86_64')
@@ -12,11 +12,9 @@ license=('LGPL3')
depends=('libzip' 'openssl' 'curl' 'libimobiledevice-glue-git' 'libplist-git' 'libimobiledevice-git' 'libirecovery-git')
makedepends=('git')
source=("git+https://github.com/libimobiledevice/idevicerestore"
- '0001-configure.ac-check-for-pthreads.patch'
- '0002-configure.ac-accept-unreleased-libirecovery-1.0-1.0..patch')
+ '0001-configure.ac-check-for-pthreads.patch')
sha256sums=('SKIP'
- 'd7fcc4e46a175d309298bd95d330c027fcca7dba3226f3e1b802c8ebe8d8ed15'
- 'b1348ccc86d0ccbbc5bf6fa4e2027b0303a52673431ace50cc1e0ef8a6171305')
+ 'd7fcc4e46a175d309298bd95d330c027fcca7dba3226f3e1b802c8ebe8d8ed15')
pkgver() {
cd idevicerestore
@@ -25,8 +23,11 @@ pkgver() {
prepare() {
cd idevicerestore
- for p in "${srcdir}"/*.patch; do
- patch -Np1 -i "${p}"
+
+ for p in "${source[@]}"; do
+ if [[ ${p} == *.patch ]]; then
+ git apply -3 "${srcdir}/${p}"
+ fi
done
NOCONFIGURE=1 ./autogen.sh
}