summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIvan Shapovalov2015-11-19 14:46:12 +0300
committerIvan Shapovalov2015-11-19 14:49:02 +0300
commitce689df20324704201a93006657098929e241e37 (patch)
tree2cb8fb2bc0aaa8a5e154061dbd02792195f893a1
parent5a068fabc10b2c5b3b9fc36905890feff6578480 (diff)
downloadaur-ce689df20324704201a93006657098929e241e37.tar.gz
Bump to r527.e2e83dc; patch build system to link to pthread.
-rw-r--r--.SRCINFO6
-rw-r--r--0001-configure.ac-check-for-pthreads.patch25
-rw-r--r--PKGBUILD9
3 files changed, 35 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a6f87695e7e9..5677c1ecba8c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = idevicerestore-git
pkgdesc = Restore/upgrade firmware of iOS devices
- pkgver = r497.861f45c
+ pkgver = r527.e2e83dc
pkgrel = 1
epoch = 1
url = http://www.libimobiledevice.org
@@ -15,7 +15,9 @@ pkgbase = idevicerestore-git
depends = openssl
depends = curl
source = git://git.sukimashita.com/idevicerestore.git
- md5sums = SKIP
+ source = 0001-configure.ac-check-for-pthreads.patch
+ sha256sums = SKIP
+ sha256sums = c259a9f977de42fbfde75ad0c9a4d813b7d39bf217ee416902409403cd6d7931
pkgname = idevicerestore-git
diff --git a/0001-configure.ac-check-for-pthreads.patch b/0001-configure.ac-check-for-pthreads.patch
new file mode 100644
index 000000000000..de2f7c5120e9
--- /dev/null
+++ b/0001-configure.ac-check-for-pthreads.patch
@@ -0,0 +1,25 @@
+From 162a079123f81f14287dcd6d3e5b4488dc6981ee Mon Sep 17 00:00:00 2001
+From: Ivan Shapovalov <intelfx100@gmail.com>
+Date: Fri, 25 Sep 2015 23:37:27 +0300
+Subject: [PATCH] configure.ac: check for pthreads
+
+Fixes building at least on Arch.
+---
+ configure.ac | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/configure.ac b/configure.ac
+index d36cc67..950ef02 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -35,6 +35,7 @@ AM_PROG_CC_C_O
+ AC_PROG_LIBTOOL
+
+ # Checks for libraries.
++AC_SEARCH_LIBS([pthread_create], [pthread])
+ PKG_CHECK_MODULES(libirecovery, libirecovery >= $LIBIRECOVERY_VERSION)
+ PKG_CHECK_MODULES(libimobiledevice, libimobiledevice-1.0 >= $LIBIMOBILEDEVICE_VERSION)
+ PKG_CHECK_MODULES(libplist, libplist >= $LIBPLIST_VERSION)
+--
+2.6.2
+
diff --git a/PKGBUILD b/PKGBUILD
index 42da9ee14663..3090ee2013cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=idevicerestore-git
epoch=1
-pkgver=r497.861f45c
+pkgver=r527.e2e83dc
pkgrel=1
pkgdesc="Restore/upgrade firmware of iOS devices"
arch=('i686' 'x86_64')
@@ -11,8 +11,10 @@ url="http://www.libimobiledevice.org"
license=('LGPL3')
depends=('libirecovery-git' 'libimobiledevice-git' 'libplist-git' 'libzip' 'openssl' 'curl')
makedepends=('git')
-source=("git://git.sukimashita.com/idevicerestore.git")
-md5sums=('SKIP')
+source=("git://git.sukimashita.com/idevicerestore.git"
+ "0001-configure.ac-check-for-pthreads.patch")
+sha256sums=('SKIP'
+ 'c259a9f977de42fbfde75ad0c9a4d813b7d39bf217ee416902409403cd6d7931')
pkgver() {
cd idevicerestore
@@ -23,6 +25,7 @@ pkgver() {
prepare() {
cd idevicerestore
+ patch -Np1 -i "${srcdir}/0001-configure.ac-check-for-pthreads.patch"
# sed -re 's|automake|& --add-missing|' -i autogen.sh
}