summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302022-01-08 07:52:14 +0100
committerGianluca Boiano2022-01-08 07:52:14 +0100
commit0d5a0c0c9575b62711a9cea305eaa06ce0e8c49e (patch)
tree6c1af4468f8ea5556270fa80e495e0f277a61804
parentd8c61c19d853b89c5dbc5f4c5dbc55442ca08dd5 (diff)
downloadaur-0d5a0c0c9575b62711a9cea305eaa06ce0e8c49e.tar.gz
idjc: fix for python 3.10 MutableSet
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
-rw-r--r--python3.10.patch30
3 files changed, 44 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a2d58c683a9b..16a64211107d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = idjc
pkgdesc = Powerful client for individuals interested in streaming live radio shows
pkgver = 0.9.2
- pkgrel = 1
+ pkgrel = 2
url = http://idjc.sourceforge.net/
arch = i686
arch = x86_64
@@ -27,6 +27,8 @@ pkgbase = idjc
optdepends = python-irc: IRC notification support
conflicts = idjc-git
source = http://downloads.sourceforge.net/idjc/idjc-0.9.2.tar.gz
+ source = python3.10.patch
sha256sums = 4762cda6eb6428a06ba3837d0cb40f47218c344293e4997b91f4ec0479933c03
+ sha256sums = 94384a7b30b71c165ee8b0c49c8f0aa1f2b28cfd2685a6db5fad5751d621572c
pkgname = idjc
diff --git a/PKGBUILD b/PKGBUILD
index 5996fbba6d90..4b610ff38f02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=idjc
pkgver=0.9.2
-pkgrel=1
+pkgrel=2
pkgdesc='Powerful client for individuals interested in streaming live radio shows'
url='http://idjc.sourceforge.net/'
license=('GPL2')
@@ -32,7 +32,14 @@ depends=(
optdepends=('mysql-python: Ampache and Prokyon 3 support'
'python-irc: IRC notification support')
conflicts=('idjc-git')
-source=("http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+source=("http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+ "python3.10.patch"
+)
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -Np1 -i ../python3.10.patch
+}
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -53,4 +60,5 @@ package() {
"${pkgdir}/usr/share/applications/${pkgname}.desktop"
}
-sha256sums=('4762cda6eb6428a06ba3837d0cb40f47218c344293e4997b91f4ec0479933c03')
+sha256sums=('4762cda6eb6428a06ba3837d0cb40f47218c344293e4997b91f4ec0479933c03'
+ '94384a7b30b71c165ee8b0c49c8f0aa1f2b28cfd2685a6db5fad5751d621572c')
diff --git a/python3.10.patch b/python3.10.patch
new file mode 100644
index 000000000000..88b833b6ede4
--- /dev/null
+++ b/python3.10.patch
@@ -0,0 +1,30 @@
+--- a/python/midicontrols.py
++++ b/python/midicontrols.py
+@@ -20,9 +20,9 @@
+ import re
+ import os.path
+ import time
+-import collections
+ import gettext
+ import functools
++from collections.abc import MutableSet
+
+ import gi
+ from gi.repository import GObject
+@@ -496,7 +496,7 @@
+ # Controls ___________________________________________________________________
+
+
+-class RepeatCache(collections.MutableSet):
++class RepeatCache(MutableSet):
+ """A smart keyboard repeat cache -- implements time to live.
+
+ Downstrokes are logged along with the time. Additional downstrokes
+@@ -2173,7 +2173,7 @@
+ it = Gtk.TreeIter()
+ self.set_user_data(it, user_data)
+ return it
+-
++
+ def do_get_flags(self):
+ return Gtk.TreeModelFlags.LIST_ONLY | Gtk.TreeModelFlags.ITERS_PERSIST