summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302015-06-17 15:40:06 +0200
committerM0Rf302015-06-17 15:40:06 +0200
commit46fa2e8873d93b986a762ee8fbe0a9c109495c66 (patch)
tree9702e8917fc7369514eb6b97b548df3483d67c83
downloadaur-46fa2e8873d93b986a762ee8fbe0a9c109495c66.tar.gz
Initial import
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD36
-rw-r--r--idjc.install11
3 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e891bfb07c05
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = idjc
+ pkgdesc = Powerful client for individuals interested in streaming live radio shows
+ pkgver = 0.8.14
+ pkgrel = 2
+ url = http://idjc.sourceforge.net/
+ install = idjc.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = desktop-file-utils
+ depends = python2
+ depends = dbus-python
+ depends = mutagen
+ depends = jack
+ depends = pygtk
+ depends = vorbis-tools
+ depends = libsndfile
+ depends = libsamplerate
+ depends = glib2
+ depends = lame
+ depends = libmad
+ depends = ffmpeg
+ depends = flac
+ depends = speex
+ depends = libshout-idjc
+ depends = twolame
+ optdepends = mysql-python: Ampache and Prokyon 3 support
+ conflicts = idjc-git
+ source = http://downloads.sourceforge.net/idjc/idjc-0.8.14.tar.gz
+ md5sums = 0b1068b5be415a73288f8f9bd449c69c
+
+pkgname = idjc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5cb934641692
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: M0Rf30 Contributor: Tobias Luther <tobias [at] tonstrom [dot] de> Contributor: GraveDigger Contributor: Gaetan Bisson <bisson@archlinux.org>
+
+pkgname=idjc
+pkgver=0.8.14
+pkgrel=2
+pkgdesc='Powerful client for individuals interested in streaming live radio shows'
+url='http://idjc.sourceforge.net/'
+license=('GPL2')
+arch=('i686' 'x86_64')
+depends=('desktop-file-utils' 'python2' 'dbus-python' 'mutagen' 'jack' 'pygtk' 'vorbis-tools' 'libsndfile' 'libsamplerate' 'glib2' 'lame' 'libmad' 'ffmpeg' 'flac' 'speex' 'libshout-idjc' 'twolame')
+optdepends=('mysql-python: Ampache and Prokyon 3 support')
+conflicts=('idjc-git')
+install=${pkgname}.install
+source=("http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ export PYTHON=/usr/bin/python2
+ ./configure \
+ --prefix=/usr \
+ --libexecdir=/usr/lib \
+ --disable-static
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+
+ sed -i 's|#! /usr/bin/python22.7|#! /usr/bin/python2|' ${pkgdir}/usr/bin/idjc
+}
+
+md5sums=('0b1068b5be415a73288f8f9bd449c69c')
diff --git a/idjc.install b/idjc.install
new file mode 100644
index 000000000000..9834cb7dd948
--- /dev/null
+++ b/idjc.install
@@ -0,0 +1,11 @@
+post_upgrade() {
+ update-desktop-database -q
+}
+
+post_install() {
+ post_upgrade
+}
+
+post_remove() {
+ post_upgrade
+}