summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302023-10-03 20:09:39 +0200
committerM0Rf302023-10-03 20:09:39 +0200
commit58aecb9d2f840927530b75e2f3d4a8541ec1e492 (patch)
tree2ecf3a49d9fe7b54123991cd9201046c037fd5d4
parent3d83b2f1ff6ec875a9b8608a1b08b6889da39553 (diff)
downloadaur-58aecb9d2f840927530b75e2f3d4a8541ec1e492.tar.gz
idjc: 0.9.6
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
-rw-r--r--getargspec.patch11
3 files changed, 8 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 751c6f11499e..5926ce0520b3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = idjc
pkgdesc = Powerful client for individuals interested in streaming live radio shows
- pkgver = 0.9.5
- pkgrel = 2
+ pkgver = 0.9.6
+ pkgrel = 1
url = http://idjc.sourceforge.net/
arch = i686
arch = x86_64
@@ -26,9 +26,7 @@ pkgbase = idjc
optdepends = python-mysqlclient: Ampache and Prokyon 3 support
optdepends = python-irc: IRC notification support
conflicts = idjc-git
- source = http://downloads.sourceforge.net/idjc/idjc-0.9.5.tar.gz
- source = getargspec.patch
- sha256sums = 6c15d1b7e034220a21dd656dcf2e8e36202090968ac4840095ec18f43b3617f4
- sha256sums = 93dbe6545764e82d3c707286ed6f42b2a71f4a61567e6ce13e25a102370fabb5
+ source = http://downloads.sourceforge.net/idjc/idjc-0.9.6.tar.gz
+ sha256sums = 71328e2e253cc877f82e41a8808e481f0785f3a8b0117c874ce6e19b5f277568
pkgname = idjc
diff --git a/PKGBUILD b/PKGBUILD
index 80dfa5d407b7..fb5e9ec0d2e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Contributor: Gaetan Bisson <bisson@archlinux.org>
pkgname=idjc
-pkgver=0.9.5
-pkgrel=2
+pkgver=0.9.6
+pkgrel=1
pkgdesc='Powerful client for individuals interested in streaming live radio shows'
url='http://idjc.sourceforge.net/'
license=('GPL2')
@@ -32,14 +32,7 @@ depends=(
optdepends=('python-mysqlclient: Ampache and Prokyon 3 support'
'python-irc: IRC notification support')
conflicts=('idjc-git')
-source=("http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz"
- getargspec.patch)
-
-prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- patch -Np1 -i ../getargspec.patch
-}
+source=("http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz")
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -60,5 +53,4 @@ package() {
"${pkgdir}/usr/share/applications/${pkgname}.desktop"
}
-sha256sums=('6c15d1b7e034220a21dd656dcf2e8e36202090968ac4840095ec18f43b3617f4'
- '93dbe6545764e82d3c707286ed6f42b2a71f4a61567e6ce13e25a102370fabb5')
+sha256sums=('71328e2e253cc877f82e41a8808e481f0785f3a8b0117c874ce6e19b5f277568')
diff --git a/getargspec.patch b/getargspec.patch
deleted file mode 100644
index 21a61d071e9f..000000000000
--- a/getargspec.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/python/irc.py 2023-09-08 14:54:45.736947800 +0200
-+++ b/python/irc.py 2023-09-08 14:55:14.064954979 +0200
-@@ -23,7 +23,7 @@
- import threading
- import traceback
- import gettext
--from inspect import getargspec
-+from inspect import getfullargspec
- from functools import wraps, partial
- from itertools import chain
-