summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjmcb2022-10-13 15:41:12 +0100
committerjmcb2022-10-13 15:41:12 +0100
commitf2828553c179933e719c0d95a13ebdfa034c60b8 (patch)
tree7e6a516b693d6bbd0dced4d9221f87375e96edce
parent795f01bf17c1a8f4c1da71ce7cfdc5c19f8ba23e (diff)
downloadaur-f2828553c179933e719c0d95a13ebdfa034c60b8.tar.gz
Better icons
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0be07bda70dc..942c5412d438 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,8 @@ arch=('any')
url="https://packages.debian.org/stable/python/idle"
license=("Python")
groups=()
-depends=('python>=3.10' 'python<3.11')
+depends=('python>=3.10' 'python<3.11'
+ 'hicolor-icon-theme')
optdepends=()
provides=()
conflicts=('idle3'
@@ -18,8 +19,11 @@ sha256sums=('8bbde2b6be32cd47bc4547fb941466fc89d13f2538a2c30594e5e21d83ca0800')
package() {
- install -Dm755 idle.desktop "${pkgdir}/usr/share/applications/idle.desktop"
- _icons_dir="${pkgdir}/usr/share/pixmaps"
- install -dm755 "${_icons_dir}"
- ln -s /usr/lib/python3.10/idlelib/Icons/idle_256.png "${_icons_dir}/idle.png"
+ install -Dm644 ${pkgname}.desktop "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+
+ for _icon in 16 32 48 256; do
+ _icon_dir="${pkgdir}/usr/share/icons/hicolor/${_icon}x${_icon}/apps"
+ install -dm644 "${_icon_dir}"
+ ln -s /usr/lib/python3.10/idlelib/Icons/idle_${_icon}.png "${_icon_dir}/${pkgname}.png"
+ done
}