summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrobot Viktor2019-04-12 13:13:24 +0300
committerDrobot Viktor2019-04-12 13:13:24 +0300
commit15ba07d0cafb9cf8bd29c2e0a7daf57e6e348d8d (patch)
tree21cc2197d4c486f36457e8f06b6070a313d3d11b
parentea02f4ca86a09e668131414b74ad6a030b35910d (diff)
downloadaur-15ba07d0cafb9cf8bd29c2e0a7daf57e6e348d8d.tar.gz
Bump to 2.3
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD36
2 files changed, 28 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a424c4e5470b..010f010a4d6a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
pkgbase = idnkit
pkgdesc = Provides functionalities about Internationalized Domain Name processing
- pkgver = 1.0
- pkgrel = 4
+ pkgver = 2.3
+ pkgrel = 1
url = https://www.nic.ad.jp/ja/idn/idnkit/download/
arch = x86_64
license = custom:BSD
depends = glibc
options = !makeflags
backup = etc/idnalias.conf
- backup = etc/idn.conf
- source = https://www.nic.ad.jp/ja/idn/idnkit/download/sources/idnkit-1.0-src.tar.gz
- sha1sums = 7d843ffcf9843b7af02079e5a160520f28c75048
+ backup = etc/idn2.conf
+ source = http://jprs.co.jp/idn/idnkit-2.3.tar.bz2
+ source = http://jprs.co.jp/idn/idnkit-doc-2.3.tar.bz2
+ sha1sums = ec256455d801af3b666d65eb7c01b6086ab6a743
+ sha1sums = abf032cde1bef9dbd0bfddd85ee525c7f1012ac2
pkgname = idnkit
diff --git a/PKGBUILD b/PKGBUILD
index 3170dcf76374..fba5453bdd39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,49 @@
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
# Contributor: Igor Nemilentsev <trezorg@gmail.com>
-# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+# Contributor: Gaetan Bisson <bisson@archlinux.org>
pkgname=idnkit
-pkgver=1.0
-pkgrel=4
+pkgver=2.3
+pkgrel=1
pkgdesc='Provides functionalities about Internationalized Domain Name processing'
url='https://www.nic.ad.jp/ja/idn/idnkit/download/'
license=('custom:BSD')
arch=('x86_64')
depends=('glibc')
-backup=('etc/idnalias.conf' 'etc/idn.conf')
+backup=('etc/idnalias.conf' 'etc/idn2.conf')
options=('!makeflags')
-source=("https://www.nic.ad.jp/ja/idn/idnkit/download/sources/idnkit-${pkgver}-src.tar.gz")
-sha1sums=('7d843ffcf9843b7af02079e5a160520f28c75048')
+source=("http://jprs.co.jp/idn/${pkgname}-${pkgver}.tar.bz2"
+ "http://jprs.co.jp/idn/${pkgname}-doc-${pkgver}.tar.bz2")
+sha1sums=('ec256455d801af3b666d65eb7c01b6086ab6a743'
+ 'abf032cde1bef9dbd0bfddd85ee525c7f1012ac2')
prepare() {
- cd idnkit-${pkgver}-src
+ cd ${srcdir}/${pkgname}-${pkgver}
sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" configure
}
build() {
- cd idnkit-${pkgver}-src
+ cd ${srcdir}/${pkgname}-${pkgver}
./configure \
--prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
- --mandir=/usr/share/man \
--enable-static=no
make
}
-check() {
- cd idnkit-${pkgver}-src
- make check
-}
-
package() {
- cd idnkit-${pkgver}-src
+ # install base
+ cd ${srcdir}/${pkgname}-${pkgver}
make DESTDIR="${pkgdir}" install
+
+ # install doc
+ cd ${srcdir}/${pkgname}-doc-${pkgver}
+ make install docdir=${pkgdir}/usr/share/doc/${pkgname}
+
+ # install license
install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ # cleanup
rm "${pkgdir}"/etc/*.sample
}