summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfelics2019-08-29 18:01:18 +0200
committerfelics2019-08-29 18:01:18 +0200
commit5e52eb54f754dad759d8e49e8831288674cbcb88 (patch)
tree5f543d3d8f5c0ed6e66ffa7c26dc5ed435655360
parent63673e64ba60ecd649645795a14ad2292aa857f9 (diff)
downloadaur-5e52eb54f754dad759d8e49e8831288674cbcb88.tar.gz
Fixed permissions for $pkgver.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5fd086c1fa24..0451501ff118 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = idos-package-updater-script
pkgdesc = Bash script which automates the process of updating installed IDOS timetable browser related packages by reinstalling and thus fetching the newest version.
pkgver = 20190825.1
- pkgrel = 2
+ pkgrel = 4
epoch = 0
arch = any
groups = idos-timetable
diff --git a/PKGBUILD b/PKGBUILD
index 7918f101dcf5..5b6e7a5131a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _pkgname=idos-package-updater-script
pkgname="${_pkgname}"
epoch=0
pkgver=20190825.1
-pkgrel=2
+pkgrel=4
pkgdesc="Bash script which automates the process of updating installed IDOS timetable browser related packages by reinstalling and thus fetching the newest version."
arch=('any')
license=('custom')
@@ -49,6 +49,11 @@ pkgver() {
}
+prepare() {
+ chmod a+x "${srcdir}/idos-packages-update.sh"
+}
+
+
package() {
_instdirbase='/opt/idos-timetable'
_instdir="${pkgdir}/${_instdirbase}"