summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgit user2023-11-20 20:25:23 +0100
committergit user2023-11-20 20:25:23 +0100
commit20a29b64f677ba526b0eb255237e157e6096b575 (patch)
tree2ea345317e0c6ab64155ef6b2a4739e14fbdf497
downloadaur-20a29b64f677ba526b0eb255237e157e6096b575.tar.gz
Initial Commit.
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD83
-rw-r--r--license-dummy.txt10
3 files changed, 118 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..90c3674dfc16
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = idos-timetable-additionalinfo-chaps-trains-2022
+ pkgdesc = Links for additional information on Czech trains and railway stations, to be used with the timetable search engines by CHAPS. Data from 2022.
+ pkgver = 2022_04_05
+ pkgrel = 1
+ epoch = 0
+ url = https://chaps.cz/eng/download/idos/zip#kotvainf
+ arch = any
+ groups = idos-timetable
+ license = custom
+ makedepends = wget
+ depends = idos-timetable-data-trains-cz
+ provides = idos-timetable-additionalinfo-chaps-trains=2022_04_05
+ provides = idos-timetable-additionalinfo-trains=2022_04_05
+ provides = idos-timetable-additionalinfo-trains-cz=2022_04_05
+ conflicts = idos-timetable-additionalinfo-chaps-trains
+ replaces = idos-timetable-additionalinfo-chaps-trains-latest<2023
+ options = !strip
+ source = c1-2022_04_05.zip::http://web.archive.org/web/20220405204613/http://ttakt.chaps.cz/TTAktual/Win/Zip/C1.ZIP
+ source = IDOS-Licence.pdf::http://web.archive.org/web/20210904102649/https://www.chaps.cz/files/idos/IDOS-Licence.pdf
+ source = license-dummy.txt
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = c6bb216055d3670d3100b7a74e04ce0644030f365f4349a09e630ef60fbcb9a4
+
+pkgname = idos-timetable-additionalinfo-chaps-trains-2022
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..17d76eb99892
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,83 @@
+# Maintainer: dreieck
+
+## `PKGBUILD` last updated: >= 2023-11-20.
+
+url="https://chaps.cz/eng/download/idos/zip#kotvainf"
+_zipfile="C1.ZIP"
+_pkgname=idos-timetable-additionalinfo-chaps-trains
+pkgname="${_pkgname}-2022"
+epoch=0
+_pkgver='2022_04_05'
+pkgver="${_pkgver}"
+pkgrel=1
+pkgdesc="Links for additional information on Czech trains and railway stations, to be used with the timetable search engines by CHAPS. Data from 2022."
+arch=('any')
+license=('custom')
+
+groups=(
+ "idos-timetable"
+ )
+depends=(
+ "idos-timetable-data-trains-cz"
+ )
+
+makedepends=(
+ "wget"
+)
+
+optdepends=()
+
+replaces=(
+ "${_pkgname}-latest<2023" # In 2023, this data seems to have vanished from `https://chaps.cz/eng/download/idos/zip#kotvainf`. So this package here is to replace the `-latest` package which is deprecated and is about to be deleted.
+)
+
+options=('!strip')
+
+provides=(
+ "${_pkgname}=${pkgver}"
+
+ "idos-timetable-additionalinfo-trains=${pkgver}"
+
+ "idos-timetable-additionalinfo-trains-cz=${pkgver}"
+)
+
+conflicts=(
+ "${_pkgname}"
+)
+
+_target="c1-${_pkgver}.zip"
+
+source=(
+ "${_target}::http://web.archive.org/web/20220405204613/http://ttakt.chaps.cz/TTAktual/Win/Zip/${_zipfile}"
+ "IDOS-Licence.pdf::http://web.archive.org/web/20210904102649/https://www.chaps.cz/files/idos/IDOS-Licence.pdf"
+ "license-dummy.txt"
+)
+
+sha256sums=(
+ 'SKIP'
+ "SKIP"
+ "c6bb216055d3670d3100b7a74e04ce0644030f365f4349a09e630ef60fbcb9a4"
+)
+
+pkgver() {
+ printf '%s' "${_pkgver}"
+}
+
+
+package() {
+ _instdirbase='/opt/idos-timetable'
+ _instdir="${pkgdir}/${_instdirbase}"
+ install -d -m755 "${_instdir}"
+
+ cp -r "${srcdir}"/Data* "${_instdir}/"
+ chmod 755 "${_instdir}"/Data*
+ chmod 755 "${_instdir}"/Data*/*
+ chmod 644 "${_instdir}"/Data*/*/*
+
+ install -d -m755 "${pkgdir}/usr/share/doc/${_pkgname}"
+ echo "${url}" > "${pkgdir}/usr/share/doc/${_pkgname}/info.url"
+ chmod 644 "${pkgdir}/usr/share/doc/${_pkgname}/info.url"
+
+ install -D -m644 "${srcdir}/license-dummy.txt" "${pkgdir}/usr/share/licenses/${pkgname}/copying.txt"
+ install -D -m644 "${srcdir}/IDOS-Licence.pdf" "${pkgdir}/usr/share/licenses/${pkgname}/IDOS-Licence.pdf"
+}
diff --git a/license-dummy.txt b/license-dummy.txt
new file mode 100644
index 000000000000..f94d2f374c02
--- /dev/null
+++ b/license-dummy.txt
@@ -0,0 +1,10 @@
+We do not know the license. Assume commercial by
+
+ CHAPS spol. s r.o.
+ Bráfova 1617/21
+ CZ-616 00 Brno
+ Czech republic
+
+ http://www.chaps.cz/
+
+Upstream URL: http://www.chaps.cz/eng/download/idos#kotvaprg