summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfelics2018-09-07 11:14:27 +0200
committerfelics2018-09-07 11:14:27 +0200
commit9bc0908f54ca502724d3964d26277bc00675b30e (patch)
tree29593448054057ce7c7e1873339236fba5a5e7bf
downloadaur-9bc0908f54ca502724d3964d26277bc00675b30e.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD77
-rw-r--r--TT.ttk.prefixbin0 -> 85 bytes
-rw-r--r--TT.ttk.suffixbin0 -> 5 bytes
-rw-r--r--copying.txt1
-rw-r--r--idos-timetable-browser-license.install16
6 files changed, 119 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3c279f6e4c29
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = idos-timetable-browser-license
+ pkgdesc = If you purchased IDOS for Windows by CHAPS, then this installs the license. You need your setup-code during installation.
+ pkgver = 2017_2018
+ pkgrel = 1
+ epoch = 1
+ url = http://www.chaps.cz/eng/download/idos-install/
+ arch = i686
+ arch = x86_64
+ groups = idos-timetable
+ license = custom
+ depends = idos-timetable-browser
+ conflicts = idos-timetable-browser-license-installer
+ source = TT.ttk.prefix
+ source = TT.ttk.suffix
+ source = IDOS-Licence.pdf::http://chaps.cz/files/idos/IDOS-Licence.pdf
+ source = copying.txt
+ source = idos-timetable-browser-license.install
+ sha256sums = c002d46e50509049428fe46193acbeb2e2265dadb2b6d0fdb52dc2a3ed83a18e
+ sha256sums = 59d379168865a4a88a697e55b2a1af342f6631cea6278ef05c98ff0c755ea0ab
+ sha256sums = e904d167ccdcfb2743f4cfd596aaa9dce8b751fb5c8315b972b42b7cbb3189e6
+ sha256sums = 6382fff14035c4ec7387e7f0d20d7494e05da3d4c24155090fb39196fa944041
+ sha256sums = f692f387815e7980b418e6e6b2c2965d79f7f9dfe0fc962f6ed3bbfe5f99570a
+
+pkgname = idos-timetable-browser-license
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..44c219ebabbb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,77 @@
+# Maintainer: dreieck
+
+# PKGBUILD last time manually edited: At least on 2016-12-11.
+
+_pkgname=idos-timetable-browser-license
+pkgname="${_pkgname}"
+epoch=1
+_pkgver=2017_2018
+pkgver="${_pkgver}"
+pkgrel=1
+pkgdesc="If you purchased IDOS for Windows by CHAPS, then this installs the license. You need your setup-code during installation."
+arch=('i686' 'x86_64')
+url="http://www.chaps.cz/eng/download/idos-install/"
+license=('custom')
+
+groups=(
+ "idos-timetable"
+ )
+
+depends=(
+ "idos-timetable-browser"
+)
+
+makedepends=()
+
+optdepends=()
+
+provides=()
+
+conflicts=(
+ "idos-timetable-browser-license-installer"
+)
+
+source=(
+ "TT.ttk.prefix"
+ "TT.ttk.suffix"
+ "IDOS-Licence.pdf::http://chaps.cz/files/idos/IDOS-Licence.pdf"
+ "copying.txt"
+ "idos-timetable-browser-license.install"
+)
+
+sha256sums=(
+ "c002d46e50509049428fe46193acbeb2e2265dadb2b6d0fdb52dc2a3ed83a18e"
+ "59d379168865a4a88a697e55b2a1af342f6631cea6278ef05c98ff0c755ea0ab"
+ "e904d167ccdcfb2743f4cfd596aaa9dce8b751fb5c8315b972b42b7cbb3189e6"
+ "6382fff14035c4ec7387e7f0d20d7494e05da3d4c24155090fb39196fa944041"
+ "f692f387815e7980b418e6e6b2c2965d79f7f9dfe0fc962f6ed3bbfe5f99570a"
+)
+
+
+pkgver() {
+ ### We use as version the timetable year.
+
+ echo "${_pkgver}"
+}
+
+
+build() {
+ cd "${srcdir}"
+
+ msg "Please enter your registration code: "
+ read _regcode
+ cat "TT.ttk.prefix" > TT.ttk
+ echo -n "${_regcode}" >> TT.ttk
+ cat "TT.ttk.suffix" >> TT.ttk
+}
+
+
+package() {
+ _instdirbase='/opt/idos-timetable'
+ _instdir="${pkgdir}/${_instdirbase}"
+
+ install -D -m644 "${srcdir}/TT.ttk" "${_instdir}/TT.ttk"
+
+ install -D -m644 "${srcdir}/IDOS-Licence.pdf" "${pkgdir}/usr/share/licenses/${pkgname}/IDOS-Licence.pdf"
+ install -D -m644 "${srcdir}/copying.txt" "${pkgdir}/usr/share/licenses/${pkgname}/copying.txt"
+}
diff --git a/TT.ttk.prefix b/TT.ttk.prefix
new file mode 100644
index 000000000000..af2069aa88f3
--- /dev/null
+++ b/TT.ttk.prefix
Binary files differ
diff --git a/TT.ttk.suffix b/TT.ttk.suffix
new file mode 100644
index 000000000000..d6b716aafbc9
--- /dev/null
+++ b/TT.ttk.suffix
Binary files differ
diff --git a/copying.txt b/copying.txt
new file mode 100644
index 000000000000..161524b9723b
--- /dev/null
+++ b/copying.txt
@@ -0,0 +1 @@
+This package provides a pesonal license file for customers who have purchased the product. The license file is generated after entering the personal registration code. This package may not be re-distributed and only be used by the qualified customer and according to the conditions under which he is allowed to use the licensed version of IDOS for Windows by CHAPS spol. s.r.o.
diff --git a/idos-timetable-browser-license.install b/idos-timetable-browser-license.install
new file mode 100644
index 000000000000..4f49b3ee566a
--- /dev/null
+++ b/idos-timetable-browser-license.install
@@ -0,0 +1,16 @@
+post_install() {
+ echo "====> Please note:"
+ echo " In case you have purchased a local license (and not a network"
+ echo " license), the license is only accepted if the software is run"
+ echo " from a place which is via wine configured as a local hard disk,"
+ echo " and not as a network drive."
+ echo "<==== If you want to check or change, run winecfg."
+}
+
+post_upgrade() {
+ post_install "$@"
+}
+
+post_remove() {
+ true
+}