summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfelics2018-11-21 11:09:24 +0100
committerfelics2018-11-21 11:09:24 +0100
commit0af1a9818dc6b9be597fc13a8528fa33bed6c512 (patch)
treeb0b40c83914a9b33016c6932c364357886612cc7
downloadaur-0af1a9818dc6b9be597fc13a8528fa33bed6c512.tar.gz
Initial commit.
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD96
-rw-r--r--license-dummy.txt10
3 files changed, 137 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..668cc31f9270
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = idos-timetable-data-chaps-trains-cz-2019-latest
+ pkgdesc = 2018/2019 Timetable data for the timetable search engines by CHAPS: Czech trains.
+ pkgver = 2018_11_20
+ pkgrel = 1
+ epoch = 0
+ url = http://chaps.cz/eng/download/idos/zip#kotvatt
+ arch = any
+ groups = idos-timetable
+ license = custom
+ makedepends = wget
+ depends = idos-timetable-data-trains-common
+ optdepends = idos-timetable-tariff-trains-cz: For showing prices.
+ optdepends = idos-timetable-maps-trains-cz: For displaying routes on maps.
+ optdepends = idos-timetable-additionalinfo-trains-cz: For (links to) additional information about train composition and stations.
+ provides = idos-timetable-data-chaps-trains-cz-2019=2018_11_20
+ provides = idos-timetable-data=2018_11_20
+ provides = idos-timetable-data-trains=2018_11_20
+ provides = idos-timetable-data-trains-cz=2018_11_20
+ provides = idos-timetable-data-trains-cz-2019=2018_11_20
+ conflicts = idos-timetable-data-chaps-trains-cz-2019
+ replaces = idos-timetable-data-chaps-trains-cz-latest
+ replaces = idos-timetable-data-chaps-trains-cz-2019<=2018_11_20
+ source = vlak19c.zip::http://ttakt.chaps.cz/TTAktual/Win/Zip/VLAK19C.ZIP
+ source = IDOS-Licence.pdf::http://chaps.cz/files/idos/IDOS-Licence.pdf
+ source = license-dummy.txt
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = c6bb216055d3670d3100b7a74e04ce0644030f365f4349a09e630ef60fbcb9a4
+
+pkgname = idos-timetable-data-chaps-trains-cz-2019-latest
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..084140d6b1ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,96 @@
+# Maintainer: dreieck
+
+# PKGBUILD last time manually edited: At least on 2017-12-17.
+
+_year='19'
+_prevyear="$(( ${_year} - 1 ))"
+
+_pkgname="idos-timetable-data-chaps-trains-cz-20${_year}"
+pkgname="${_pkgname}-latest"
+epoch=0
+pkgver=2018_11_20
+pkgrel=1
+pkgdesc="20${_prevyear}/20${_year} Timetable data for the timetable search engines by CHAPS: Czech trains."
+arch=(any)
+url="http://chaps.cz/eng/download/idos/zip#kotvatt"
+license=('custom')
+
+groups=(
+ "idos-timetable"
+ )
+
+depends=(
+ "idos-timetable-data-trains-common"
+ )
+
+makedepends=(
+ "wget"
+)
+
+optdepends=(
+ "idos-timetable-tariff-trains-cz: For showing prices."
+ "idos-timetable-maps-trains-cz: For displaying routes on maps."
+ "idos-timetable-additionalinfo-trains-cz: For (links to) additional information about train composition and stations."
+ )
+
+provides=(
+ "${_pkgname}=${pkgver}"
+
+ "idos-timetable-data=${pkgver}"
+ "idos-timetable-data-trains=${pkgver}"
+
+ "idos-timetable-data-trains-cz=${pkgver}"
+ "idos-timetable-data-trains-cz-20${_year}=${pkgver}"
+)
+
+replaces=(
+ 'idos-timetable-data-chaps-trains-cz-latest'
+ "${_pkgname}<=${pkgver}"
+)
+
+conflicts=(
+ "${_pkgname}"
+ ### The conflict will be handled by idos-timetable-data-chaps-all, if needed. Sometimes idos-timetable-data-chaps-all does not provide the train data, and then idos-timetable-data-chaps-all will depend on this package, thus this package should not have idos-timetable-data-chaps-all as conflict.
+ # "idos-timetable-data-chaps-all"
+)
+
+_zipfile="VLAK${_year}C.ZIP"
+_target="vlak${_year}c.zip"
+
+source=(
+ "vlak${_year}c.zip::http://ttakt.chaps.cz/TTAktual/Win/Zip/${_zipfile}"
+ "IDOS-Licence.pdf::http://chaps.cz/files/idos/IDOS-Licence.pdf"
+ "license-dummy.txt"
+)
+
+sha256sums=(
+ 'SKIP'
+ "SKIP"
+ "c6bb216055d3670d3100b7a74e04ce0644030f365f4349a09e630ef60fbcb9a4"
+)
+
+pkgver() {
+ # Do not use metadata of the source file, but do website parsing: So we do not need to download the file to (AUR-)update the package version with our own crude hacked script 'idos-aur-update-versions.sh'.
+ #date -r "${srcdir}/${_target}" +"%Y_%m_%d"
+
+ wget -nv -O- "${url}" | tr -d '\a' | tr '\n' '\a' | sed 's|^.*File '"${_zipfile}"'\(.*\)Zip/'"${_zipfile}"'.*$|\1\n|g' | tr '\a' '\n' | grep 'Update date:' | cut -d, -f1 | sed -r 's|([0-9]+)\.([0-9]+)\.([0-9]+).|\n\3_\2_\1\n|g' | grep -E '^[0-9]+_[0-9]+_[0-9]+'
+}
+
+
+package() {
+ _instdirbase='/opt/idos-timetable'
+ _instdir="${pkgdir}/${_instdirbase}"
+ install -d -m755 "${_instdir}"
+
+ cp -r "${srcdir}"/Data* "${_instdir}/"
+ chmod 755 "${_instdir}"/Data*
+ chmod 644 "${_instdir}"/Data*/*
+ rm -f "${_instdir}/Data1"/[vV][lL][aA][kK].[tT][tT][rR] # This one is provided by idos-timetable-data-trains-common.
+
+ install -d -m755 "${pkgdir}/usr/share/doc/${_pkgname}"
+ echo "${url}" > "${pkgdir}/usr/share/doc/${_pkgname}/info.url"
+ chmod 644 "${pkgdir}/usr/share/doc/${_pkgname}/info.url"
+
+ install -D -m644 "${srcdir}/license-dummy.txt" "${pkgdir}/usr/share/licenses/${pkgname}/copying.txt"
+ install -D -m644 "${srcdir}/IDOS-Licence.pdf" "${pkgdir}/usr/share/licenses/${pkgname}/IDOS-Licence.pdf"
+}
diff --git a/license-dummy.txt b/license-dummy.txt
new file mode 100644
index 000000000000..f94d2f374c02
--- /dev/null
+++ b/license-dummy.txt
@@ -0,0 +1,10 @@
+We do not know the license. Assume commercial by
+
+ CHAPS spol. s r.o.
+ Bráfova 1617/21
+ CZ-616 00 Brno
+ Czech republic
+
+ http://www.chaps.cz/
+
+Upstream URL: http://www.chaps.cz/eng/download/idos#kotvaprg