summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfelics2018-12-10 15:37:23 +0100
committerfelics2018-12-10 15:37:23 +0100
commit6c3145af4ea866d3e5cbe5246bad5f07c3ad9b73 (patch)
treecd34248cc02578bf196cf391988540f78fc35ea2
downloadaur-6c3145af4ea866d3e5cbe5246bad5f07c3ad9b73.tar.gz
Initial Commit
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD97
-rw-r--r--license-dummy.txt10
3 files changed, 139 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cbc6363a6964
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = idos-timetable-data-chaps-trains-idol-2019-latest
+ pkgdesc = 2018/2019 Timetable data for the timetable search engines by CHAPS: Trains in Liberec public transport reagion (IDOL). Note that this timetable needs the purchased version of IDOS to run.
+ pkgver = 2018_12_7
+ pkgrel = 1
+ epoch = 0
+ url = http://chaps.cz/eng/download/idos/zip#kotvatt
+ arch = any
+ groups = idos-timetable
+ license = custom
+ makedepends = wget
+ depends = idos-timetable-data-trains-common
+ optdepends = idos-timetable-tariff-mhd-idol: For showing prices.
+ optdepends = idos-timetable-maps-mhd-idol: For displaying routes on maps.
+ optdepends = idos-timetable-additionalinfo-mhd-idol: For additional information.
+ optdepends = idos-timetable-browser-license: To use this timetable.
+ provides = idos-timetable-data-chaps-trains-idol-2019=2018_12_7
+ provides = idos-timetable-data=2018_12_7
+ provides = idos-timetable-data-trains=2018_12_7
+ provides = idos-timetable-data-trains-idol=2018_12_7
+ provides = idos-timetable-data-trains-idol-2019=2018_12_7
+ conflicts = idos-timetable-data-chaps-trains-idol-2019
+ replaces = idos-timetable-data-chaps-trains-europe-latest
+ replaces = idos-timetable-data-chaps-trains-idol-2019<=2018_12_7
+ source = vlakidol19.zip::http://ttakt.chaps.cz/TTAktual/Win/Zip/VLAKIDOL19.ZIP
+ source = IDOS-Licence.pdf::http://chaps.cz/files/idos/IDOS-Licence.pdf
+ source = license-dummy.txt
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = c6bb216055d3670d3100b7a74e04ce0644030f365f4349a09e630ef60fbcb9a4
+
+pkgname = idos-timetable-data-chaps-trains-idol-2019-latest
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..12f32f5c60d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,97 @@
+# Maintainer: dreieck
+
+# PKGBUILD last time manually edited: At least on 2018-12-10.
+
+_year='19'
+_prevyear="$(( ${_year} - 1 ))"
+
+_pkgname="idos-timetable-data-chaps-trains-idol-20${_year}"
+pkgname="${_pkgname}-latest"
+epoch=0
+pkgver=2018_12_7
+pkgrel=1
+pkgdesc="20${_prevyear}/20${_year} Timetable data for the timetable search engines by CHAPS: Trains in Liberec public transport reagion (IDOL). Note that this timetable needs the purchased version of IDOS to run."
+arch=(any)
+url="http://chaps.cz/eng/download/idos/zip#kotvatt"
+license=('custom')
+
+groups=(
+ "idos-timetable"
+ )
+
+depends=(
+ "idos-timetable-data-trains-common"
+ )
+
+makedepends=(
+ "wget"
+)
+
+optdepends=(
+ "idos-timetable-tariff-mhd-idol: For showing prices."
+ "idos-timetable-maps-mhd-idol: For displaying routes on maps."
+ "idos-timetable-additionalinfo-mhd-idol: For additional information."
+ "idos-timetable-browser-license: To use this timetable."
+ )
+
+provides=(
+ "${_pkgname}=${pkgver}"
+
+ "idos-timetable-data=${pkgver}"
+ "idos-timetable-data-trains=${pkgver}"
+
+ "idos-timetable-data-trains-idol=${pkgver}"
+ "idos-timetable-data-trains-idol-20${_year}=${pkgver}"
+)
+
+replaces=(
+ 'idos-timetable-data-chaps-trains-europe-latest'
+ "${_pkgname}<=${pkgver}"
+)
+
+conflicts=(
+ "${_pkgname}"
+ ### The conflict will be handled by idos-timetable-data-chaps-all, if needed. Sometimes idos-timetable-data-chaps-all does not provide the train data, and then idos-timetable-data-chaps-all will depend on this package, thus this package should not have idos-timetable-data-chaps-all as conflict.
+ # "idos-timetable-data-chaps-all"
+)
+
+_zipfile="VLAKIDOL${_year}.ZIP"
+_target="vlakidol${_year}.zip"
+
+source=(
+ "${_target}::http://ttakt.chaps.cz/TTAktual/Win/Zip/${_zipfile}"
+ "IDOS-Licence.pdf::http://chaps.cz/files/idos/IDOS-Licence.pdf"
+ "license-dummy.txt"
+)
+
+sha256sums=(
+ 'SKIP'
+ "SKIP"
+ "c6bb216055d3670d3100b7a74e04ce0644030f365f4349a09e630ef60fbcb9a4"
+)
+
+pkgver() {
+ # Do not use metadata of the source file, but do website parsing: So we do not need to download the file to (AUR-)update the package version with our own crude hacked script 'idos-aur-update-versions.sh'.
+ #date -r "${srcdir}/${_target}" +"%Y_%m_%d"
+
+ wget -nv -O- "${url}" | tr -d '\a' | tr '\n' '\a' | sed 's|^.*File '"${_zipfile}"'\(.*\)Zip/'"${_zipfile}"'.*$|\1\n|g' | tr '\a' '\n' | grep 'Update date:' | cut -d, -f1 | sed -r 's|([0-9]+)\.([0-9]+)\.([0-9]+).|\n\3_\2_\1\n|g' | grep -E '^[0-9]+_[0-9]+_[0-9]+'
+}
+
+
+package() {
+ _instdirbase='/opt/idos-timetable'
+ _instdir="${pkgdir}/${_instdirbase}"
+ install -d -m755 "${_instdir}"
+
+ cp -r "${srcdir}"/Data* "${_instdir}/"
+ chmod 755 "${_instdir}"/Data*
+ chmod 644 "${_instdir}"/Data*/*
+ rm -f "${_instdir}/Data1"/[vV][lL][aA][kK].[tT][tT][rR] # This one is provided by idos-timetable-data-trains-common.
+
+ install -d -m755 "${pkgdir}/usr/share/doc/${_pkgname}"
+ echo "${url}" > "${pkgdir}/usr/share/doc/${_pkgname}/info.url"
+ chmod 644 "${pkgdir}/usr/share/doc/${_pkgname}/info.url"
+
+ install -D -m644 "${srcdir}/license-dummy.txt" "${pkgdir}/usr/share/licenses/${pkgname}/copying.txt"
+ install -D -m644 "${srcdir}/IDOS-Licence.pdf" "${pkgdir}/usr/share/licenses/${pkgname}/IDOS-Licence.pdf"
+}
diff --git a/license-dummy.txt b/license-dummy.txt
new file mode 100644
index 000000000000..f94d2f374c02
--- /dev/null
+++ b/license-dummy.txt
@@ -0,0 +1,10 @@
+We do not know the license. Assume commercial by
+
+ CHAPS spol. s r.o.
+ Bráfova 1617/21
+ CZ-616 00 Brno
+ Czech republic
+
+ http://www.chaps.cz/
+
+Upstream URL: http://www.chaps.cz/eng/download/idos#kotvaprg