summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfelics@felics-tablet2017-12-17 20:43:17 +0100
committerfelics@felics-tablet2017-12-17 20:43:17 +0100
commit7ca0e5fa13f2fa174769c1b02c2055e38cf94f3b (patch)
tree083a5b041e66041371148351948719326791f191
downloadaur-7ca0e5fa13f2fa174769c1b02c2055e38cf94f3b.tar.gz
Initial commit.
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD78
-rw-r--r--license-dummy.txt10
3 files changed, 118 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a60ec1c3c4a4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = idos-timetable-data-chaps-trains-odis-2017-latest
+ pkgdesc = 2016/2017 Timetable data for the timetable search engines by CHAPS: Trains in Ostrava public transport reagion (ODIS). Note that this timetable needs the purchased version of IDOS to run.
+ pkgver = 2017_11_15
+ pkgrel = 1
+ epoch = 0
+ url = http://chaps.cz/eng/download/idos/zip#kotvatt
+ arch = any
+ groups = idos-timetable
+ license = custom
+ makedepends = wget
+ depends = idos-timetable-data-trains-common
+ optdepends = idos-timetable-tariff-mhd-odis: For showing prices.
+ optdepends = idos-timetable-maps-mhd-odis: For displaying routes on maps.
+ optdepends = idos-timetable-additionalinfo-mhd-odis: For additional information (changes, fare, sales points, etc.).
+ optdepends = idos-timetable-browser-license: To use this timetable.
+ provides = idos-timetable-data-chaps-trains-odis-2017=2017_11_15
+ provides = idos-timetable-data=2017_11_15
+ provides = idos-timetable-data-trains=2017_11_15
+ provides = idos-timetable-data-trains-odis=2017_11_15
+ provides = idos-timetable-data-trains-odis-2017=2017_11_15
+ conflicts = idos-timetable-data-chaps-trains-odis-2017
+ source = vlakodis17.zip::http://ttakt.chaps.cz/TTAktual/Win/Zip/VLAKODIS17.ZIP
+ source = IDOS-Licence.pdf::http://chaps.cz/files/idos/IDOS-Licence.pdf
+ source = license-dummy.txt
+ sha256sums = SKIP
+ sha256sums = e904d167ccdcfb2743f4cfd596aaa9dce8b751fb5c8315b972b42b7cbb3189e6
+ sha256sums = c6bb216055d3670d3100b7a74e04ce0644030f365f4349a09e630ef60fbcb9a4
+
+pkgname = idos-timetable-data-chaps-trains-odis-2017-latest
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c55ce43b0882
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,78 @@
+# Maintainer: dreieck
+
+# PKGBUILD last time manually edited: At least on 2017-12-17.
+
+_pkgname=idos-timetable-data-chaps-trains-odis-2017
+pkgname="${_pkgname}-latest"
+epoch=0
+pkgver=2017_11_15
+pkgrel=1
+pkgdesc="2016/2017 Timetable data for the timetable search engines by CHAPS: Trains in Ostrava public transport reagion (ODIS). Note that this timetable needs the purchased version of IDOS to run."
+arch=(any)
+url="http://chaps.cz/eng/download/idos/zip#kotvatt"
+license=('custom')
+
+groups=(
+ "idos-timetable"
+ )
+
+depends=(
+ "idos-timetable-data-trains-common"
+ )
+
+makedepends=(
+ "wget"
+)
+
+optdepends=(
+ "idos-timetable-tariff-mhd-odis: For showing prices."
+ "idos-timetable-maps-mhd-odis: For displaying routes on maps."
+ "idos-timetable-additionalinfo-mhd-odis: For additional information (changes, fare, sales points, etc.)."
+ "idos-timetable-browser-license: To use this timetable."
+ )
+
+provides=(
+ "${_pkgname}=${pkgver}"
+
+ "idos-timetable-data=${pkgver}"
+ "idos-timetable-data-trains=${pkgver}"
+
+ "idos-timetable-data-trains-odis=${pkgver}"
+ "idos-timetable-data-trains-odis-2017=${pkgver}"
+)
+
+conflicts=(
+ "${_pkgname}"
+ ### The conflict will be handled by idos-timetable-data-chaps-all, if needed. Sometimes idos-timetable-data-chaps-all does not provide the train data, and then idos-timetable-data-chaps-all will depend on this package, thus this package should not have idos-timetable-data-chaps-all as conflict.
+ # "idos-timetable-data-chaps-all"
+)
+
+source=(
+ "vlakodis17.zip::http://ttakt.chaps.cz/TTAktual/Win/Zip/VLAKODIS17.ZIP"
+ "IDOS-Licence.pdf::http://chaps.cz/files/idos/IDOS-Licence.pdf"
+ "license-dummy.txt"
+)
+
+sha256sums=(
+ 'SKIP'
+ "e904d167ccdcfb2743f4cfd596aaa9dce8b751fb5c8315b972b42b7cbb3189e6"
+ "c6bb216055d3670d3100b7a74e04ce0644030f365f4349a09e630ef60fbcb9a4"
+)
+
+package() {
+ _instdirbase='/opt/idos-timetable'
+ _instdir="${pkgdir}/${_instdirbase}"
+ install -d -m755 "${_instdir}"
+
+ cp -r "${srcdir}"/Data* "${_instdir}/"
+ chmod 755 "${_instdir}"/Data*
+ chmod 644 "${_instdir}"/Data*/*
+ rm -f "${_instdir}/Data1"/[vV][lL][aA][kK].[tT][tT][rR] # This one is provided by idos-timetable-data-trains-common.
+
+ install -d -m755 "${pkgdir}/usr/share/doc/${_pkgname}"
+ echo "${url}" > "${pkgdir}/usr/share/doc/${_pkgname}/info.url"
+ chmod 644 "${pkgdir}/usr/share/doc/${_pkgname}/info.url"
+
+ install -D -m644 "${srcdir}/license-dummy.txt" "${pkgdir}/usr/share/licenses/${pkgname}/copying.txt"
+ install -D -m644 "${srcdir}/IDOS-Licence.pdf" "${pkgdir}/usr/share/licenses/${pkgname}/IDOS-Licence.pdf"
+}
diff --git a/license-dummy.txt b/license-dummy.txt
new file mode 100644
index 000000000000..f94d2f374c02
--- /dev/null
+++ b/license-dummy.txt
@@ -0,0 +1,10 @@
+We do not know the license. Assume commercial by
+
+ CHAPS spol. s r.o.
+ Bráfova 1617/21
+ CZ-616 00 Brno
+ Czech republic
+
+ http://www.chaps.cz/
+
+Upstream URL: http://www.chaps.cz/eng/download/idos#kotvaprg