summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgit user2024-01-14 23:47:29 +0100
committergit user2024-01-14 23:47:29 +0100
commit1d97f42936457430c637e1effa05e70815a918e5 (patch)
treee1244602f19630f6ae9db83f52b0976fc04a2d79
downloadaur-1d97f42936457430c637e1effa05e70815a918e5.tar.gz
Initial Commit.
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD102
-rw-r--r--license-dummy.txt10
3 files changed, 143 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fef388d724de
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = idos-timetable-data-chaps-trains-odis-2024-latest
+ pkgdesc = 2023/2024 Timetable data for the timetable search engines by CHAPS: Trains in Ostrava public transport reagion (ODIS). Note that this timetable needs the purchased version of IDOS to run.
+ pkgver = 2024_01_12
+ pkgrel = 3
+ epoch = 0
+ url = https://chaps.cz/eng/download/idos/zip#kotvatt
+ arch = any
+ groups = idos-timetable
+ license = custom
+ makedepends = wget
+ depends = idos-timetable-data-trains-common
+ optdepends = idos-timetable-tariff-mhd-odis: For showing prices.
+ optdepends = idos-timetable-maps-mhd-odis: For displaying routes on maps.
+ optdepends = idos-timetable-additionalinfo-mhd-odis: For additional information (changes, fare, sales points, etc.).
+ optdepends = idos-timetable-browser-license: To use this timetable.
+ provides = idos-timetable-data-chaps-trains-odis-2024=2024_01_12
+ provides = idos-timetable-data=2024_01_12
+ provides = idos-timetable-data-trains=2024_01_12
+ provides = idos-timetable-data-trains-odis=2024_01_12
+ provides = idos-timetable-data-trains-odis-2024=2024_01_12
+ conflicts = idos-timetable-data-chaps-trains-odis-2024
+ replaces = idos-timetable-data-chaps-trains-odis-latest
+ replaces = idos-timetable-data-chaps-trains-odis-2024<=2024_01_12
+ source = vlakodis24-2024_01_12.zip::https://ttakt.chaps.cz/TTAktual/Win/Zip/VLAKODIS24.ZIP
+ source = IDOS-Licence.pdf::https://chaps.cz/files/idos/IDOS-Licence.pdf
+ source = license-dummy.txt
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = c6bb216055d3670d3100b7a74e04ce0644030f365f4349a09e630ef60fbcb9a4
+
+pkgname = idos-timetable-data-chaps-trains-odis-2024-latest
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a8fb269ad1bc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,102 @@
+# Maintainer: dreieck
+
+# PKGBUILD last time manually edited: At least on 2024-01-14.
+
+_year='24'
+_prevyear="$(( ${_year} - 1 ))"
+url="https://chaps.cz/eng/download/idos/zip#kotvatt"
+_zipfile="VLAKODIS${_year}.ZIP"
+_pkgver() {
+ # Reason for a _pkgver(): Have something to run before source download so that we can have version aware source downloads.
+ # Do not use metadata of the source file, but do website parsing: So we do not need to download the file to (AUR-)update the package version with our own crude hacked script 'idos-aur-update-versions.sh'.
+ #date -r "${srcdir}/${_target}" +"%Y_%m_%d"
+
+ wget -nv -O- "${url}" | tr -d '\a' | tr '\n' '\a' | sed 's|^.*File '"${_zipfile}"'\(.*\)Zip/'"${_zipfile}"'.*$|\1\n|g' | tr '\a' '\n' | grep 'Update date:' | cut -d, -f1 | sed -r 's|([0-9]+)\.([0-9]+)\.([0-9]+).|\n\3_\2_\1\n|g' | grep -E '^[0-9]+_[0-9]+_[0-9]+' | sed -E -e 's|_([0-9])_|_0\1_|g' -e 's|_([0-9])$|_0\1|g'
+}
+
+_pkgname="idos-timetable-data-chaps-trains-odis-20${_year}"
+pkgname="${_pkgname}-latest"
+epoch=0
+_pkgver="$(_pkgver)" # This should be set _before_ sources get downloaded.
+pkgver="${_pkgver}"
+pkgrel=3
+pkgdesc="20${_prevyear}/20${_year} Timetable data for the timetable search engines by CHAPS: Trains in Ostrava public transport reagion (ODIS). Note that this timetable needs the purchased version of IDOS to run."
+arch=(any)
+license=('custom')
+
+groups=(
+ "idos-timetable"
+ )
+
+depends=(
+ "idos-timetable-data-trains-common"
+ )
+
+makedepends=(
+ "wget"
+)
+
+optdepends=(
+ "idos-timetable-tariff-mhd-odis: For showing prices."
+ "idos-timetable-maps-mhd-odis: For displaying routes on maps."
+ "idos-timetable-additionalinfo-mhd-odis: For additional information (changes, fare, sales points, etc.)."
+ "idos-timetable-browser-license: To use this timetable."
+ )
+
+provides=(
+ "${_pkgname}=${pkgver}"
+
+ "idos-timetable-data=${pkgver}"
+ "idos-timetable-data-trains=${pkgver}"
+
+ "idos-timetable-data-trains-odis=${pkgver}"
+ "idos-timetable-data-trains-odis-20${_year}=${pkgver}"
+)
+
+replaces=(
+ 'idos-timetable-data-chaps-trains-odis-latest'
+ "${_pkgname}<=${pkgver}"
+)
+
+conflicts=(
+ "${_pkgname}"
+ ### The conflict will be handled by idos-timetable-data-chaps-all, if needed. Sometimes idos-timetable-data-chaps-all does not provide the train data, and then idos-timetable-data-chaps-all will depend on this package, thus this package should not have idos-timetable-data-chaps-all as conflict.
+ # "idos-timetable-data-chaps-all"
+)
+
+_target="vlakodis${_year}-${_pkgver}.zip"
+
+source=(
+ "${_target}::https://ttakt.chaps.cz/TTAktual/Win/Zip/${_zipfile}"
+ "IDOS-Licence.pdf::https://chaps.cz/files/idos/IDOS-Licence.pdf"
+ "license-dummy.txt"
+)
+
+sha256sums=(
+ 'SKIP'
+ "SKIP"
+ "c6bb216055d3670d3100b7a74e04ce0644030f365f4349a09e630ef60fbcb9a4"
+)
+
+pkgver() {
+ printf '%s' "${_pkgver}"
+}
+
+
+package() {
+ _instdirbase='/opt/idos-timetable'
+ _instdir="${pkgdir}/${_instdirbase}"
+ install -d -m755 "${_instdir}"
+
+ cp -r "${srcdir}"/Data* "${_instdir}/"
+ chmod 755 "${_instdir}"/Data*
+ chmod 644 "${_instdir}"/Data*/*
+ rm -f "${_instdir}/Data1"/[vV][lL][aA][kK].[tT][tT][rR] # This one is provided by idos-timetable-data-trains-common.
+
+ install -d -m755 "${pkgdir}/usr/share/doc/${_pkgname}"
+ echo "${url}" > "${pkgdir}/usr/share/doc/${_pkgname}/info.url"
+ chmod 644 "${pkgdir}/usr/share/doc/${_pkgname}/info.url"
+
+ install -D -m644 "${srcdir}/license-dummy.txt" "${pkgdir}/usr/share/licenses/${pkgname}/copying.txt"
+ install -D -m644 "${srcdir}/IDOS-Licence.pdf" "${pkgdir}/usr/share/licenses/${pkgname}/IDOS-Licence.pdf"
+}
diff --git a/license-dummy.txt b/license-dummy.txt
new file mode 100644
index 000000000000..f94d2f374c02
--- /dev/null
+++ b/license-dummy.txt
@@ -0,0 +1,10 @@
+We do not know the license. Assume commercial by
+
+ CHAPS spol. s r.o.
+ Bráfova 1617/21
+ CZ-616 00 Brno
+ Czech republic
+
+ http://www.chaps.cz/
+
+Upstream URL: http://www.chaps.cz/eng/download/idos#kotvaprg