summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeif Warner2015-08-26 18:26:53 -0700
committerLeif Warner2015-08-26 18:43:24 -0700
commit34567fb05a5cd840a06e9439d8b70583a8905b90 (patch)
tree081a3cae4b939f2206a04a6a23c1c543d41a6258
downloadaur-34567fb05a5cd840a06e9439d8b70583a8905b90.tar.gz
Initial import v0.9.18.r472.7642503
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD43
-rw-r--r--idris-git.install18
3 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6d05608de164
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = idris-git
+ pkgdesc = Functional Programming Language with Dependent Types
+ pkgver = v0.9.18.r472.7642503
+ pkgrel = 1
+ url = http://www.idris-lang.org/
+ install = idris-git.install
+ arch = i686
+ arch = x86_64
+ license = custom:BSD3
+ depends = gmp
+ depends = libffi
+ depends = gcc
+ provides = idris
+ conflicts = idris
+ options = staticlibs
+ source = git://github.com/idris-lang/Idris-dev.git
+ md5sums = SKIP
+
+pkgname = idris-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..93fa08c0ef11
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Leif Warner <abimelech@gmail.com>
+_gitname=Idris-dev
+pkgname=idris-git
+pkgver=v0.9.18.r472.7642503
+pkgrel=1
+pkgdesc="Functional Programming Language with Dependent Types"
+url="http://www.idris-lang.org/"
+license=('custom:BSD3')
+arch=('i686' 'x86_64')
+makedpends=('ghc' 'haskell-annotated-wl-pprint<0.7' 'haskell-ansi-terminal<0.7' 'haskell-ansi-wl-pprint<0.7' 'haskell-base64-bytestring<1.1' 'haskell-binary<0.8' 'haskell-blaze-html<0.8' 'haskell-blaze-markup<0.6.3.0' 'haskell-bytestring' 'haskell-cheapskate<0.2' 'haskell-containers' 'haskell-deepseq' 'haskell-directory' 'haskell-filepath' 'haskell-fingertree<0.2' 'haskell-haskeline<0.8' 'haskell-mtl' 'haskell-network' 'haskell-optparse-applicative<0.12' 'haskell-parsers<0.13' 'haskell-pretty' 'haskell-process' 'haskell-safe' 'haskell-split<0.3' 'haskell-text' 'haskell-time' 'haskell-transformers' 'haskell-transformers-compat>=0.3' 'haskell-trifecta<1.6' 'haskell-uniplate<1.7' 'haskell-unix' 'haskell-unordered-containers<0.3' 'haskell-utf8-string<0.4' 'haskell-vector<0.11' 'haskell-vector-binary-instances<0.3' 'haskell-zip-archive<0.2.4' 'haskell-zlib' 'haskell-libffi')
+depends=('gmp' 'libffi' 'gcc')
+options=('staticlibs')
+provides=('idris')
+conflicts=('idris')
+source=("git://github.com/idris-lang/${_gitname}.git")
+md5sums=('SKIP')
+install=${pkgname}.install
+
+pkgver() {
+ cd $_gitname
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd $_gitname
+ runhaskell Setup configure -O ${PKGBUILD_HASKELL_ENABLE_PROFILING:+-p } --enable-split-objs --enable-shared \
+ --prefix=/usr --docdir=/usr/share/doc/${pkgname} --libsubdir=\$compiler/site-local/\$pkgid -fFFI -fGMP
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+package() {
+ cd $_gitname
+ install -D -m744 register.sh ${pkgdir}/usr/share/haskell/${pkgname}/register.sh
+ install -m744 unregister.sh ${pkgdir}/usr/share/haskell/${pkgname}/unregister.sh
+ install -d -m755 ${pkgdir}/usr/share/doc/ghc/html/libraries
+ ln -s /usr/share/doc/${pkgname}/html ${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}
+ runhaskell Setup copy --destdir=${pkgdir}
+ install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ rm -f ${pkgdir}/usr/share/doc/${pkgname}/LICENSE
+}
diff --git a/idris-git.install b/idris-git.install
new file mode 100644
index 000000000000..79a0ff1fc959
--- /dev/null
+++ b/idris-git.install
@@ -0,0 +1,18 @@
+HS_DIR=usr/share/haskell/idris-git
+post_install() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+pre_upgrade() {
+ ${HS_DIR}/unregister.sh
+}
+post_upgrade() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+pre_remove() {
+ ${HS_DIR}/unregister.sh
+}
+post_remove() {
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}