summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCodingCellist2022-10-31 11:36:27 +0100
committerCodingCellist2022-10-31 11:36:27 +0100
commitb162407d50b6d0db105b3f19f06f56ff8a9e9aa2 (patch)
tree46565b82acde4c1a89eca0438d5b407ae1d2fe6f
parentca6303fc2aac46e2dd34df2abe0c82375929e5ad (diff)
downloadaur-b162407d50b6d0db105b3f19f06f56ff8a9e9aa2.tar.gz
Version 0.6.0
Numerous new features (e.g. multi-with), detailed help support at the REPL, refactoring of existing code (e.g. the `linear` and `papers` libraries), various bug-fixes, etc. For a complete list, see the [CHANGELOG](https://github.com/idris-lang/Idris2/blob/main/CHANGELOG.md) Also actually checks Idris built correctly now (via `make test`).
-rw-r--r--PKGBUILD27
1 files changed, 20 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 00dcf072356f..e414adc55e05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,21 @@
#
# Maintainer: Mark Barbone <mark.l.barbone at gmail>
+# Co-maintainer: Thomas Hansen <thomas-e-hansen at teh6 dot eu>
#
pkgname=idris2
-pkgver=0.5.1
-pkgrel=2
-pkgdesc="Funtional Programming Lanugage with Dependent Types"
-url="https://www.idris-lang.org/"
+pkgver=0.6.0
+pkgrel=1
+pkgdesc="Functional Programming Language with Dependent Types"
+url="https://idris-lang.github.io/"
license=('custom')
arch=('x86_64')
depends=('chez-scheme')
+optdepends=('nodejs: for the node backend'
+ 'racket: for the racket backend')
makedepends=('git')
source=("https://www.idris-lang.org/idris2-src/idris2-${pkgver}.tgz")
-sha256sums=('a8cf6f60756b93fd97f9d4e9c48473e6e41179a6312ae10d93005591eec48859')
+sha256sums=('4db59312ed954778d135c78d8e41701bb37b1c4911a8f414a2074e87b246a153')
_srcname="Idris2-$pkgver"
@@ -30,7 +33,17 @@ build() {
PATH="$srcdir/bootstrap/bin:$PATH" \
LD_LIBRARY_PATH="$srcdir/bootstrap/lib:$LD_LIBRARY_PATH" \
PREFIX=/usr/lib \
- make
+ make all
+}
+
+check() {
+ cd "$srcdir/$_srcname"
+
+ unset MAKEFLAGS
+ export SCHEME=chez
+
+ PATH="$srcdir/$_srcname/build/exec:$PATH" \
+ make test INTERACTIVE=""
}
package() {
@@ -50,7 +63,7 @@ package() {
IDRIS2_PREFIX="$pkgdir/usr/lib" \
"$IDRIS2_BINARY" --install-with-src $1.ipkg
}
- for lib in prelude base contrib network test ; do
+ for lib in prelude base contrib linear network test ; do
( cd libs/$lib ; install_lib $lib )
done
install_lib idris2api