summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Doege2015-06-09 11:41:26 +0200
committerMartin Doege2015-06-09 11:41:26 +0200
commit17865381aef717a21ce3eb0c659a39205c6e0708 (patch)
tree49b31ba25f38ae2e45e7c1d6eff7c04c7c1fcb1e
downloadaur-17865381aef717a21ce3eb0c659a39205c6e0708.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
-rwxr-xr-xidsk.install29
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bcc51d7e0d37
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = idsk
+ pkgdesc = A tool for managing Amstrad CPC DSK images
+ pkgver = 0.13
+ pkgrel = 2
+ url = http://koaks.amstrad.free.fr/amstrad/projets/
+ install = idsk.install
+ arch = i686
+ arch = x86_64
+ license = unknown
+ makedepends = addinclude
+ source = http://sid.cpc.free.fr/iDSK.0.13-src.tgz
+ md5sums = b221623d3039e09b15c5a071caf343b8
+
+pkgname = idsk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..38d02d2d8a93
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Martin C. Doege <mdoege at compuserve dot com>
+
+pkgname=idsk
+pkgver=0.13
+pkgrel=2
+pkgdesc="A tool for managing Amstrad CPC DSK images"
+arch=('i686' 'x86_64')
+url="http://koaks.amstrad.free.fr/amstrad/projets/"
+license=('unknown')
+depends=()
+install=$pkgname.install
+makedepends=("addinclude")
+source=("http://sid.cpc.free.fr/iDSK."$pkgver"-src.tgz")
+md5sums=('b221623d3039e09b15c5a071caf343b8')
+
+build() {
+ cd "$srcdir/iDSK."$pkgver"/iDSK"
+ for i in Basic.cpp BitmapCPC.cpp Dams.cpp Desass.cpp GestDsk.cpp Outils.cpp
+ do
+ addinclude src/$i stdio
+ done
+ ./configure --prefix=/usr
+ make || return 1
+}
+
+package() {
+ cd "$srcdir/iDSK."$pkgver"/iDSK"
+ make DESTDIR="$pkgdir" install
+}
+
diff --git a/idsk.install b/idsk.install
new file mode 100755
index 000000000000..9bbea234883d
--- /dev/null
+++ b/idsk.install
@@ -0,0 +1,29 @@
+post_install() {
+ cat << EOF
+==========================================================
+English help text (help text in the program is in French):
+==========================================================
+
+Usage :
+ iDSK <DSKfile> [OPTIONS] [files to process]
+OPTIONS : EXAMPLE
+-l : List disk catalog iDSK floppy.dsk -l
+-g : export ('Get') file iDSK floppy.dsk -g myprog.bas
+-r : Remove file iDSK floppy.dsk -r myprog.bas
+-n : create New dsk file iDSK floppy2.dsk -n
+-z : disassemble a binary file iDSK floppy.dsk -z myprog.bin
+-b : list a Basic file iDSK floppy.dsk -b myprog.bas
+-d : list a Dams file iDSK floppy.dsk -d myprog.dms
+-h : list a binary file as Hexadecimal iDSK floppy.dsk -h myprog.bin
+-i : Import file iDSK floppy.dsk -i myprog.bas
+ -t : fileType (0=ASCII/1=BINARY) ... -t 1
+ -e : hex Execute address of file ... -e C000 -t 1
+ -c : hex loading address of file ... -e C000 -c 4000 -t 1
+ -f : Force overwriting if file exists ... -f
+ -o : insert a read-Only file ... -o
+ -s : insert a System file ... -s
+ -u : insert file with User number ... -u 3
+--------------------------------------------------------------------------------
+Please report bugs ! - Demoniak/Sid/PulkoMandy
+EOF
+}