summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHector Mtz-Seara2016-03-15 15:39:51 +0100
committerHector Mtz-Seara2016-03-15 15:42:43 +0100
commit1cde257094218a7cb647e87e180a34268537a40b (patch)
treef51e695c6e43bc1f8b1c3aff8f96c6c8c8ca991d
parent4a617f772c3820dcad680c0313201b7d50c9fd0c (diff)
downloadaur-1cde257094218a7cb647e87e180a34268537a40b.tar.gz
Patched iep to avoid kernel SYN_flood false positive problem: iep-3.7-2
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
-rw-r--r--SYN_flood.patch25
3 files changed, 39 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d127e812bdd0..fa334de295d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = iep
pkgdesc = Pronounced as 'eep'is a cross-platform Python IDE focused on interactivity and introspection, which makes it very suitable for scientific computing. Its practical design is aimed at simplicity and efficiency.
pkgver = 3.7
- pkgrel = 1
+ pkgrel = 2
url = http://iep-project.org
arch = any
license = BSD
@@ -10,7 +10,9 @@ pkgbase = iep
optdepends = python-pyqt4: At least one qt4 python bindings should be installed
optdepends = python-pyside: At lease one qt4 python bindings should be installed
source = http://bitbucket.org/iep-project/iep/downloads/iep-3.7.source.zip
+ source = SYN_flood.patch
sha1sums = 4c5251813934f876b8aca6f213e5ff36686174c4
+ sha1sums = 037799e6b50934e1fca169af90fddc2f47799cc9
pkgname = iep
diff --git a/PKGBUILD b/PKGBUILD
index 1fd7a4ea7abb..890a424482b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
#Contributor: Hector Mtz-Seara <hseara.#at#.gmail*.*com>
pkgname=iep
pkgver=3.7
-pkgrel=1
+pkgrel=2
pkgdesc="Pronounced as 'eep'is a cross-platform Python IDE focused on interactivity and introspection, which makes it very suitable for scientific computing. Its practical design is aimed at simplicity and efficiency."
url="http://iep-project.org"
license=("BSD")
@@ -14,8 +14,16 @@ optdepends=(
makedepends=('python-setuptools')
-source=("http://bitbucket.org/iep-project/iep/downloads/iep-${pkgver}.source.zip")
-sha1sums=('4c5251813934f876b8aca6f213e5ff36686174c4')
+source=("http://bitbucket.org/iep-project/iep/downloads/iep-${pkgver}.source.zip"
+ "SYN_flood.patch")
+
+sha1sums=('4c5251813934f876b8aca6f213e5ff36686174c4'
+ '037799e6b50934e1fca169af90fddc2f47799cc9')
+prepare(){
+ cp SYN_flood.patch ${srcdir}/${pkgname}-${pkgver}/iep/yoton
+ cd "${srcdir}/${pkgname}-${pkgver}"/iep/yoton
+ patch connection_tcp.py < SYN_flood.patch
+}
build(){
cd "${srcdir}/${pkgname}-${pkgver}"
diff --git a/SYN_flood.patch b/SYN_flood.patch
new file mode 100644
index 000000000000..40192ae17d75
--- /dev/null
+++ b/SYN_flood.patch
@@ -0,0 +1,25 @@
+From f54d1707ed6cbdfe8bd33dc9a49d9a20e2f684b7 Mon Sep 17 00:00:00 2001
+From: Almar Klein <almar.klein@gmail.com>
+Date: Tue, 15 Mar 2016 11:35:44 +0100
+Subject: [PATCH] fix slowness on new Linux kernel. issue #381
+
+---
+ pyzo/yoton/connection_tcp.py | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/pyzo/yoton/connection_tcp.py b/pyzo/yoton/connection_tcp.py
+index dc3a279..e8725fd 100644
+--- a/pyzo/yoton/connection_tcp.py
++++ b/pyzo/yoton/connection_tcp.py
+@@ -180,8 +180,9 @@ def _bind(self, hostname, port, max_tries=1):
+ tmp = "Could not bind to any of the " + tmp + " ports tried."
+ raise IOError(tmp)
+
+- # Tell the socket it is a host, backlog of zero
+- s.listen(0)
++ # Tell the socket it is a host. Backlog of at least 1 to avoid linux
++ # kernel from detecting SYN flood and throttling the connection (#381)
++ s.listen(1)
+
+ # Set connected (status 1: waiting for connection)
+ # Will be called with status 2 by the hostThread on success