summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcyril@biminsight.ch2019-05-05 12:17:11 +0200
committercyril@biminsight.ch2019-05-05 12:17:11 +0200
commit40158424e02edb7eff242755165d7d081125f2f2 (patch)
tree6691322c6b2f94863a058d85d7ddc2631f617834
parentea23d473af81ba7186be530553502badbba05a5f (diff)
downloadaur-40158424e02edb7eff242755165d7d081125f2f2.tar.gz
Update to 0.6.0a1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD54
-rw-r--r--boost-1.58.patch61
3 files changed, 40 insertions, 94 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ac31bd47b3c..0eb0a1785dc4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,25 @@
pkgbase = ifcopenshell
pkgdesc = Open source IFC library and geometry engine. Provides static libraries, python3 wrapper and blender addon.
- pkgver = 0.4.0
- pkgrel = 2
+ pkgver = 0.6.0a1
+ pkgrel = 1
url = http://ifcopenshell.org/
arch = x86_64
arch = i686
- license = GPL3
+ license = LGPL3
makedepends = cmake
makedepends = boost>=1.58.0
makedepends = swig
+ depends = boost-libs>=1.58.0
depends = opencascade
+ depends = icu
depends = opencollada
- depends = boost-libs>=1.58.0
depends = python
- source = https://github.com/IfcOpenShell/IfcOpenShell/archive/v0.4.0.tar.gz
- source = boost-1.58.patch
- md5sums = 12bbb9726d8012cf88222f5921a767c3
- md5sums = 9628e73de9049ae183774aa2363b6fda
+ provides = ifcopenshell
+ provides = ifcblender
+ provides = IfcConvert
+ provides = IfcGeomServer
+ source = https://github.com/IfcOpenShell/IfcOpenShell/archive/v0.6.0a1.tar.gz
+ md5sums = 869cd9a4440bda959734a99bc23be633
pkgname = ifcopenshell
diff --git a/PKGBUILD b/PKGBUILD
index 0ec8b2f8cee5..c1efea9f609c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,53 +1,57 @@
-# Maintainer: mickele <mimocciola[at]yahoo[dot]com>
pkgname=ifcopenshell
-pkgver=0.4.0
-pkgrel=2
+pkgver=0.6.0a1
+pkgrel=1
pkgdesc="Open source IFC library and geometry engine. Provides static libraries, python3 wrapper and blender addon."
-url="http://ifcopenshell.org/"
arch=('x86_64' 'i686')
-license=('GPL3')
-depends=('opencascade' 'opencollada' 'boost-libs>=1.58.0' 'python')
+url="http://ifcopenshell.org/"
+license=('LGPL3')
+depends=('boost-libs>=1.58.0' 'opencascade' 'icu' 'opencollada' 'python')
optdepends=()
makedepends=('cmake' 'boost>=1.58.0' 'swig')
+provides=('ifcopenshell' 'ifcblender' 'IfcConvert' 'IfcGeomServer')
conflicts=()
replaces=()
backup=()
-source=("https://github.com/IfcOpenShell/IfcOpenShell/archive/v${pkgver}.tar.gz" "boost-1.58.patch")
-
-_blenderver=2.76
+source=("https://github.com/IfcOpenShell/IfcOpenShell/archive/v${pkgver//_/-}.tar.gz")
+_blenderver=2.79
prepare(){
- cd "${srcdir}/IfcOpenShell-${pkgver}"
- patch -Np1 -i "${srcdir}/boost-1.58.patch"
+ cd "${srcdir}/IfcOpenShell-${pkgver//_/-}"
+
+ find src -type f -exec sed -i -e "s|UnicodeString|icu::UnicodeString|g" {} \;
}
build() {
- cd "${srcdir}/IfcOpenShell-${pkgver}"
+ cd "${srcdir}/IfcOpenShell-${pkgver//_/-}"
mkdir -p build
- cd "${srcdir}/IfcOpenShell-${pkgver}/build"
+ cd "${srcdir}/IfcOpenShell-${pkgver//_/-}/build"
local _pythonver=$(python --version >&1)
- cmake ../cmake \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DOCC_INCLUDE_DIR=/opt/opencascade/inc \
- -DOCC_LIBRARY_DIR=/opt/opencascade/lib \
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_CXX_STANDARD=11 \
+ -DOCC_INCLUDE_DIR=/usr/include/opencascade \
+ -DOCC_LIBRARY_DIR=/usr/lib \
-DOPENCOLLADA_INCLUDE_DIR=/usr/include/opencollada \
-DOPENCOLLADA_LIBRARY_DIR=/usr/lib/opencollada \
- -DPYTHON_INCLUDE_DIR:PATH=/usr/include/python${_pythonver:7:3}m \
- -DPYTHON_LIBRARY:FILEPATH=/usr/lib64/libpython${_pythonver:7:3}m.so
+ -DICU_INCLUDE_DIR=/usr/include/unicode \
+ -DICU_LIBRARY_DIR=/usr/lib \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python${_pythonver:7:3}m \
+ -DPYTHON_LIBRARY=/usr/lib64/libpython${_pythonver:7:3}m.so \
+ -DSWIG_EXECUTABLE=/usr/bin/swig \
+ ../cmake
make
}
package() {
- cd "${srcdir}/IfcOpenShell-${pkgver}/build"
+ cd "${srcdir}/IfcOpenShell-${pkgver//_/-}/build"
make DESTDIR="${pkgdir}" install
- cd "${srcdir}/IfcOpenShell-${pkgver}"
+ cd "${srcdir}/IfcOpenShell-${pkgver//_/-}"
install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
mkdir -p "${pkgdir}"/usr/share/blender/${_blenderver}/scripts/addons_contrib
- cp -rf "${srcdir}"/IfcOpenShell-${pkgver}/src/ifcblender/* "${pkgdir}"/usr/share/blender/${_blenderver}/scripts/addons_contrib
- cp -f "${srcdir}"/IfcOpenShell-${pkgver}/build/ifcwrap/*IfcImport* "${pkgdir}"/usr/share/blender/${_blenderver}/scripts/addons_contrib/io_import_scene_ifc/
+ cp -rf "${srcdir}"/IfcOpenShell-${pkgver//_/-}/src/ifcblender/* "${pkgdir}"/usr/share/blender/${_blenderver}/scripts/addons_contrib
+ cp -rf "${srcdir}"/IfcOpenShell-${pkgver//_/-}/src/ifcopenshell-python/* "${pkgdir}"/usr/share/blender/${_blenderver}/scripts/addons_contrib/io_import_scene_ifc
+ cp -f "${srcdir}"/IfcOpenShell-${pkgver//_/-}/build/ifcwrap/*ifcopenshell_wrapper* "${pkgdir}"/usr/share/blender/${_blenderver}/scripts/addons_contrib/io_import_scene_ifc/ifcopenshell
}
-md5sums=('12bbb9726d8012cf88222f5921a767c3'
- '9628e73de9049ae183774aa2363b6fda')
+md5sums=('869cd9a4440bda959734a99bc23be633')
diff --git a/boost-1.58.patch b/boost-1.58.patch
deleted file mode 100644
index 0995b567332e..000000000000
--- a/boost-1.58.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-diff -Naur IfcOpenShell-0.4.0-rc2.orig/src/examples/IfcOpenHouse.cpp IfcOpenShell-0.4.0-rc2/src/examples/IfcOpenHouse.cpp
---- IfcOpenShell-0.4.0-rc2.orig/src/examples/IfcOpenHouse.cpp 2015-10-24 15:25:46.346898794 +0200
-+++ IfcOpenShell-0.4.0-rc2/src/examples/IfcOpenHouse.cpp 2015-10-24 15:46:14.363636904 +0200
-@@ -40,7 +40,7 @@
- typedef std::string S;
- typedef IfcWrite::IfcGuidHelper guid;
- typedef std::pair<double, double> XY;
--boost::none_t const null = (static_cast<boost::none_t>(0));
-+boost::none_t const null = boost::none;
-
- // The creation of Nurbs-surface for the IfcSite mesh, to be implemented lateron
- void createGroundShape(TopoDS_Shape& shape);
-diff -Naur IfcOpenShell-0.4.0-rc2.orig/src/ifcgeom/IfcGeomFunctions.cpp IfcOpenShell-0.4.0-rc2/src/ifcgeom/IfcGeomFunctions.cpp
---- IfcOpenShell-0.4.0-rc2.orig/src/ifcgeom/IfcGeomFunctions.cpp 2015-10-24 15:25:46.356898796 +0200
-+++ IfcOpenShell-0.4.0-rc2/src/ifcgeom/IfcGeomFunctions.cpp 2015-10-24 15:47:41.246975292 +0200
-@@ -568,7 +568,7 @@
- 0, std::string("Facetation"), std::string("SurfaceModel"), items);
-
- reps->push(rep);
-- Ifc2x3::IfcProductDefinitionShape* shapedef = new Ifc2x3::IfcProductDefinitionShape(0, 0, reps);
-+ Ifc2x3::IfcProductDefinitionShape* shapedef = new Ifc2x3::IfcProductDefinitionShape(boost::none, boost::none, reps);
-
- es->push(shell);
- es->push(surface_model);
-@@ -600,4 +600,4 @@
- }
- if (!removed) break;
- }
--}
-\ No newline at end of file
-+}
-diff -Naur IfcOpenShell-0.4.0-rc2.orig/src/ifcparse/IfcHierarchyHelper.cpp IfcOpenShell-0.4.0-rc2/src/ifcparse/IfcHierarchyHelper.cpp
---- IfcOpenShell-0.4.0-rc2.orig/src/ifcparse/IfcHierarchyHelper.cpp 2015-10-24 15:25:46.366898796 +0200
-+++ IfcOpenShell-0.4.0-rc2/src/ifcparse/IfcHierarchyHelper.cpp 2015-10-24 15:49:42.396982340 +0200
-@@ -267,7 +267,7 @@
- ? context
- : getSingle<Ifc2x3::IfcRepresentationContext>(), std::string("Body"), std::string("SweptSolid"), items);
- reps->push(rep);
-- Ifc2x3::IfcProductDefinitionShape* shape = new Ifc2x3::IfcProductDefinitionShape(0, 0, reps);
-+ Ifc2x3::IfcProductDefinitionShape* shape = new Ifc2x3::IfcProductDefinitionShape(boost::none, boost::none, reps);
- AddEntity(rep);
- AddEntity(shape);
- addExtrudedPolyline(rep, points, h, place, place2, dir, context);
-@@ -281,7 +281,7 @@
- {
- if (false) {
- Ifc2x3::IfcRectangleProfileDef* profile = new Ifc2x3::IfcRectangleProfileDef(
-- Ifc2x3::IfcProfileTypeEnum::IfcProfileType_AREA, 0, place ? place : addPlacement2d(), w, d);
-+ Ifc2x3::IfcProfileTypeEnum::IfcProfileType_AREA, boost::none, place ? place : addPlacement2d(), w, d);
- Ifc2x3::IfcExtrudedAreaSolid* solid = new Ifc2x3::IfcExtrudedAreaSolid(profile,
- place2 ? place2 : addPlacement3d(), dir ? dir : addTriplet<Ifc2x3::IfcDirection>(0, 0, 1), h);
-
-@@ -309,7 +309,7 @@
- Ifc2x3::IfcShapeRepresentation* rep = new Ifc2x3::IfcShapeRepresentation(
- context ? context : getSingle<Ifc2x3::IfcRepresentationContext>(), std::string("Body"), std::string("SweptSolid"), items);
- reps->push(rep);
-- Ifc2x3::IfcProductDefinitionShape* shape = new Ifc2x3::IfcProductDefinitionShape(0, 0, reps);
-+ Ifc2x3::IfcProductDefinitionShape* shape = new Ifc2x3::IfcProductDefinitionShape(boost::none, boost::none, reps);
- AddEntity(rep);
- AddEntity(shape);
- addBox(rep, w, d, h, place, place2, dir, context);