summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNahouhak2022-01-04 03:35:07 +0100
committerNahouhak2022-01-04 03:35:07 +0100
commit031f5af9eb1bf6870745b61e29a4654e42d3106e (patch)
treebb70e9da997c2275676b819ac3b6d336e325d331
parent1c40d305f3296d68ad0a3680e7f4df19f2514bed (diff)
downloadaur-031f5af9eb1bf6870745b61e29a4654e42d3106e.tar.gz
Fix regular expressions for blender/python version
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf373c2acd4a..e1abb1d8596e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ifcopenshell-git
pkgdesc = Open source IFC library and geometry engine. Provides static libraries, python3 wrapper and blender addon. GIT version.
- pkgver = 211203.r16.gee56e06d
+ pkgver = 220104.r0.g0625e415
pkgrel = 1
url = http://ifcopenshell.org/
arch = x86_64
@@ -33,10 +33,11 @@ pkgbase = ifcopenshell-git
optdepends = python-pyparsing: ifcexpressparser support
optdepends = python-requests: blender bim addon covetool support
optdepends = python-lark-parser: util, ifccsv, ifcclash support
- optdepends = python-odfpy: ifccobie support
+ optdepends = python-odfpy: blender bim addon and ifccobie support
optdepends = python-behave: python-bimtester
optdepends = python-isodate: blender bim addon
optdepends = python-olca-ipc: blender bim addon life cycle analysis support
+ optdepends = python-toposort: ifcpatch
provides = ifcopenshell
provides = blender-plugin-bim
provides = IfcConvert
diff --git a/PKGBUILD b/PKGBUILD
index 2b589337913d..551d1db289a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Cyril Waechter <cyril[at]biminsight[dot]ch>
# Contributor: mickele <mimocciola[at]yahoo[dot]com>
pkgname=(ifcopenshell-git blender-plugin-bim-git)
-pkgver=211203.r16.gee56e06d
+pkgver=220104.r0.g0625e415
pkgrel=1
pkgdesc="Open source IFC library and geometry engine. Provides static libraries, python3 wrapper and blender addon. GIT version."
arch=('x86_64' 'i686')
@@ -18,10 +18,11 @@ optdepends=('python-svgwrite: blender bim addon svg support'
'python-pyparsing: ifcexpressparser support'
'python-requests: blender bim addon covetool support'
'python-lark-parser: util, ifccsv, ifcclash support'
- 'python-odfpy: ifccobie support'
+ 'python-odfpy: blender bim addon and ifccobie support'
'python-behave: python-bimtester'
'python-isodate: blender bim addon'
- 'python-olca-ipc: blender bim addon life cycle analysis support')
+ 'python-olca-ipc: blender bim addon life cycle analysis support'
+ 'python-toposort: ifcpatch')
makedepends=('cmake' 'boost>=1.58.0' 'swig' 'python-babel')
provides=('ifcopenshell' 'blender-plugin-bim' 'IfcConvert' 'IfcGeomServer' 'python-ifcpatch' 'python-ifcdiff' 'python-bcf' 'python-bimtester' 'python-ifccsv')
conflicts=()
@@ -30,8 +31,8 @@ backup=()
source=("git+https://github.com/IfcOpenShell/IfcOpenShell.git"
"git+https://github.com/IfcOpenShell/svgfill.git"
"git+https://github.com/svgpp/svgpp.git")
-_blender_ver=$(blender --version | grep -Po 'Blender \K[0-9]\...')
-_python_ver=$(python --version | grep -Po 'Python \K[0-9]\..')
+_blender_ver=$(blender --version | grep -Po 'Blender \K[0-9].[0-9]+')
+_python_ver=$(python --version | grep -Po 'Python \K[0-9].[0-9]+')
prepare() {
cd "${srcdir}/IfcOpenShell"