summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNahouhak2023-09-24 21:40:02 +0200
committerNahouhak2023-09-24 21:40:02 +0200
commit1141b8a49cd37e462c3a3d16c3b85b04e96add73 (patch)
treedcbd19717d318a890f0cfc15dcf71a5b2a484cf6
parent8080d47aa1390fe61a2ef2ed13c1440ce3a149fe (diff)
downloadaur-1141b8a49cd37e462c3a3d16c3b85b04e96add73.tar.gz
Add bsdd
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 925ea3945880..ad1985b006cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ifcopenshell-git
pkgdesc = Open source IFC library and geometry engine. Provides static libraries, python3 wrapper and blender addon. GIT version.
- pkgver = 230410.r7.ge71ee988b
+ pkgver = 230922.r19.gbe2c7a62f
pkgrel = 1
url = http://ifcopenshell.org/
arch = x86_64
@@ -50,6 +50,7 @@ pkgbase = ifcopenshell-git
provides = python-bcf
provides = python-bimtester
provides = python-ifccsv
+ provides = python-bsdd
source = git+https://github.com/IfcOpenShell/IfcOpenShell.git
source = git+https://github.com/IfcOpenShell/svgfill.git
source = git+https://github.com/svgpp/svgpp.git
diff --git a/PKGBUILD b/PKGBUILD
index 467ada5e9ced..9e5e6c6d9135 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Cyril Waechter <cyril[at]biminsight[dot]ch>
# Contributor: mickele <mimocciola[at]yahoo[dot]com>
pkgname=(ifcopenshell-git blender-plugin-bim-git)
-pkgver=230410.r7.ge71ee988b
+pkgver=230922.r19.gbe2c7a62f
pkgrel=1
pkgdesc="Open source IFC library and geometry engine. Provides static libraries, python3 wrapper and blender addon. GIT version."
arch=('x86_64' 'i686')
@@ -27,7 +27,7 @@ optdepends=('python-svgwrite: blender bim addon svg support'
'python-brickschema: brickschema support'
'python-shapely>=2.0.1: blender bim addon space generation support')
makedepends=('cmake' 'boost>=1.58.0' 'swig' 'python-babel')
-provides=('ifcopenshell' 'blender-plugin-bim' 'IfcConvert' 'IfcGeomServer' 'python-ifcpatch' 'python-ifcdiff' 'python-bcf' 'python-bimtester' 'python-ifccsv')
+provides=('ifcopenshell' 'blender-plugin-bim' 'IfcConvert' 'IfcGeomServer' 'python-ifcpatch' 'python-ifcdiff' 'python-bcf' 'python-bimtester' 'python-ifccsv' 'python-bsdd')
conflicts=()
replaces=()
backup=()
@@ -111,6 +111,7 @@ package_ifcopenshell-git() {
cp -rf "${srcdir}/IfcOpenShell/src/ifcpatch" "./"
cp -rf "${srcdir}/IfcOpenShell/src/ifc4d/ifc4d" "./"
cp -rf "${srcdir}/IfcOpenShell/src/ifc5d/ifc5d" "./"
+ cp -rf "${srcdir}/IfcOpenShell/src/bsdd" "./"
pybabel compile -d "./bimtester/locale"
python -O -m compileall "./"
}