summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNahouhak2022-12-14 04:33:02 +0100
committerNahouhak2022-12-14 04:33:02 +0100
commit1235257889e12b438e65ab5e4150ed4fef79c0a7 (patch)
treedac42815ad37952f8cde7de5e2523d3d075f430a
parent60721d7cd55a2ea89709277db148cd62ef513fb9 (diff)
downloadaur-1235257889e12b438e65ab5e4150ed4fef79c0a7.tar.gz
Add brickschema support
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD39
2 files changed, 25 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b9483280c032..98ae83ae51a0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ifcopenshell-git
pkgdesc = Open source IFC library and geometry engine. Provides static libraries, python3 wrapper and blender addon. GIT version.
- pkgver = 221111.r6.g9dfd7e03f
+ pkgver = 221213.r0.g05cd11ae1
pkgrel = 1
url = http://ifcopenshell.org/
arch = x86_64
@@ -39,6 +39,7 @@ pkgbase = ifcopenshell-git
optdepends = python-olca-ipc: blender bim addon life cycle analysis support
optdepends = python-toposort: ifcpatch
optdepends = python-xsdata: blender bim addon
+ optdepends = python-brickschema: brickschema support
provides = ifcopenshell
provides = blender-plugin-bim
provides = IfcConvert
@@ -51,9 +52,11 @@ pkgbase = ifcopenshell-git
source = git+https://github.com/IfcOpenShell/IfcOpenShell.git
source = git+https://github.com/IfcOpenShell/svgfill.git
source = git+https://github.com/svgpp/svgpp.git
+ source = https://github.com/BrickSchema/Brick/releases/download/nightly/Brick.ttl
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
+ md5sums = 5a2d3512fb67f54afa695498f192f131
pkgname = ifcopenshell-git
diff --git a/PKGBUILD b/PKGBUILD
index 57e8a08577a3..5a14e8126d3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Cyril Waechter <cyril[at]biminsight[dot]ch>
# Contributor: mickele <mimocciola[at]yahoo[dot]com>
pkgname=(ifcopenshell-git blender-plugin-bim-git)
-pkgver=221111.r6.g9dfd7e03f
+pkgver=221213.r0.g05cd11ae1
pkgrel=1
pkgdesc="Open source IFC library and geometry engine. Provides static libraries, python3 wrapper and blender addon. GIT version."
arch=('x86_64' 'i686')
@@ -9,21 +9,22 @@ url="http://ifcopenshell.org/"
license=('LGPL3')
depends=('boost-libs>=1.58.0' 'opencascade' 'icu' 'opencollada' 'python' 'nlohmann-json' 'libxml2' 'hdf5' 'libaec' 'sz' 'cgal' 'gmp' 'mpfr')
optdepends=('python-svgwrite: blender bim addon svg support'
- 'python-occ-core: blender bim addon cut ifc support'
- 'python-pystache: blender bim addon'
- 'python-numpy: blender bim addon cut ifc support'
- 'python-xmlschema: blender bim addon, bcf support'
- 'hpp-fcl: ifcclash'
- 'python-deepdiff: ifcdiff'
- 'python-pyparsing: ifcexpressparser support'
- 'python-requests: blender bim addon covetool support'
- 'python-lark-parser: util, ifccsv, ifcclash support'
- 'python-odfpy: blender bim addon and ifccobie support'
- 'python-behave: python-bimtester'
- 'python-isodate: blender bim addon'
- 'python-olca-ipc: blender bim addon life cycle analysis support'
- 'python-toposort: ifcpatch'
- 'python-xsdata: blender bim addon')
+ 'python-occ-core: blender bim addon cut ifc support'
+ 'python-pystache: blender bim addon'
+ 'python-numpy: blender bim addon cut ifc support'
+ 'python-xmlschema: blender bim addon, bcf support'
+ 'hpp-fcl: ifcclash'
+ 'python-deepdiff: ifcdiff'
+ 'python-pyparsing: ifcexpressparser support'
+ 'python-requests: blender bim addon covetool support'
+ 'python-lark-parser: util, ifccsv, ifcclash support'
+ 'python-odfpy: blender bim addon and ifccobie support'
+ 'python-behave: python-bimtester'
+ 'python-isodate: blender bim addon'
+ 'python-olca-ipc: blender bim addon life cycle analysis support'
+ 'python-toposort: ifcpatch'
+ 'python-xsdata: blender bim addon'
+ 'python-brickschema: brickschema support')
makedepends=('cmake' 'boost>=1.58.0' 'swig' 'python-babel')
provides=('ifcopenshell' 'blender-plugin-bim' 'IfcConvert' 'IfcGeomServer' 'python-ifcpatch' 'python-ifcdiff' 'python-bcf' 'python-bimtester' 'python-ifccsv')
conflicts=()
@@ -31,7 +32,8 @@ replaces=()
backup=()
source=("git+https://github.com/IfcOpenShell/IfcOpenShell.git"
"git+https://github.com/IfcOpenShell/svgfill.git"
- "git+https://github.com/svgpp/svgpp.git")
+ "git+https://github.com/svgpp/svgpp.git"
+ "https://github.com/BrickSchema/Brick/releases/download/nightly/Brick.ttl")
_blender_ver=$(blender --version | grep -Po 'Blender \K[0-9].[0-9]+')
_python_ver=$(python --version | grep -Po 'Python \K[0-9].[0-9]+')
@@ -45,6 +47,7 @@ prepare() {
git config submodule.svgpp.url "${srcdir}/IfcOpenShell/src/svgfill/3rdparty/svgpp/"
git submodule update
sed -i 's/lib_ext a/lib_ext so/' ${srcdir}/IfcOpenShell/cmake/CMakeLists.txt
+ cp "${srcdir}/Brick.ttl" "${srcdir}/IfcOpenShell/src/blenderbim/blenderbim/bim/schema"
}
pkgver() {
@@ -113,4 +116,4 @@ package_blender-plugin-bim-git() {
chmod -R a+rwX "${pkgdir}/usr/share/blender/${_blender_ver}/scripts/addons/blenderbim/bim/data"
}
-md5sums=('SKIP' 'SKIP' 'SKIP')
+md5sums=('SKIP' 'SKIP' 'SKIP' '5a2d3512fb67f54afa695498f192f131')