summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNahouhak2021-05-19 08:45:26 +0200
committerNahouhak2021-05-19 08:45:26 +0200
commit386d667d27804b9b5260c9603356a8ca95ff10a0 (patch)
tree93a2b8566e038a4261326d1772b6bc0a1a0d181e
parentac470112fe9231fa573f40244d1fd782663e69e7 (diff)
downloadaur-386d667d27804b9b5260c9603356a8ca95ff10a0.tar.gz
Add dependency python-isodate
-rw-r--r--.SRCINFO49
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9af8c8f84922..c2b87dd9a5d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,51 +1,6 @@
pkgbase = ifcopenshell-git
pkgdesc = Open source IFC library and geometry engine. Provides static libraries, python3 wrapper and blender addon. GIT version.
- pkgver = 0.6.0b0.r1736.g92cb138c
- pkgrel = 1
- url = http://ifcopenshell.org/
- arch = x86_64
- arch = i686
- license = LGPL3
- makedepends = cmake
- makedepends = boost>=1.58.0
- makedepends = swig
- depends = boost-libs>=1.58.0
- depends = opencascade
- depends = icu
- depends = opencollada
- depends = python
- depends = nlohmann-json
- depends = libxml2
- optdepends = python-svgwrite: blender bim addon svg support
- optdepends = python-occ-core: blender bim addon cut ifc support
- optdepends = python-pystache: blender bim addon
- optdepends = python-numpy: blender bim addon cut ifc support
- optdepends = python-fcl: ifcclash
- optdepends = python-deepdiff: ifcdiff
- optdepends = python-pyparsing: ifcexpressparser support
- optdepends = python-requests: blender bim addon covetool support
- optdepends = python-lark-parser: util, ifccsv, ifcclash support
- optdepends = python-odfpy: ifccobie support
- optdepends = python-behave: python-bimtester
- provides = ifcopenshell
- provides = blender-plugin-bim
- provides = IfcConvert
- provides = IfcGeomServer
- provides = python-ifcpatch
- provides = python-ifcdiff
- provides = python-bcf
- provides = python-bimtester
- provides = python-ifccsv
- source = git+https://github.com/IfcOpenShell/IfcOpenShell.git
- md5sums = SKIP
-
-pkgname = ifcopenshell-git
-
-pkgname = blender-plugin-bim-git
-
-pkgbase = ifcopenshell-git
- pkgdesc = Open source IFC library and geometry engine. Provides static libraries, python3 wrapper and blender addon. GIT version.
- pkgver = 210329.r1.g44df1f67
+ pkgver = 210519.r1.g77a97233
pkgrel = 1
url = http://ifcopenshell.org/
arch = x86_64
@@ -65,6 +20,7 @@ pkgbase = ifcopenshell-git
optdepends = python-occ-core: blender bim addon cut ifc support
optdepends = python-pystache: blender bim addon
optdepends = python-numpy: blender bim addon cut ifc support
+ optdepends = python-xmlschema: blender bim addon, bcf support
optdepends = python-fcl: ifcclash
optdepends = python-deepdiff: ifcdiff
optdepends = python-pyparsing: ifcexpressparser support
@@ -72,6 +28,7 @@ pkgbase = ifcopenshell-git
optdepends = python-lark-parser: util, ifccsv, ifcclash support
optdepends = python-odfpy: ifccobie support
optdepends = python-behave: python-bimtester
+ optdepends = python-isodate: blender bim addon
provides = ifcopenshell
provides = blender-plugin-bim
provides = IfcConvert
diff --git a/PKGBUILD b/PKGBUILD
index 8c323a5b6b19..7caa90b7a990 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Cyril Waechter <cyril[at]biminsight[dot]ch>
# Contributor: mickele <mimocciola[at]yahoo[dot]com>
pkgname=(ifcopenshell-git blender-plugin-bim-git)
-pkgver=210329.r1.g44df1f67
+pkgver=210519.r1.g77a97233
pkgrel=1
pkgdesc="Open source IFC library and geometry engine. Provides static libraries, python3 wrapper and blender addon. GIT version."
arch=('x86_64' 'i686')
@@ -12,13 +12,15 @@ optdepends=('python-svgwrite: blender bim addon svg support'
'python-occ-core: blender bim addon cut ifc support'
'python-pystache: blender bim addon'
'python-numpy: blender bim addon cut ifc support'
+ 'python-xmlschema: blender bim addon, bcf support'
'python-fcl: ifcclash'
'python-deepdiff: ifcdiff'
'python-pyparsing: ifcexpressparser support'
'python-requests: blender bim addon covetool support'
'python-lark-parser: util, ifccsv, ifcclash support'
'python-odfpy: ifccobie support'
- 'python-behave: python-bimtester')
+ 'python-behave: python-bimtester'
+ 'python-isodate: blender bim addon')
makedepends=('cmake' 'boost>=1.58.0' 'swig')
provides=('ifcopenshell' 'blender-plugin-bim' 'IfcConvert' 'IfcGeomServer' 'python-ifcpatch' 'python-ifcdiff' 'python-bcf' 'python-bimtester' 'python-ifccsv')
conflicts=()